Kodi Community Forum

Full Version: TIDAL music (former WiMP)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
(2021-09-01, 19:54)C.O.D. Wrote: [ -> ]
(2021-08-28, 12:49)mazeeff Wrote: [ -> ]
(2021-08-28, 11:51)C.O.D. Wrote: [ -> ]Hey @arneson,
Titel- and Artist-Radio doesn't show any list items anymore for a few days now.
Maybe you can have a look into this?

Best regards

I just tried both Artist Radio and Track Radio, and they both work fine, on a Windows 10 PC. Those are the two main features, that I use everyday!
So what can I say? My lists are empty and it happened from one day to another...
Hi C.O.D.

TIDAL changes the api for the mix items.
I allready get it working in my development environment. Please be patient, I'm very busy at work these days ;-)

arneson
Hi everybody,

I fixed my TIDAL2 addon for the mix item api changes.
And I also removed the music info part from video items so videos will start in fullscreen mode now (in Kodi Matrix).

You can find the updated version V2.0.3 in my TIDAL2 repository on github

I read in the release notes of the TIDAL web player that lyrics are available golbally.
Now I try to develop a "TIDAL2 Lyrics Addon" from a copy of the CU LRC Lyrics addon, because this addon can't display emmbedded lyrics from internet streams.

arneson
(2021-09-04, 18:32)arneson Wrote: [ -> ]Hi everybody,

I fixed my TIDAL2 addon for the mix item api changes.
And I also removed the music info part from video items so videos will start in fullscreen mode now (in Kodi Matrix).

You can find the updated version V2.0.3 in my TIDAL2 repository on github

I read in the release notes of the TIDAL web player that lyrics are available golbally.
Now I try to develop a "TIDAL2 Lyrics Addon" from a copy of the CU LRC Lyrics addon, because this addon can't display emmbedded lyrics from internet streams.

arneson
Thanks for the quick fix. Your Tidal app was automatically updated, when I opened Kodi. Could not have been any simpler! Thanks. Listening to my Mix 1!
The BEST One, as always!
Thanks a LLLooooTTT !
@arneson, you are my hero! Rofl
(2021-09-04, 18:32)arneson Wrote: [ -> ]You can find the updated version V2.0.3 in my TIDAL2 repository on github
Hi @arneson ,

I am unable to login to my Tidal account. I updated to your latest version 2.03. (leia). I contacted Tidal to ask if they could provide me with the login log. They refer back to you saying that "TIDAL has processed security changes to the login authentication, all third parties do have to process these changes on their own interface. Since TIDAL does not have access to third-party software we cannot make the changes directly." Can you help?

Kind regards, Berend Raap
(2021-09-14, 15:56)hifiBerend Wrote: [ -> ]
(2021-09-04, 18:32)arneson Wrote: [ -> ]You can find the updated version V2.0.3 in my TIDAL2 repository on github
Hi @arneson ,

I am unable to login to my Tidal account. I updated to your latest version 2.03. (leia). I contacted Tidal to ask if they could provide me with the login log. They refer back to you saying that "TIDAL has processed security changes to the login authentication, all third parties do have to process these changes on their own interface. Since TIDAL does not have access to third-party software we cannot make the changes directly." Can you help?

Kind regards, Berend Raap
Hi Berend,

did you use the right version from the "until-leia" branch from my repository ?
The version from the "main" is for Kodi Matrix !
(2021-09-15, 19:25)arneson Wrote: [ -> ]
(2021-09-14, 15:56)hifiBerend Wrote: [ -> ]
(2021-09-04, 18:32)arneson Wrote: [ -> ]You can find the updated version V2.0.3 in my TIDAL2 repository on github
Hi @arneson ,

I am unable to login to my Tidal account. I updated to your latest version 2.03. (leia). I contacted Tidal to ask if they could provide me with the login log. They refer back to you saying that "TIDAL has processed security changes to the login authentication, all third parties do have to process these changes on their own interface. Since TIDAL does not have access to third-party software we cannot make the changes directly." Can you help?

Kind regards, Berend Raap
Hi Berend,

did you use the right version from the "until-leia" branch from my repository ?
The version from the "main" is for Kodi Matrix !
Hi Arneson,

Yes I did choose the untill Leia branch. Log file says:

2021-09-14 17:39:09.299 T:1658401664   ERROR: [TIDAL2] Failed to retrieve Preview-Token
2021-09-14 17:39:12.196 T:1807721344 WARNING: COMXImageFile::GetCodingType progressive images not supported by decoder
2021-09-14 17:39:12.199 T:1807721344 WARNING: Previous line repeats 1 times.
2021-09-14 17:39:12.205 T:1807721344  NOTICE: LoadJpeg: unable to load /storage/.kodi/addons/plugin.audio.tidal2/fanart.jpg
2021-09-14 17:39:15.707 T:1658401664   ERROR: [TIDAL2] Failed to retrieve Preview-Token
2021-09-14 17:39:16.108 T:1658401664   ERROR: [TIDAL2] <Response [401]> <Response [401]>
2021-09-14 17:39:16.108 T:1658401664   ERROR: [TIDAL2] Login failed !
                                            401 Client Error: Unauthorized for url: https://auth.tidal.com/v1/oauth2/device_authorization

Kind regards, Berend.
(2021-09-15, 20:20)hifiBerend Wrote: [ -> ]
(2021-09-15, 19:25)arneson Wrote: [ -> ]
(2021-09-14, 15:56)hifiBerend Wrote: [ -> ]Hi @arneson ,

I am unable to login to my Tidal account. I updated to your latest version 2.03. (leia). I contacted Tidal to ask if they could provide me with the login log. They refer back to you saying that "TIDAL has processed security changes to the login authentication, all third parties do have to process these changes on their own interface. Since TIDAL does not have access to third-party software we cannot make the changes directly." Can you help?

Kind regards, Berend Raap
Hi Berend,

did you use the right version from the "until-leia" branch from my repository ?
The version from the "main" is for Kodi Matrix !
@arneson  Yes I did use the Leia branch
(2021-09-15, 20:20)hifiBerend Wrote: [ -> ]
(2021-09-15, 19:25)arneson Wrote: [ -> ]
(2021-09-14, 15:56)hifiBerend Wrote: [ -> ]Hi @arneson ,

I am unable to login to my Tidal account. I updated to your latest version 2.03. (leia). I contacted Tidal to ask if they could provide me with the login log. They refer back to you saying that "TIDAL has processed security changes to the login authentication, all third parties do have to process these changes on their own interface. Since TIDAL does not have access to third-party software we cannot make the changes directly." Can you help?

Kind regards, Berend Raap
Hi Berend,

did you use the right version from the "until-leia" branch from my repository ?
The version from the "main" is for Kodi Matrix !
@arneson Could you please assist me in this. I am sure I have the right version of your addon and I am sure I h ave the right credentials as I can lofin to Tidal from web.
LibreElec 10.0.0, Tidal 2.0.3, SMSL SU 9

Anyone noticed if MQA stopped working (again)?

Not sure when, but some time in the past 3 months I think. Prior to that, it was working fine.

I tried upgrading LibreElec from 9.x to 10.0 but that didn't fix it. With the upgrade I did a fresh installation - no dice.

If I take out the USB cable and plug it into my Windows laptop, Tidal MQA works fine so I know it's not a DAC / Amp issue. (And I know my accounts fine.)

Obvs the plugin itself is set to MQA.

Wondering if a new Client ID is needed? Other than that I can't think what's changed as I don't fiddle with the setup once it's working.
Hi @arneson ,

I did a complete new install of Lebreelec 18.9. Then, without doing anything else, I installed your TIDAL2 plugin from your Git (https://github.com/arnesongit/repository...-2.0.3.zip) Then I tried to connect to Tidal again with the same result. I am 100% sure my credentials are OK. What can I do now?

Kind regards, Berend Raap
(2021-10-20, 14:49)hifiBerend Wrote: [ -> ]Hi @arneson ,

I did a complete new install of Lebreelec 18.9. Then, without doing anything else, I installed your TIDAL2 plugin from your Git (https://github.com/arnesongit/repository...-2.0.3.zip) Then I tried to connect to Tidal again with the same result. I am 100% sure my credentials are OK. What can I do now?

Kind regards, Berend Raap
Then I removed the plugin again and tried to install from the repository ( repository.tidal2-0.1.0.zip) . Same again. "Login failed" I did set the quality to high and video to 720. Error is again: "Failed to retrieve Preview-Token"
(2021-10-20, 14:49)hifiBerend Wrote: [ -> ]Hi @arneson ,

I did a complete new install of Lebreelec 18.9. Then, without doing anything else, I installed your TIDAL2 plugin from your Git (https://github.com/arnesongit/repository...-2.0.3.zip) Then I tried to connect to Tidal again with the same result. I am 100% sure my credentials are OK. What can I do now?

Kind regards, Berend Raap
Sorry I mean Libreelec 9.2.8
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45