Kodi Community Forum

Full Version: [Module] youtube-dl - multi-site playable URL resolver
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
First, thank you very much @ruuk for the update.

I'm working with the current version of youtube dl and I have a problem streaming a youtube video. The video is showing very well but there is no sound.
I have checked the settings and it's seem to be all fine. The code that I'm running search a video in Youtube and show the list items with the results. When you select a item you call back the plugin to
run the YDStreamExtractor to get the stream URL and run setResolvedUrl() function to play the content.

The main code is:
Code:
#
# Main code
#
if sys.argv[2] == "":
    # Search form to get Youtube ID
    ventana = VentanaBusqueda()
    ventana.doModal()
else:
    # Playing selected item
    idVideo = "http://www.youtube.com/watch?v=%s" % (sys.argv[2][1:])
    vid = YDStreamExtractor.getVideoInfo(idVideo, quality=0)
    item = xbmcgui.ListItem(path=vid.streamURL())
    xbmcplugin.setResolvedUrl(int(sys.argv[1]), True, item)

With this code the video is show perfect but without sound. What could be the issue?

Thanks
(2017-04-23, 00:42)ruuk Wrote: [ -> ]Until recently it was not possible to play MPEG-DASH streams on Kodi. The addon does not yet support this and YouTube videos over 720p are MPEG-DASH only. If you limit to 720p you shouldn't have this issue.
(2017-05-23, 17:24)ruuk Wrote: [ -> ]
(2017-04-23, 00:42)ruuk Wrote: [ -> ]Until recently it was not possible to play MPEG-DASH streams on Kodi. The addon does not yet support this and YouTube videos over 720p are MPEG-DASH only. If you limit to 720p you shouldn't have this issue.

Setting quality to 1 (720p) result in the same issue. Undecided
(2017-05-23, 18:49)SSalvatella Wrote: [ -> ]
(2017-05-23, 17:24)ruuk Wrote: [ -> ]
(2017-04-23, 00:42)ruuk Wrote: [ -> ]Until recently it was not possible to play MPEG-DASH streams on Kodi. The addon does not yet support this and YouTube videos over 720p are MPEG-DASH only. If you limit to 720p you shouldn't have this issue.

Setting quality to 1 (720p) result in the same issue. Undecided
It could be that for this video 720p is also DASH only. Try putting this in your code.

YDStreamExtractor.disableDASHVideo(True)
(2017-05-23, 19:30)ruuk Wrote: [ -> ]
(2017-05-23, 18:49)SSalvatella Wrote: [ -> ]
(2017-05-23, 17:24)ruuk Wrote: [ -> ]

Setting quality to 1 (720p) result in the same issue. Undecided
It could be that for this video 720p is also DASH only. Try putting this in your code.

YDStreamExtractor.disableDASHVideo(True)

Thanks for the sugestions but it still not working...
Maybe is something from Kodi? Huh
Well, ultimately it's Kodi that is failing to play the sound assuming the stream URL we're pointing it to has sound Smile
The video ID that i'm trying to see is SGyOaCXr8Lw (https://www.youtube.com/watch?v=SGyOaCXr8Lw).

I put the complete code in case it could help : https://gist.github.com/ssalvatella/7960...cd496e6566
Version 17.518.1

Changes:
  • Added setting 'Skip Videos Without Audio' to force choosing videos with audio

On Kodi repo, pending mirror updates.
@SSalvatella: The latest version should fix your issue. It appears some streams now have no audio and also don't mention DASH in their info so I added the setting to skip these which defaults to True.
(2017-05-25, 04:02)ruuk Wrote: [ -> ]@SSalvatella: The latest version should fix your issue. It appears some streams now have no audio and also don't mention DASH in their info so I added the setting to skip these which defaults to True.

Thanks! Now it works. You are awesome!
I use this addon a lot, but sometimes my internet connection drops and it stays stuck indicates downloading.

Can you add an option to remove stuck downloads due to internet connection loss ?
Auto resume or timeout setting.

Re-adding doesn't restart downloading, only working option I found was reboot.
(2017-07-03, 12:06)PiMONSTER Wrote: [ -> ]I use this addon a lot, but sometimes my internet connection drops and it stays stuck indicates downloading.

Can you add an option to remove stuck downloads due to internet connection loss ?
Auto resume or timeout setting.

Re-adding doesn't restart downloading, only working option I found was reboot.
There's probably an error when this happens. A log when this happens would be helpful.
@ruuk Mayby you can update the youtube-dl again.
I use youtube-dl for my new dailymtion addon.
Since some changes it stoped working. I tried to replace script.module.youtube.dl\lib\youtube_dl witth the new Version from "youtube-dl version 2017.07.09"
it has worked for Dailymtion.
I if helps i could make an PR, buit i havnt tested all Funtkions
(2017-07-09, 23:37)L0RE Wrote: [ -> ]@ruuk Mayby you can update the youtube-dl again.
I use youtube-dl for my new dailymtion addon.
Since some changes it stoped working. I tried to replace script.module.youtube.dl\lib\youtube_dl witth the new Version from "youtube-dl version 2017.07.09"
it has worked for Dailymtion.
I if helps i could make an PR, buit i havnt tested all Funtkions
I'll update today or tomorrow
Version 17.709.0

Changes:
  • Updated youtube-dl core to 2017.07.09

On Kodi repo, pending mirror updates.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21