Kodi Community Forum

Full Version: XBMCbuntu and windows 7 dualboot
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, on my intel NUC I've installed XBMCbuntu and windows 7 as a dualboot by GRUB. Everything booting fine, but always I have to chose system in grub menu. It won't start automatic always wait until press enter choosing proper system to boot.

this is my grub config:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=3
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_GFXPAYLOAD_LINUX=keep
Have you, from Linux, run sudo update-grub ?
Yes, /boot/grub/grub.cnf is changing but still no effect after reboot Sad
You're editing /etc/default/grub right?
Also tried reinstalling grub with upgrade-grub-from-legacy (note that command is from memory, typing update into the command prompt then pressing tab should give you the exact name)
yes, I'm editing /etc/default/grub
after it sudo update-grub and reboot - not working
my grub ver. is 2.02

is upgrade-grub-from-legacy command reinstall grub2 to grub?
Its for upgrading grub but it will also reinstall it.

Bit of a silly question, but I have seen similar behaviour after unclean shutdowns, you're not hard rebooting or anything like that?
After unclean shutdown (ones) few lines appeared on the end of the grub file, but I clean it. Is the same situation (stop on grub menu) no matter if I reboot system or turn system off and then on.
Hmmm.. Strange... Everything looks like it should, but I'll post my working config file when I get home for comparison.

Though, a stab I'm the dark, tried commenting out the grub-timeout line? From memory grub defaults to 10seconds. Or try using grub_hidden_timeout instead.

EDIT Are there any errors when running update-grub?
I'm noob in linux matter, so I first read everything from the net about grub2 (and grub2 reinstall) and I didn't run update yet. I'll change to hidden and try.
Here is mine, after a quick comparison I cant see anything out of place in yours, but it might give you some ideas of what to try.
http://paste.ubuntu.com/7985023/

Note its a bit of a mess because Ive been (unsuccessfully) trying to get a splash screen to show and the menu to stay hidden unless I press shift.

Also some other options are to run 'grub boot-repair' or 'grub-customizer'

Oh and if you do get it sorted check out the reboot2oos add-on in my sig, it make booting between OS's easy.
solved - I had mounted two partition with /boot, and proper one was covered by the unused one. Thanks for your help Smile
Hello,

I'd like to install XBMC and Windows 7 on my NUC and I was wondering if you could give me a clue how I go about it.

Thank you in advance Smile