Kodi Community Forum

Full Version: CDVDMessageQueue:Get - asked for new data packet, with nothing available
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am posted this to help others that may have somewhat of the same problem.

For the last couple weeks I have been experiencing stuttering and freezes momentarily while using XBMC. I have been an avid supporter of the platform for years with absolutely no hiccups until last week. I had figured the stuttering and freezing was from me upgrading from 13 to 13.2, and started to investigate the cause of the problem. But before I get into that part a little background on my set up.
I run a small business from home with an attached office for customers to walk in. The office is running 5 hardwire network computers, with 2 of those having an install of XBMC, for the times I am slow at work. 1 of the computers is my NAS, that runs 24/7 and can be accessed from anywhere. In my home I have 3 hardwired computers and 1 wireless computer, all running XBMC. My network consists of a business class cable modem, a wireless router with 4 ports hardwired, a 8 port patch panel, a 8 port switch and a 4 port switch, all 10/100/1000 capable. My LAN speeds have always been great. So as you can see my network is vast and I haven't taken into account the numerous iPhones, tablets, smart TV's and networked avr's that connect to the network either hardwired or wireless. This in a nutshell is my set up and I am not posting this to brag or show off but to help you understand that through all this, my installs of XBMC for years has been flawless. So onto the stuttering and freezing.

The stuttering seem to start after I upgraded to 13.2, so naturally I uninstalled 13.2 and installed my old 13 back. I had made a back up of my userdata folder, so thought all would be good. Fired up XBMC and started to watch a show, after about 5 minutes into it , again the stuttering. I turned on debugging, which by the way I never had to do since I started using XBMC 6 years ago (a big thumbs up to the DEVs for this Love ), to help isolate the cause. What I found in the log file was
WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
I then went onto this forum to do some searching and found many threads with the same message, but really without a clear answer. Off to google and found the same results, but from other forums on the net. Starting reading and looking at remedies for a fix.

1) Make sure all drivers are up to date.
Checked my system and installed new graphic, audio, and network drivers. Start XBMC and problem still exists. So now I am thinking that maybe my old usedata folder has something to do with the problem, since I have all new drivers. Uninstall my XBMC along with the userdata folder. That was hard to do since I have over 24TB worth of stuff to rescan into XBMC. Install 13.2 again, but only scan in 1 mkv to the fresh install. Same problem, down grade again with a fresh install of 13.1, same problem, then down to 12.3, same problem. Now by this time I am getting pretty frustrated.Confused Off to google again.

2)Maybe a conflict with other programs that have been installed.
Since my main install is in my living room I have very few programs on it but I did install a few new programs that seemed to correspond to around the time the stuttering started to happen. I uninstalled 2 programs. And started XBMC. This did not cure the stuttering, only made it worse. Now I am really fed up and thinking I may need to install plex or mb3 or Jriver. I am steaming and tired. I think to myself uninstall the graphics driver, the audio, network driver and XBMC. Do a shutdown and boot to bios and check the system out there. Booted to bios and all values had not been changed since building the cpu. Good, boot to windows and load all new drivers along with another install of XBMC. Nothing changed, only my disposition. Go into office and fire XBMC up on a computer and runs fine. Grab my tablet and start XBMC and runs fine. Come back onto this forum and search around again.

3)Set up a advancedsetting.xml file
I never need to use an advancedsettings.xml for XBMC but thought "Why not". Created the file with this setting
and stuck it into my userdata folder. Started XBMC and thought it was good until about 10 minutes into a movie and BAM..stutter, stutter.

4) Set the NIC to Jumbo frames.
Set my network adapter to 4KB MTU value from the default of off. Restart computer and XBMC and same stutter.

5) The Real Problem
Now this has me thinking. I open media player classic and play a video from my computer, plays great. I play another video through my network and it freezes. Hmmm. now we are getting some where. I open XBMC and play a video on my computer runs fine, network stutters. Now I am thinking it is not XBMC that is the fault but something in my network. I run a speed test and all is really good. I transfer a 1 gig file through the LAN and seems to be slower than normal. Ok after work I will restart the whole network. I wait til after 8pm and go into the office and unplug the cable modem, the router and all the switches, wait 15 minutes and plug them all back in with this order , the cable modem, wait for all lights to light up, then the router, wait for all lights to light up, then onto to switches. Go back into the house and start computer, check to see if I have internet and LAN. Check, start XBMC and get the same stutter but only after 30 minutes of play. Start Media Player Classic and stutter is there also through the LAN. Now I am finally seeing a problem but o narrow it down further I need more testing. I bring my nuc into the living room ad hook it up. Start XBMC and it also stutters, so I now know it has nothing to do with my computer. I take the nuc to the bedroom and run it there. No stutter there. The bedroom hardwire goes straight to the switch in the office. So this has me thinking that the switch in the living room is bad. I unplug the switch in the living room and unplug the avr, tv and computer and turn it off. I plug the computer cable in and start it back up. Same stutter. I go back into the bedroom and play another video on XBMC but leave this on for 30 minutes and it too starts to stutter. Now I have narrowed down the problem to the switch in the office. This morning I replaced the switch with my old 16 port netgear switch,10/100, and restarted the whole network once again. Came into the house and watched 1 hour of a movie on XBMC without a stutter. So this looks like I will be replacing all the switches and I haven't ruled out the router with new ones.

6) Conclusion
So after 3 days and too many hours and restarts, I feel pretty confident about the results. Bottom line is this check your network before going through all the headaches I did if you see the same error message in your XBMC log.
Side note: Since I never needed a log file I never knew my denon 4311 wasn't accepting DD+, even though it states it should.

I hope this will help others with the same problem and save you some time in repairing it.
Just an update on this.
Today bought a new router and have been watching 5 straight hours without and stutter or buffering going on. Even though the old router was working, in so much as I ran speed tests and all tests came back above my rated ISP throttle, the connection passed to the LAN was suffering. Now my LAN speed are back to normal with over 100MB/s.
Harro, I know you posted this a while back but it's exactly what has been happening to me for the last few days. I've been going through the same troubleshooting that you started with, coming up empty each time but having read this posting I've just changed out my gigarouter and the issue is solved.

Thanks for sharing!