Kodi Community Forum

Full Version: XBMC hidden file duplicates
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My library suddenly went to poops on me. I have all my media stored on an external hd which I connect to my macbook pro that I run Kodi off of. Now the problem is that for the majority of my TV show episodes and movies, somehow the tv shows and movies have created 4kB duplicates with the same directory and file names and my library now shows duplicates. However, the duplicate files are only visible in the file directory using the Kodi file manager. When I actually go through my external hd (either through finder or terminal) even with hidden files shown, these duplicates are no where to be found so I can't delete them. I could delete them through the Kodi file manager but I would have to do it one by one and that isn't an option with thousands of files. Does anyone have a solution to this?

I've tried cleaning the library, rebuilding the library, verifying and repairing the external hd, even deleting a couple of those duplicated 4kBs to make sure that was the problem, and it is. I just need a quick way to delete all of them or a better solution

Image

Image
(2014-09-14, 03:55)Ned Scott Wrote: [ -> ]Mac_FAQ#Appledouble (wiki)

That was handy in explaining what was wrong but the ghost files still aren't visible on my external hd. Every other hidden file is there except the ones that I need to delete...
found the solution!
found a terminal command that deleted all the ghost files

dot_clean --keep=dotbar /Volumes/mounted_smb_volume

http://superuser.com/questions/306108/disable-creation-of-appledouble-files-on-mac-os-x
After I upgraded to Kodi, I have the same problem now.
Is it possible that Gotham ignored those files? I never had duplicates in my database when I used xbmc 13.xx.

IMHO, the link posted above is not a solution; its more a workaround.
I dont want do scan my NAS every day to delete files that macOS created.

Wouldn't it be simpler to tell KODI to ignore those files?
Can someone give me a hint how to do it?

bye
Tell MacOS to not create those files.
By using the command "defaults write com.apple.desktopservices DSDontWriteNetworkStores true", you can tell MacOS not to create the ".DS_Store" files, but there is no way to prevent mac from creating ".AppleDouble" files.

Everytime a mac access a non-HFS drive, those files will be created.
The only thing you can do is to automatically run a cron job to delete those files (or use e.g. BlueHarvest to do this for you)

Maybe someone could add this to the wiki. Lots of users seem to have problem with appledouble files, and 99% of all answers are wrong / missleading.

bye

Update:

There was definately a change between Gotham 13.xx and Helix 14.xx

Gotham ignores those appledouble-Files, Helix adds them to the library. This is 100% reproducable.
Adding the following in the advancedsettings.xml worked for me.

Regexp to ignore ._filename.ext and .AppleDouble files:

<advancedsettings>
<video>
<excludefromscan action="append">
<regexp>[\\/]\.\_</regexp>
<regexp>\.AppleDouble</regexp>
</excludefromscan>
<excludetvshowsfromscan action="append">
<regexp>[\\/]\.\_</regexp>
<regexp>\.AppleDouble</regexp>
</excludetvshowsfromscan>
</video>
</advancedsettings>
Hello everyone

I find the solution, after a long time. You've just to configure xmbc to not display the hidden folder and files. And when you scan again (before, you have to delete the previous links), it will not duplicate each files.

Bye
for removing duplicate files from your computer use "duplicatefilesdeleter" software