Kodi Community Forum

Full Version: QUARTZ - Gotham
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
pecinko Wrote:Here you go - I suppose this will be the last beta and future releases will be pushed through repository.

Quartz 3.0.4

- Added DVD dialog
- Selectable Quit button behavior
- Fixed borked screen with Trailers (thanks Baswazz)
- Fixed missing icon for pictures (thanks Peter911)
- Both Music&Video OSDs de-cluttered - big timeSmile
- some cosmetics
- Added stronger font alternative (selectable from appearance setting)

I have problems when I play music. Don't know if this appeared now after the new version. I can't consistently go to the OSD, and no buttons will stop the music... Sometimes the OSD shows, but mostly I just see the equalizer visualization. I use XBCM on ATV2.
Thats fast i go try it Smile
dynaflash Wrote:Installing on 3 boxes right now ... Pecinko: what exactly do you want us be be looking for and testing over 3.0.3 ? This way we can target your changes.

Mostly that everything's fine with add-ons and that new OSDs work as expected.
bthusby Wrote:I have problems when I play music. Don't know if this appeared now after the new version. I can't consistently go to the OSD, and no buttons will stop the music... Sometimes the OSD shows, but mostly I just see the equalizer visualization. I use XBCM on ATV2.

Just tried with ATV2 on beta2 and everything seems fine? Anyone else having problem?

I'm not sure if it's my custom keymap.xml or is the default done differently than movies but:

hold select (middle button) for OSD
hold menu to stop
short menu to jump out and leave music in background
Fantastic! My initial impressions on Quartz 3.0.4 are below. I addressed the areas that I use in my use case scenario. Where I don't currently use improvements you listed, I simply omitted them.

pecinko Wrote:- Added DVD dialog
Perfect .. out of the way but very simple and functional .. both on MBP as well as the AppleTV 1 with a usb dvd drive attached. Perfect imo.
pecinko Wrote:- Selectable Quit button behavior
Works as advertised in my testing on my MBP ( atv 1 with linux its not the skins fault, there is no way for xbmc to shut it down or reboot it or even quit xbmc in a resonable way (this is verified as per davilla and as I said, not the sking nor xbmc's fault)).

pecinko Wrote:- Both Music&Video OSDs de-cluttered - big timeSmile
I like it ! Advanced (Read: not always used) functions are easily noted in the apparent and obvious "Gear" icon on the far right, with a very nice overlay if you choose it so you can access them. Great!

Summary: Unless someone finds something broken or what not ... imo this is indeed the best Quartz yet and is extremely stable (as actually imo 3.0.3 was). I could digress on where I have been and what I have done to find the perfect skin to be very user friendly ( ala a more or less atv-like interface) in an effort to make xbmc more like say ... atv os or plex to the end user. Imo it has not been done *ever* until now. The best part is .. in general Q3 does not limit the user and in fact allows for almost all customization in a friendly, non- geek manner in which the average user can understand. Its been a very long road for you I know ... but it is bearing great fruit! But, once again thats just my .02 Wink
pecinko Wrote:Just tried with ATV2 on beta2 and everything seems fine? Anyone else having problem?

I'm not sure if it's my custom keymap.xml or is the default done differently than movies but:

hold select (middle button) for OSD
hold menu to stop
short menu to jump out and leave music in background

Well, on atv 1 using xbmc beta 3 ... everything works fine here on music OSD as well.
dynaflash Wrote:Summary: Unless someone finds something broken or what not ... imo this is indeed the best Quartz yet and is extremely stable (as actually imo 3.0.3 was). I could digress on where I have been and what I have done to find the perfect skin to be very user friendly ( ala a more or less atv-like interface) in an effort to make xbmc more like say ... atv os or plex to the end user. Imo it has not been done *ever* until now. The best part is .. in general Q3 does not limit the user and in fact allows for almost all customization in a friendly, non- geek manner in which the average user can understand. Its been a very long road for you I know ... but it is bearing great fruit! But, once again thats just my .02 Wink

Many thanks for this. I'm really glad that there are users that do recognize and appreciate the effort put in. It is indeed very hard to bring Apple philosophy into XBMC world (and the looks being the least problem).
pecinko Wrote:Just tried with ATV2 on beta2 and everything seems fine? Anyone else having problem?

I'm not sure if it's my custom keymap.xml or is the default done differently than movies but:

hold select (middle button) for OSD
hold menu to stop
short menu to jump out and leave music in background

Sorry, you're right. I panicked and forgot to hold the buttonsSmile

Another thing, when I start a song sometimes in the songlist, the new cool playing-screen doesn't show. It just stays in the song list and song is playing. I would prefer your new playing-screen when song starts playing.

And when the playing-screen actually shows, I see it for a brief moment, and the equalizer visualization takes over. Is this intended?
Hmm, hold the phone ... i am getting some strange stuff when I go to the music osd ... it does work, but doesn't scale to my screen!? Let me see if I can get a screenshot of what I am seeing ...
bthusby Wrote:Sorry, you're right. I panicked and forgot to hold the buttonsSmile

Another thing, when I start a song sometimes in the songlist, the new cool playing-screen doesn't show. It just stays in the song list and song is playing. I would prefer your new playing-screen when song starts playing.

And when the playing-screen actually shows, I see it for a brief moment, and the equalizer visualization takes over. Is this intended?

When you start music XBMC default action is to play it in background. You have to use TAB on your keyboard or "playing" button in view options to go to fullscreen.

As for the second you use I on keyboard to switch modes between Info, info only when music starts and info off (info being album art and stuff). Don't know how to toggle this with remote but if you disable visualization you'll get info screen always on.
Okay ... so here is what happens on the atv 1 on my panasonic 50" display (please excuse the crappy camera work, was in a hurry but should illustrate the issue I think I am seeing) ...

Play some music and hit the osd on remote ... here is what it looks like ... notice the cutoff on the bottom (note, this does not happen for movies):

http://dynaflashtech.net/downloads/scree...ic_osd.jpg

so then .. quit the music and go back to the home screen .... note the very bottom ...

http://dynaflashtech.net/downloads/scree...screen.jpg

Then going back to movies in the list view I get this kinda weird deal on the selected button ...

http://dynaflashtech.net/downloads/scree...3_list.jpg

now, not sure but I did not have this on the Q 3.0.3 skin ?

Also apparently it only happens when I do the music osd.
if I stay in video it seems fine.

Thoughts ?
dynaflash Wrote:Okay ... so here is what happens on the atv 1 on my panasonic 50" display (please excuse the crappy camera work, was in a hurry but should illustrate the issue I think I am seeing) ...

Play some music and hit the osd on remote ... here is what it looks like ... notice the cutoff on the bottom (note, this does not happen for movies):

http://dynaflashtech.net/downloads/scree...ic_osd.jpg

so then .. quit the music and go back to the home screen .... note the very bottom ...

http://dynaflashtech.net/downloads/scree...screen.jpg

Then going back to movies in the list view I get this kinda weird deal on the selected button ...

http://dynaflashtech.net/downloads/scree...3_list.jpg

now, not sure but I did not have this on the Q 3.0.3 skin ?

Also apparently it only happens when I do the music osd.
if I stay in video it seems fine.

Thoughts ?

Looks like XBMC bug to me, that somehow triggers in music visualization. I'll rework music options to be similar to video and we'll see if this helps.
pecinko Wrote:Looks like XBMC bug to me, that somehow triggers in music visualization. I'll rework music options to be similar to video and we'll see if this helps.

Hmm, well might be. Would it help if I turn off visualizations and see if it still does it ?
Okay same exact visualisation on my MacBook Pro ... I do not see the same issue. Strange. Maybe the overscan settings on the atv 1 on the panasonic tv ?

Everything else is equal as far as xbmc rev, Q 3.0.4 and library.

Edit: Q 3.0.4
dynaflash Wrote:Okay same exact visualisation on my MacBook Pro ... I do not see the same issue. Strange. Maybe the overscan settings on the atv 1 on the panasonic tv ?

Everything else is equal as far as xbmc rev, Q 3.0.4 and library.

Edit: Q 3.0.4

We can only guess. The fact is skin engine is not the same (XBMC does not behave the same) on all platforms. Remember that strange glitch on home screen on ATV1?

I believe I can work around this.