Kodi Community Forum

Full Version: Advanced launcher N64 and Snes Emulator Issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello. I am having some hard problems with emulators getting them to work like they should work.

the first issue I have is with the latest version of Zsnes. When I putt the settings of this emulator, into launch at fullscreen, and when i launch the Rom inside xbmc it always goes back to windowed settings
Image

The second issue I have. Is with the N64 Emulator [Project64 2.1] When I try to launch the Rom inside advanced laucnher iam getting a ''attempt to open file'' error. i tried to launch the rom outside xbmc and then it launches with no problem
Image


Hopefully somebody can help me out.
I wanted to putt all my Retro Games together with Hyperspin. But that is a project on hold, since it is a pain setting it up
Nobody?
Have a look at the commands being used by advanced launcher in the xbmc.log file AMD see if they work from a command prompt.
this was the only thing i could find about the emulator in the log files

21:40:05 T:2996 NOTICE: AdvancedLauncher: Load launchers.xml file
21:40:05 T:2996 NOTICE: AdvancedLauncher: Initialisation
21:40:05 T:2996 NOTICE: AdvancedLauncher: application : E:\Emulator\Snes\zsnesw.exe
21:40:05 T:2996 NOTICE: AdvancedLauncher: arguments : -m -s -v 22 "E:\Emulator\Snes\Roms\Batman Returns (U) [!].smc"
21:40:13 T:2280 NOTICE: CJoystick::EnumJoysticksCallback : Enabled Joystick: Nintendo RVL-CNT-01
21:40:13 T:2280 NOTICE: CJoystick::EnumJoysticksCallback : Total Axis: 0 Total Hats: 0 Total Buttons: 0
21:40:14 T:4088 NOTICE: Thread LanguageInvoker start, auto delete: false
21:40:14 T:4088 NOTICE: -->Python Interpreter Initialized<--
21:40:14 T:7912 WARNING: CActiveAE::ActiveAE::CActiveAE::StateMachine - signal: 0 from port: OutputControlPort not handled for state: 6
21:40:16 T:6104 NOTICE: Thread BackgroundLoader start, auto delete: false
21:40:18 T:4164 NOTICE: Thread LanguageInvoker start, auto delete: false


And this is my log file of the N64 Emulator

22:20:01 T:6444 NOTICE: AdvancedLauncher: Load launchers.xml file
22:20:01 T:6444 NOTICE: AdvancedLauncher: Initialisation
22:20:01 T:6444 NOTICE: AdvancedLauncher: application : E:\Emulator\n64\Project64 2.1\Project64.exe
22:20:01 T:6444 NOTICE: AdvancedLauncher: arguments : E:\Emulator\n64\roms\Legend of Zelda, The - Ocarina of Time (USA) (Rev B).z64
22:20:10 T:7984 NOTICE: CJoystick::EnumJoysticksCallback : Enabled Joystick: Nintendo RVL-CNT-01
22:20:10 T:7984 NOTICE: CJoystick::EnumJoysticksCallback : Total Axis: 0 Total Hats: 0 Total Buttons: 0
22:20:16 T:2384 NOTICE: Thread LanguageInvoker start, auto delete: false
(2014-10-21, 22:00)Paynemaster Wrote: [ -> ]21:40:05 T:2996 NOTICE: AdvancedLauncher: arguments : -m -s -v 22 "E:\Emulator\Snes\Roms\Batman Returns (U) [!].smc"
Are you sure that the video mode 22 is corresponding to fullscreen on your system?

(2014-10-21, 22:00)Paynemaster Wrote: [ -> ]22:20:01 T:6444 NOTICE: AdvancedLauncher: application : E:\Emulator\n64\Project64 2.1\Project64.exe
22:20:01 T:6444 NOTICE: AdvancedLauncher: arguments : E:\Emulator\n64\roms\Legend of Zelda, The - Ocarina of Time (USA) (Rev B).z64
Seems that you do not pass any parameters except the rom path to Project64. So does Project64 is setup to automatically start into fullscreen?
Quote:Are you sure that the video mode 22 is corresponding to fullscreen on your system?
I am not sure about Mode22. I am using 1920x1080 on my system. I made a custom resolution in the video config section of the emulator. so its also 1920x1080. What i do know is. that when i use the emulator without xbmc its working like it should. Full screen etc. but when i use that with xbmc it resets again. i can checked this by going back to the emulator without xbmc again. and then its also in windowed mode. so it almost sees that xbmc change something. I am not sure what u mean with mode22 since i did not change anything special with xbmc nor advanced launcher

Quote:Seems that you do not pass any parameters except the rom path to Project64. So does Project64 is setup to automatically start into fullscreen?

i found another old thread u replied in About someone that has the same error. u said u had to use the quotes on the rom naming. But that makes no difference. what i did find out, is that if i launch the rom with the zip extension
it gives me the same error. that could be because there is no zip file in my rom list. so i was thinking advanced launcher thought that he wanted to load a file that was not there. so i removed the zip extension. But the error is still here. i have totally no idea why this happens
(2014-10-22, 14:27)Paynemaster Wrote: [ -> ]I am not sure about Mode22. I am using 1920x1080 on my system. I made a custom resolution in the video config section of the emulator. so its also 1920x1080. What i do know is. that when i use the emulator without xbmc its working like it should. Full screen etc. but when i use that with xbmc it resets again. i can checked this by going back to the emulator without xbmc again. and then its also in windowed mode. so it almost sees that xbmc change something. I am not sure what u mean with mode22 since i did not change anything special with xbmc nor advanced launcher
According to ZSNES documentation (http://zsnes-docs.sourceforge.net/html/advanced.htm), video mode for fullscreen custom video is 39, 41 or 42. Video mode 22 (as it setup into Advanced Launcher ) is corresponding to 1024x896 windowed mode. So that logical that Advanced Launcher start ZSNES windowed.

(2014-10-22, 14:27)Paynemaster Wrote: [ -> ]i found another old thread u replied in About someone that has the same error. u said u had to use the quotes on the rom naming. But that makes no difference. what i did find out, is that if i launch the rom with the zip extension
it gives me the same error. that could be because there is no zip file in my rom list. so i was thinking advanced launcher thought that he wanted to load a file that was not there. so i removed the zip extension. But the error is still here. i have totally no idea why this happens
This mainly depend which version of Project64 you are using. But, according to Project64 documentation (http://www.pj64-emu.com/faqs/general/how...et-setups/) at the opposite of any others existing applications Project64 do not double quotes paths containing withe space. So if you try to remove the double quotes it may works.
Quote:According to ZSNES documentation (http://zsnes-docs.sourceforge.net/html/advanced.htm), video mode for fullscreen custom video is 39, 41 or 42. Video mode 22 (as it setup into Advanced Launcher ) is corresponding to 1024x896 windowed mode. So that logical that Advanced Launcher start ZSNES windowed.
So my question is. How do i change the resolution inside advanced launcher. So i can get full screen 1920x1080


Quote:This mainly depend which version of Project64 you are using. But, according to Project64 documentation (http://www.pj64-emu.com/faqs/general/how...et-setups/) at the opposite of any others existing applications Project64 do not double quotes paths containing withe space. So if you try to remove the double quotes it may works.

I already tried it without the quotes before. that was also not working

Here is a image of how it is set up right now

Image

as u see its %ROM% and i still get the error :S
(2014-10-22, 17:44)Paynemaster Wrote: [ -> ]So my question is. How do i change the resolution inside advanced launcher. So i can get full screen 1920x1080
If you want to use the custom video mode of ZSNES, just indicate it into the launcher argument :

Code:
-m -s -v 42 "%rom%"

You will also surely have to edit the ZSNES configuration file (zsnes.cfg) tio setup the custom video mode as 1920x1080.

(2014-10-22, 17:44)Paynemaster Wrote: [ -> ]I already tried it without the quotes before. that was also not working

Here is a image of how it is set up right now

Image

as u see its %ROM% and i still get the error :S
As the Project64 software do not respect the common command line rule that paths containing white spaces as to be double quoted to be rightly recognized, there is no easy way to fix this problem. You can rename the paths and the roms filename to do not have any space in them.
Quote:If you want to use the custom video mode of ZSNES, just indicate it into the launcher argument :

Code:
-m -s -v 42 "%rom%"

You will also surely have to edit the ZSNES configuration file (zsnes.cfg) tio setup the custom video mode as 1920x1080.

Sorry to say, but i have no idea where to change that code in the launcher argument :S

u know what i can't understand is that there is no big thread about this. there should be loads of people that have the same issues like me right?





Quote:As the Project64 software do not respect the common command line rule that paths containing white spaces as to be double quoted to be rightly recognized, there is no easy way to fix this problem. You can rename the paths and the roms filename to do not have any space in them.

same with this. its weird i find nothing about this issue at all. or i am confused about everything now Tongue. So ur saying if i rename the path and the rom filename it should work?? i have no idea what to enter on the path name now. since i tried some things
(2014-10-23, 03:16)Paynemaster Wrote: [ -> ]Sorry to say, but i have no idea where to change that code in the launcher argument :S
Into Advanced Launcher, select your SNES launcher > go into the context menu ("C" key) > Edit Launcher > Advanced Modification > Modify Arguments.

(2014-10-23, 03:16)Paynemaster Wrote: [ -> ]u know what i can't understand is that there is no big thread about this. there should be loads of people that have the same issues like me right?
Your issue here is "What is the right command line to start ZSNES into a specific custom video mode?". It is not specifically related to XBMC or Advanced Launcher. So maybe you will have a better support into the dedicated forum : http://board.zsnes.com/phpBB3/

(2014-10-23, 03:16)Paynemaster Wrote: [ -> ]same with this. its weird i find nothing about this issue at all. or i am confused about everything now Tongue. So ur saying if i rename the path and the rom filename it should work?? i have no idea what to enter on the path name now. since i tried some things
That's not a Advanced Launcher issue, that's a project64 bug. Personnaly I prefer to use Mupen64 as N64 emulator.
Quote:Into Advanced Launcher, select your SNES launcher > go into the context menu ("C" key) > Edit Launcher > Advanced Modification > Modify Arguments.


I give up on Project64 . and i am looking at Mupen64. The only problem i have with mupen64 is when i want to start the rom with advanced launcher it only opens the emulator window, but nothing happens. am i missing something here?
(2014-10-27, 18:03)Paynemaster Wrote: [ -> ]
Quote:Into Advanced Launcher, select your SNES launcher > go into the context menu ("C" key) > Edit Launcher > Advanced Modification > Modify Arguments.


I give up on Project64 . and i am looking at Mupen64. The only problem i have with mupen64 is when i want to start the rom with advanced launcher it only opens the emulator window, but nothing happens. am i missing something here?
Honestly, if you do not explain what you have done, it will be complicated to tell you if you have missing something or not. Confused
https://code.google.com/p/mupen64plus/wi...nsoleUsage
Quote:if you do not explain what you have done, it will be complicated to tell you if you have missing something or not. Confused


What is there to explain. i just installed Mupen64 and did the rest with Advanced launcher. adding rom directory etc.

do i need to edit something from that cfg file? i am not seeing anything that might needed to make it work inside advanced launcher
That link u posted is saying the following. ''If this file does not exist, it will be created and default settings will be written'' i checked the location but there is no 'mupen64plus.cfg'. i have totally no idea what to do :S
Pages: 1 2