Kodi Community Forum

Full Version: Can't update some info
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

TMM can't update the info multimedia of one film such "kbps", "audio", "subtitles", etc.

Any help here?

Thank you
try to download mediainfo ( http://mediaarea.net/de/MediaInfo ) and open the file with that tool.
There you can see whether mediainfo is able to parse the file or not
Mediainfo update is working only when open "tinymediamanager.exe" directly.

After open a shortcut to .exe doesn´t seems to work.
please send us the log after starting it from the shortcut (and after forcing a mediainfo update)
Hi,

I´m having again the same issue. Here is the log

Quote:23:32:27.395 ERROR org.tinymediamanager.thirdparty.MediaInfo - Failed to load mediainfo
java.lang.UnsatisfiedLinkError: C:\Users\FeliChe\AppData\Local\Temp\jna-695228516\jna2481148959748128557.dll: Acceso denegado
at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_25]
at java.lang.ClassLoader.loadLibrary0(Unknown Source) ~[na:1.8.0_25]
at java.lang.ClassLoader.loadLibrary(Unknown Source) ~[na:1.8.0_25]
at java.lang.Runtime.load0(Unknown Source) ~[na:1.8.0_25]
at java.lang.System.load(Unknown Source) ~[na:1.8.0_25]
at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:761) ~[jna.jar:4.1.0 (b4)]
at com.sun.jna.Native.loadNativeDispatchLibrary(Native.java:736) ~[jna.jar:4.1.0 (b4)]
at com.sun.jna.Native.<clinit>(Native.java:131) ~[jna.jar:4.1.0 (b4)]
at org.tinymediamanager.thirdparty.MediaInfoLibrary.<clinit>(MediaInfoLibrary.java:38) ~[tmm.jar:2.6.4 (r1770)]
at org.tinymediamanager.thirdparty.MediaInfo.staticOption(MediaInfo.java:498) [tmm.jar:2.6.4 (r1770)]
at org.tinymediamanager.thirdparty.MediaInfo.staticOption(MediaInfo.java:484) [tmm.jar:2.6.4 (r1770)]
at org.tinymediamanager.thirdparty.MediaInfo.version(MediaInfo.java:446) [tmm.jar:2.6.4 (r1770)]
at org.tinymediamanager.TinyMediaManager$1.run(TinyMediaManager.java:267) [tmm.jar:2.6.4 (r1770)]
at java.awt.event.InvocationEvent.dispatch(Unknown Source) [na:1.8.0_25]
at java.awt.EventQueue.dispatchEventImpl(Unknown Source) [na:1.8.0_25]
at java.awt.EventQueue.access$400(Unknown Source) [na:1.8.0_25]
at java.awt.EventQueue$3.run(Unknown Source) [na:1.8.0_25]
at java.awt.EventQueue$3.run(Unknown Source) [na:1.8.0_25]
at java.security.AccessController.doPrivileged(Native Method) [na:1.8.0_25]
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source) [na:1.8.0_25]
at java.awt.EventQueue.dispatchEvent(Unknown Source) [na:1.8.0_25]
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source) [na:1.8.0_25]
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source) [na:1.8.0_25]
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source) [na:1.8.0_25]
at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [na:1.8.0_25]
at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [na:1.8.0_25]
at java.awt.EventDispatchThread.run(Unknown Source) [na:1.8.0_25]
23:32:27.395 ERROR org.tinymediamanager.TinyMediaManager - could not load MediaInfo!

Any idea?
maybe you started tmm once as admin..

you can do either:

a) delete the temp. folder C:\Users\FeliChe\AppData\Local\Temp\jna-695228516
b) start tmm as admin

I'd prefer not starting any app as admin - that produces only problems, because of the poor user/admin rights management implementation by M$ (unix/linux had never a problem with that..). So try to get rid of the temp folder (probably it has been created by an admin account in your user dir Big Grin ) and try again

hth
Great mlaggner,

working it now.

Really thanks

Wink