Kodi Community Forum

Full Version: Issues with Master Lock [Solved]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Is anyone having an issue when they use Master Lock to lock settings (ANY level of setting and nothing else) on ANY skin, all of the videos vanish.

My MOVIES screen is available. The bar shows how many movies I have. When I click in, it is empty. If I disable my Master Lock, all is fine. It doesn't matter what I lock. The same result.

I have OpenElec on a Chromebox. I've reset, rebuilt, and done everything to figure out that this was the issue with my box. I've done it a dozen times. Lock = bad. Unlock = working.

Any suggestions or is there an alternate lock add-on I can use to lock out my settings?

Anyone with this?
I just tried this with 13.2 and a recent v14 nightly, and couldn't reproduce the situation. Setting the master lock and telling it to lock a settings level didn't hide any of my movies. Not sure why it would do that. Maybe the file source locking is being triggered? http://kodi.wiki/view/Media_sources#Locking

See if under Videos -> Files the context menu has an option that says "Remove lock" on your movie sources.
It's weird. If I just ENABLE the lock. It doesn't matter what is locked... My videos go to nothing. Unlocked = all good.
I'm using Gotham + Nox 4. No matter what skin, it still vanishes. I didn't see anything about a source lock for the file. When I hit the context menu in the videos area, nothing gives me a lock/unlock option.

Movies black out. TV shows black out. Whatever I have linked vanishes.
Last attempt...any ideas? Seems odd that it's just me.
I'm not sure how much detail from masterlock is logged, but maybe if you can get a debug log of when you turn it on or off. There might be a message in there about why it's locking the sources.
Nah. Nothing there in the logs.
If I literally set master lock with nothing checked, my sources just....show nothing. The widgets, however, seem to still show the options and can be selected. I haven't modded anything. Using OpenElec. Confluence. I thought maybe the VIEW, but the views didn't fix it either.

...what...the heck....
My sources are directly plugged in. There are no options to lock or unlock. I had an option for Shared videos...network autoadded it. IT had a LOCK option, but no unlock. I deleted the whole folder. Still nothing. I only have 1 video source. Craziness.

I think I'm out of ideas. I reset the whole system. Still the same deal. Someone out there would see this and go....OH YEAH! It's that thing.
But alas, I can't lock away my secret business! Now everyone will know I watch cartoons. Sad
...the grown up kind....with guys and girls...
stuff up.

HEY! I just opened my SOURCES.xml and DON'T see my plugged in file sources. Why would they not be showing? They show up fine in Kodi... That has to be something that is messing with my lock too...

sources added via USB and such are automatically mounted. Sources.xml is just what you manually have added.
Well, they're MOUNTED, but I added them as actual sources. The sources do not show in the sources.xml

EDIT: If you add via File_Manager = they will show up fine in the Movie or TV show tabs. If you lock your system with any settings at all...any...it will hide them completely from that view. // You MUST add them via Video/File and search your plugged in items via vars/media. Once added, you can view the items even if the system has a lock. You can also lock the individual sources from play and view.

Weird. What is the point of even adding it via file manager? Whatever. It's fixed.

Thanks for the help, everyone!
If you add the source under the File manager you can't set the content type or scraper to scan it into the library. You must have added them under Videos at one point and then they got removed (without library removal) or the sources.xml file got overwritten. Still, strange that it would do that. It's likely a weird combination of things, but still a bug. Nice catch.