Kodi Community Forum

Full Version: Problems with NFS and XBMCBUNTU 13.2 * Solved*
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have the newest XBMCBUNTU installed on a HTPC, and it is updated to 13.2. I have freenas that I am using to share my media. I have NFS Setup and have been able to use it via XBMC in windows 7, but with XBMCBUNTU, I can add the NFS Share, and browse the contents, but when I try to play any file, XBMC try's for a while then says it can't open the file. On freenas when I add the hostname to the list, it says "bad hostname, skipping." When I try to add the HTPC IP directly into the NFS Allowed hosts list, it doesn't seem to have any effect. I'm not super familiar with NFS, so does anyone have any advice on how I can troubleshoot this?
debug log (wiki) - also might read the nfs wiki link in my signature (read it carefully - nfs is no magic - but most users which are used to smb or something struggle to understand its authentication and file permission principal).
The debug log said that it couldn't open the file. I solved this problem by mounting the share on startup in fstab, and magically it not only started working, but the speed was many times faster than CIFS in XBMCBUNTU, and faster than the NFS share was in windows. No change to the server at all. It just looks like XBMC was having trouble mounting them from its GUI.
Yeah - you are the pro...
Unless I am mistakenly interpreting your last comment, It seems like you are being intentionally rude to me for taking your advice, looking at the debug log, reading up on the NFS wiki in your signature, and then finding a working solution and posting a follow up and the results of my solution.

what should I do on a help forum differently than I did to get a better response from other forum members?
My advice was not ment to say "look into the debug log" but instead "post the debug log so I can have a look at it". I am pretty sure it tells more then "it couldn't open the file" which could have helped me to tell you what in your setup might be incompatible with kodi.

Using filesystem mounts of the OS is always a good solution because it keeps any support burdon of of me (its not a solution if different kodi instances are running on different operating systems and all are sharing the database).

What stays in the forum are a dozen of topics which say "NFS not working" - which are mostly because of server side settings. So if i can request one last thing from you - please change the thread topic to include "solved".

My rudeness was caused by the "It just looks like XBMC was having trouble mounting them from its GUI." thingy. I somehow always feel attacked when people are stating such general things when the real problem is the backend not the frontend.

sry didn't look at your post count - i try to give rude answers only for users with more then 20 posts normally Wink
No problem. I didn't mean to criticize XBMC. I think that it is fantastic. I have been using it off and on since the original XBOX version.