Kodi Community Forum

Full Version: Remote keypress issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi guys,

Got a really strange issue that has just started this evening. Previously my setup of i3 NUC + XBMC 360 media remote was working fine, using OpenELEC

All of the sudden this evening after button mashing the remote by accident, all of my keypresses are interpreted strangely by the NUC. That is, if I press a navigation key (i.e. left), it will skip 2-3 menu items across. If I hold it down too long, it doesnt work at all.

Even stranger, this is also happening on a generic MCE/RC6 remote, which also worked fine before.

I've already tried resetting XBMC (even did a clean install of OpenELEC latest stable build), and also tried resetting the BIOS to defaults. No change, still getting strange navigation behaviour.

I'm at a loss as to how to fix this - please help!

Thanks in advance,
It may be that you pressed multiple keys at the same time (e.g.TV and OK) that changed the internal settings of the receiver. There should be details in the instructions (if you still have them.)
For the receiver on the NUC? Didn't think that was possible. Not really sure the NUC came with instructions, other than a quick setup guide.
Since you re-installed OE that kind of rules out a driver type issue. If you didn't have the same problem with the other remote, I'd say your batteries were low.

Might be a poor connection in the IR LED circuit or something on your NUC or its power supply causing noise. But I'm not sure how you could check or verify a noise problem, other than try a different power supply.

May want to try a cheap usb MCE IR receiver.
The issue exists with both remotes. It almost feels like a timing issue. If i hold it down longer than 10ms, it just doesn't register. And when I do hit it correctly, it skips 2-3 menu/list items at a time (random number).

Completely at a loss at this point.
Yes, both remotes but same receiver. The receiver is the most likely culprit. Noise can screw up a IR receiver, as well as a poor connection. Both could return inconsistent results as you describe. Things you could try;

-Open up the NUC, jiggle any connectors. Move cables to IR sensor away from other cables or anything 'noisy' they may be touching.

-Maybe try moving the NUC to a different location & electrical outlet temporarily to see if there is some local grounding noise causing the problem.

-Try a new power supply

-Try a USB IR receiver.

Does it have a fan? I suppose a faulty fan could cause circuit noise as well, although that sounds like a long shot. You could try changing the fan speed setting for kicks.
New development:

Came home, and the unit worked correctly for about 30 seconds, thinking - It's fixed. Issue appeared instantly. So after doing the following:

- Powering the unit down
- Rebooting the unit
- Putting it to sleep
- Reflashing the NUC firmware
- Reformatting the mSATA drive
- Trying different remotes / new batteries

... nothing happened. No fix.

I then decided to just pull the power plug out of the NUC/wall, and leave it for a few moments. Powered up and... hey presto - no issue!

Completely and utterly strange. No issues since last night, so I have no real idea as to what caused the issue. Thanks for the help/suggestions everyone! Hopefully this doesn't appear again!