Kodi Community Forum

Full Version: Can"t get passthrough to work on kodi 14.0
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have set up kodi and everything has gone very well except that i can"t get passthrough to work. I am running kodi 14.0 on a minix neo x7. I am running jb 4.2.2. Passthrough works fine on all other programs including beyond xbmc. I have gone into system/settings/system/audio output with the setting set at advanced and passthrough enabled, but no luck. Audio output device and passthrough output device are not highlighted either and passthrough output device is listed as android audio track. I have a Denon receiver capable of ac3 and dts. My connection is hdmi, but i have also tried a spdif connection as well as a way to trouble shoot. My addon log uploader is not working so I can't send or read logs myself either. Any and all help welcome. Thanks, Kevin
(2015-01-11, 18:55)smokie171 Wrote: [ -> ]I have set up kodi and everything has gone very well except that i can"t get passthrough to work. I am running kodi 14.0 on a minix neo x7. I am running jb 4.2.2. Passthrough works fine on all other programs including beyond xbmc. I have gone into system/settings/system/audio output with the setting set at advanced and passthrough enabled, but no luck. Audio output device and passthrough output device are not highlighted either and passthrough output device is listed as android audio track. I have a Denon receiver capable of ac3 and dts. My connection is hdmi, but i have also tried a spdif connection as well as a way to trouble shoot. My addon log uploader is not working so I can't send or read logs myself either. Any and all help welcome. Thanks, Kevin

Almost the same thing, mate! I was surprised to find kodi able to open a DVD rip, even to navigate through DVD's menu, but was completely disappointed by missing passthrough, although the feature is enabled in both system audio output and current playback audio settings. Confused
At the same time, the built-in player correctly recognize audio tracks and redirects accordingly (but is too dummy to work with DVD structures). It's a fail for me...
Would highly appreciate advises how to bypass the issue.

My configuration: Q7 CS918 on RK3188 + Android 4.4 + XBMC Gottham upgraded to Kodi + DVD rip: - 2ch stereo track; - DTS track; - AC3 track.
Nota bene: SNMC as well as justXBMC beyond with passthrough engaged generate just a buzzy noise. Other players do not display multichannel tracks either. Very strange!

[Update!]
Forgot to mention that I'm sending the signal to Yamaha RX-V1700, a receiver that is able to decode DTS, DD, DDEX, Dolby Pro, Dolby ProII. It recognizes the signal in real-time. While playing through Kodi, it shows just PCM. So, may be a manual file edit would be just enough for my very case?..
I think you will need the miniX version of XBMC/Kodi or the updated version of SPMC (wiki) when it comes out. IIRC, Rockchip-based boxes need a special bit of code for audio passthrough to work reliably, and that code is not in vanilla Kodi builds yet.
(2015-01-12, 01:52)Ned Scott Wrote: [ -> ]I think you will need the miniX version of XBMC/Kodi or the updated version of SPMC (wiki) when it comes out. IIRC, Rockchip-based boxes need a special bit of code for audio passthrough to work reliably, and that code is not in vanilla Kodi builds yet.

Hi, Ned. Thanks for suggestion. It appears a lil bit strange to me to go for SPMC. As I've understood, SPMC is a small project derived from Gottham and accomplished by a small group of enthusiasts, while Kodi team is bigger. Perhaps, the miniX is built on SPMC that's why the last one has that "special bit of code", while Kodi does not. Anyway, I'm affraid, I won't test all the possible makes and builds waiting that someday my issue will be solved. From my experience all new FW are solving some bugs and bring each time a dozen of new bugs. Moreover, it may happen that an update may completely kill the device. So, there should be a simple bypass for this issue.
(2015-01-12, 12:44)iMag Wrote: [ -> ]As I've understood, SPMC is a small project derived from Gottham and accomplished by a small group of enthusiasts

Veeeerry small group of enthusiasts Big Grin
It may not be helpful to you but I have the droidplayer and was at first confused by the setup of the passthrough on XBMC player..

even though I had the droidplayer system setting to "pass through enabled" the audio did not "passthrough" until I enabled the same option on the XBMC player screen when playing the movies itself..

for me it was press Enter/OK, the center button on the RC which would display the player buttons, then arrow left to the audio settings, then arrow down to the "pass through > enable" option. the streaming would pause and then continue in DTS or DD 5.1..

ignore this all if I am way of target..
cheers
CD
I have a fire TV and a nas drive running plex server. Movies have been ripped via makemkv and handbrake to m4v files with ac3 5.1 sound and h.264 video

The plex client on fire TV has issues with playback (stuttering video and sound) although it does output sound in 5.1 (using ac3 pass thorough).

After loading Kodi on the fire TV and setting plex to use an external player which I set as Kodi the video playback issues seem to be gone HOWEVER sound is only stereo. If I configure Kodi to use audio passthrough I just get white noise on the audio

Any suggestions ??

Thanks

Ian
Did you enable HDMI passthrough in the AFTV settings?
if you are getting "white noise" it means that the amp/AVR is not decoding the data stream..
so the output of the player is ok, it is 'passing through' the data stream, but you just need to get it decoded by the amplifier you are connecting it to...
cheers
CD
Thanks answering in order ....

Hdmi passthrough is enabled on the firetv

The amp is configured and works fine outputting 5.1 for amazon prime movies and a movie played with the plex player only when xbmc or kodi is used with ac3 passthrough enabled do I get the white noise. This is what makes me think it's the player not the rest of the system.

Annoyingly the little bit of info that xbmc or kodi displays tells me that the audio is 5.1 down mixed to stereo. I have now tried xbmc 13.2 and kodi 14.1 and both seem to have this issue.

Ian
Are you sure that you have enabled pass through on the android unit's settings AS WELL AS the xbmc audio setting in the video player window of the xbmc.
Yes I have - proven by the fact that the same file played through the native player in Plex outputs the sound to the amp as 5.1 whereas the XBMC or Kodi player defaults to stereo and if set to pass through outputs white noise. Given that the settings on the firetv are the same in both cases leads me to believe that the issue is with XBMC or Kodi.
I have the same experience with Kodi on my Raspberry Pi. Playing AC3 sound from iso-files with passthrough enabled results in noise only. When turning passthrough off AC3 is downmixed to stereo and plays ok.
Playing other video-files works ok apparantly because these are handled by the special OMXPlayer on Raspberry Pi. Turning off OMXPlayer ie. making the standard player play all video files shows the same problem for the other video files.

Conclusion: There is something wrong with the passthrough handling in Kodi.
I am trying to set up M3U Plauer List URL but when I clicked the M3U Plauer List URL box I can see the key board but do not see the alphabets and numbers in keyboard except "BackSpace, Done, Capsloack, Shift, Symbols, Space, IP Address , and <>"
Can any one tell me how to get the key board alphabets?