Kodi Community Forum

Full Version: Stuttering during playback
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have 2 setups running Kodi v14. One is an Amazon Fire TV, and the other is a HTPC, running OpenElec. Both of them have stuttering during playback on movies that are 25fps. All movies that are 23.976fps, play perfectly smooth. I tried enabling the Video setting that says "Adjust display refresh rate to match video", but that didn't help. Does anyone know how I can fix this problem? I don't remember having this issue when I was running Gotham on my setups.
Is it happening with all/any video types, or only specific types? If you connect a keyboard to the boxes and press "o", you'll get an overlay explaining what the video type is. See Codecinfo (wiki) for more info, and provide the video types if it is only specific types.
I would start this way...

For the HTPC with openelec running:

1. enable debug logging in system settings -> system -> debugging -> enable debug logging
2. reboot
3. reproduce your issue and dont reboot!!!!!!!
4. ssh in from another pc and do:

Code:
paste /storage/.kodi/temp/kodi.log

and provide the URL you will get

Unfortunatel I cant help much with the fire-TV. So for this, others are able to help more and can give better support.
(2015-01-13, 23:07)David1977 Wrote: [ -> ]I would start this way...

For the HTPC with openelec running:

1. enable debug logging in system settings -> system -> debugging -> enable debug logging
2. reboot
3. reproduce your issue and dont reboot!!!!!!!
4. ssh in from another pc and do:

Code:
paste /storage/.kodi/temp/kodi.log

and provide the URL you will get

Unfortunatel I cant help much with the fire-TV. So for this, others are able to help more and can give better support.

"Permission denied" when I pasted that in.
Maybe your TV doesn´t support 50HZ,

Option A "play 25fps movies at 24fps":
  1. system settings > video > playback > adjust display refresh rate to match video > on start/stop
  2. system settings > video > playback > a/v sync method > videoclock (resample audio)
  3. put this advancedsettings.xml in your userdata folder
  4. and restart kodi

Option B "force HDMI refresh rate 50hz only OpenELEC"
  1. system settings > video > playback > adjust display refresh rate to match video > on start/stop
  2. system settings > video > playback > a/v sync method > videoclock (Drop/Dupe audio)
  3. put this advancedsettings.xml in your userdata folder. (The advancedsettings.xml is different than other)
  4. put this Autostart.sh in /storage/.config/
  5. and restart kodi

PD: Actually i use the second option, because my LG TVs, have issues with EDID.
With both of those options, is the advancedsettings.xml required, along with the settings, or do I just use one or the other?
Yes, you have to use both.
(2015-01-14, 02:03)lennie paz Wrote: [ -> ]
(2015-01-13, 23:07)David1977 Wrote: [ -> ]I would start this way...

For the HTPC with openelec running:

1. enable debug logging in system settings -> system -> debugging -> enable debug logging
2. reboot
3. reproduce your issue and dont reboot!!!!!!!
4. ssh in from another pc and do:

Code:
paste /storage/.kodi/temp/kodi.log

and provide the URL you will get

Unfortunatel I cant help much with the fire-TV. So for this, others are able to help more and can give better support.

"Permission denied" when I pasted that in.

then you got a typo or you didn´t do it on the openelec machine. Don't do this on your fire-TV as I said in the line in red!!!!!!

you could also do a:

Code:
cat /storage/.kodi/temp/kodi.log | paste

which does the same.

To see, what is supported by the TV:

Code:
xrandr | paste

NOTE: ALL THIS IS FOR THE OPENELEC MACHINE AND NOT FOR THE FIRE-TV!!!!
Why are you using exclamation points? I didn't do it on the Fire TV, I did it on my OpenElec HTPC!
no offense Wink...just want to be clear Wink

So you got a typo. The logfile for kodi on openelec is stored under /storage/.kodi/temp/kodi.log and you don't need any permissions for this, because you are always root under OpenELEC. So a "permission denied" thing doesn´ t make sense in this case. That's why I thought you maybe didn't do it on your OE machine.

Maybe Iḿ completely wrong...what might be...but then I hope someone steps in and do the correct thing how to provide a logfile under OE. I always do it this way.

You can check this, too:

Debug Log

and choose "logfile easy". Which works as well.

Without a logfile it's mostly hard to tell, what the issue is.

Greetings
Well, I copied and pasted what you told me to do, so if there was a typo, it came from what you posted.
what hardware are you using on your HTPC?
It looks like my TV supports 50Hz?




login as: root
##############################################
# OpenELEC - The living room PC for everyone #
# ...... visit http://www.openelec.tv ...... #
##############################################

OpenELEC (official) Version: 5.0.0
OpenELEC:~ # xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 32767 x 32767
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 1329mm x 748mm
1920x1080 60.00*+ 60.00 50.00 59.94 24.00 23.98
1920x1080i 60.00 50.00 59.94
2880x576 50.00
2880x480 60.00 59.94
1280x800 59.91
1280x720 120.00 119.88 60.00 50.00 59.94
1440x576 50.00
1024x768 75.08 70.07 60.00
1440x480 60.00 59.94
800x600 72.19 75.00 60.32
720x576 50.00
720x480 120.00 119.88 60.00 59.94
640x480 75.00 60.00 59.94
720x400 70.08
DP2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
OpenELEC:~ #

OpenELEC:~ # /storage/.kodi/temp/kodi.log
-sh: /storage/.kodi/temp/kodi.log: Permission denied
OpenELEC:~ # /storage/.kodi/temp/kodi.log
-sh: /storage/.kodi/temp/kodi.log: Permission denied
OpenELEC:~ # /storage/.kodi/temp/kodi.log
-sh: /storage/.kodi/temp/kodi.log: Permission denied
OpenELEC:~ #
/storage/.kodi/temp/kodi.log
-sh: /storage/.kodi/temp/kodi.log: Permission denied
OpenELEC:~ # /storage/.kodi/temp/kodi.log
-sh: /storage/.kodi/temp/kodi.log: Permission denied
OpenELEC:~ #
Yes, your tv support [email protected],

Try this in openelec
  1. system settings > video > playback > adjust display refresh rate to match video > on start/stop
  2. system settings > video > playback > a/v sync method > videoclock (Drop/Dupe audio)
  3. put this advancedsettings.xml in your userdata folder.
  4. and restart kodi
Quote:OpenELEC:~ # /storage/.kodi/temp/kodi.log
-sh: /storage/.kodi/temp/kodi.log: Permission denied

Yes...of course, that doesn't work. So you didn´t do, what I told you to:

Code:
cat /storage/.kodi/temp/kodi.log | paste
or
Code:
paste /storage/.kodi/temp/kodi.log

both do the same in the end. You will get an URL back where the output of those commands is pasted to. "kodi.log" is not a command you can run or you can execute. It's a text file within all the needed info.

And we still don't know which kind of hardware you are using. Except of the Fire-TV.

Eidt:

Ah...now I think, what you did wrong....you think "paste" is a hint, that you should copy and paste that following into the command line Wink...."paste" is a command. So please copy and paste the whole thing...with the "paste"-word Wink So it have to look like:

Quote:OpenELEC:~ # paste /storage/.kodi/temp/kodi.log

then it should work Wink
Pages: 1 2