Kodi Community Forum

Full Version: Visible tag question
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have been messing around with the visible tags this one in particular

<visible allowhiddenfocus="true">

It has been working great. But I have run into a problem. When I use this tag on the bookmarks created through the skin settings it acts weird. Like, if you have the last visible button highlighted and press down on the dpad the texturefocus dissappears but the button is being highlighted behind the background. I have tried many different combinations but none have worked right. Is there anyway to use this tag with these bookmarks?
The allowhiddenfocus attribute just means that if the control is hidden, you may still move on to it (thus focusing it, and one would presume the plan is to make it visible). If you focus on an invisible button with allowhiddenfocus set to true, they'll receive focus, but will not become visible, unless the visible condition causes them to do so.

Thanks for the clarification jmarshall. I was afraid that might have been the answer. But I think I might have found a solution to my problem after a lot of thinking about it. Thanks again!
Alright, I have another question. Why doesn't this work correctly

<visible>[!Skin.HasSetting(bookmarkbuttons) + Skin.HasSetting(ProgramsBM4)] + Control.HasFocus(2)|Control.HasFocus(3)|Control.HasFocus(4)|Control.HasFocus(99)|Control.HasFocus(6)|Control.HasFocus(31)|Control.HasFocus(32)|Control.HasFocus(33)|Control.HasFocus(34)</visible>

This allows buttons to be focused if bookmarks are not set or enabled. So is my logic wrong on this? Shouldn't this be

[true] and one of these is true

then a button is focused? Because the way it is acting now is that it is focused even if this part [] is not true.
Try adding [] around the or operations.
I have and it didn't work. I will try it again just to make sure. I'll let you know.
Thanks jmarshall that fixed it. I had tried it before but was using the allowhiddenfocus tag. Thats why it didn't work.