Kodi Community Forum

Full Version: Cleaning library leads to crash
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Going go "settings-videos" and select "clean library". The dialogue box "Clean up library - cleaning database - this may take some time" comes up, but Kodi then freezes / crashes. I can no longer move the mouse or cancel the dialogue box. This does not change even after one hour.

I am attaching the debug log. Any help appreciated!

http://pastebin.com/8PnV7aPX
I've been getting this problem quite a lot since the move to 14.x, and it seems to be if I make a major change to sources. Right now, I have about 200 movies in my library that need cleaning, and it gets stuck and crashes at about 35%.

This is on Windows 8.1 so I don't know that the problem is Mac specific.

EDIT: I've taken to manually removing each false movie entry manually because of the crashing problem...
can you try the 14.2 beta install?
and recreate the crash and give the crashlog on OSX
I believe the issue below is related (and includes logs). Will give 14.2 a try.

218359 (thread)
Possibly, although mine never crashes on 'update library'. Having said that, my library is about 10% the size of yours!

There is one thing I want to try before going to 14.2 beta. Brief back story...I have all my movies in folders according to their BBFC certification as it makes adding appropriate sources for my kids easier. It occurred to me that the 12A certification is for cinema only, not home video, so on the NAS, I moved all my 12A movies to the 12 folder and deleted the 12A folder.

Then when I got to Kodi, I removed the source, and ran a clean library, then it crashed at about 35% or so.

One of the posts in your thread, steve1977, rang a little bell. I'm thinking it's constantly looking for the old source. So, I'm going to recreate the folder, add the source back into Kodi, then try the scan.

If that works, then it shows that clean library clearly prefers the your sources to still be there (which makes sense...you're usually just removing a film or two from a source...not a whole source). I'll post here once I've tried that. If it works, then it looks like Kodi 'just' needs some error trapping for that particular circumstance...but that's jumping ahead.
Unfortunately, things don't work with 14.2-beta either. Still having the same issue. It is "freezing" rather than a "crashing". Any ideas based on the logs provided? Can I install Gotham and Helix in parallel? Would love to try out whether this issue is there in Gotham. My library hasn't grown much and I never experienced the issue in Gotham. Thanks!
Any luck with this issue by chance? I'm running 14.2 RC and I've been having the same problem since 14.x. I just tried removing the two SMB sources I had to my video library and chose to have it remove the files from the library. That library clean-up was reasonably quick, around 1 minute. I think went straight to Settings, Video, Library and initiated another Clean. It immediately froze up, even though I now have no sources or files in my video library.
Also still getting freezes. I had to remove the database on my main profile, and it now updates and cleans that with no issues, however if I go into my daughters profile, it freezes trying the same thing, so I guess I have to delete her database as well.
Still an issue. (win10, smb directories)
(2019-07-26, 13:38)cear Wrote: [ -> ]Still an issue. (win10, smb directories)

It's more than 4 years later in this thread. I think we need some more details of your "problem description" than what you gave us now.
Here's a log
ahihiwusul.kodi (paste)
Kodi hangs on the last line > NOTICE: CVideoDatabase::CleanDatabase: Starting videodatabase cleanup ..

On my Nvidia Shield, using the exact same library, the clean happens within a minute.