Kodi Community Forum

Full Version: XBMC 12.3 Curl Errors on Library Update
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So at some point over the past week, without changing anything on the system to my knowledge, library updates began to fail. ANyone know what could be the issue? I am running the latest build for my OS (Fedora 19).

I can actually use curl via the command line to download the URL in the logs below:

Code:
[localhost temp]$ curl -O http://thetvdb.com/api/1D62F2F90030C444/series/259372/all/en.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  8700  100  8700    0     0  33463      0 --:--:-- --:--:-- --:--:-- 33590

XBMC Version:
Code:
XBMC (12.3 Git:Unknown), Platform: Linux (Fedora release 19 (Schrödinger’s Cat), 3.10.10-200.fc19.i686 i686). Built on Mar  8 2014

Curl Version:
Code:
curl 7.29.0 (i686-redhat-linux-gnu) libcurl/7.29.0 NSS/3.17.2 Basic ECC zlib/1.2.7 libidn/1.26 libssh2/1.4.3
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp scp sftp smtp smtps telnet tftp
Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz

Debug Log:
Code:
23:45:35 T:2882693952   DEBUG: GetEpisodeId (/mnt/video/TV/House of Bryan/Season 3/House of Bryan - S03E10 - Mo' Money, Door Problems.flv), query = select idEpisode from episode where idFile=5492
23:45:35 T:2882693952   DEBUG: VideoInfoScanner: No NFO file found. Using title search for '/mnt/video/TV/House of Bryan/Season 3/House of Bryan - S03E11 - A Hardwood Day's Night.flv'
23:45:35 T:2882693952   DEBUG: GetEpisodeList: Searching 'http://thetvdb.com/api/1D62F2F90030C444/series/259372/all/en.zip' using The TVDB scraper (file: '/home/zxarr/.xbmc/addons/metadata.tvdb.com', content: 'tvshows', version: '1.7.1')
23:45:35 T:2882693952   DEBUG: CurlFile::Open(0xb69f3628) http://thetvdb.com/api/1D62F2F90030C444/series/259372/all/en.zip
23:45:35 T:2882693952    INFO: easy_aquire - Created session to http://thetvdb.com
23:45:35 T:2882693952 WARNING: FillBuffer: curl failed with code 56
23:45:35 T:2882693952   ERROR: CCurlFile::CReadState::Open, didn't get any data from stream.
23:45:35 T:2882693952   ERROR: Run: Unable to parse web site
23:45:35 T:2882693952 WARNING: No information found for item '/mnt/video/TV/House of Bryan/', it won't be added to the library.
Anyone out there have any idea why this might happen?

It's rather annoying, the sudden inability to update any shows / movies.

Thanks.
try downgrading or upgrading curl. Might be the well know curl bug introduced in one version and fixed in the next.
I'm also seeing these errors on a Windows install - since the Jan 8th update to cURL to 7.4

Has anyone had success in fixing this issue ?
So I've tried downgrading curl, libcurl and python-curl to no avail. I was going to update the whole thing to Ubuntu 14.04 in a few weeks, but in the mean time this is rather annoying.

I'd like to get this sorted, even if it's just for posterity...

I also have to add that no updates were done to the system outside of addon updates that are automatic. I have tried removing and reinstalling most of the updates I have. Doesn't seem to solve it either.
this error is very generic:
CURLE_RECV_ERROR (56): Failure with receiving network data.

maybe read
http://serverfault.com/questions/555335/...961-errors