Kodi Community Forum

Full Version: Scanning for videos terminates immediately (SMB)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My setup:
  • Ubuntu 14
  • Kodi Helix 14.1
  • Samba for shares
  • advanced settings for MySQL

I have some Samba shares on my Linux machine where my videos are. I use these shares so I can connect my OpenElec (Raspberry Pi) to the Ubuntu server to play these files. Then I add these shared folders in Kodi using username & password to gain access.

So here's my problem. When I add a source I follow these steps:
  1. Goto videos-->Files
  2. Add source
  3. browse to folder
  4. enter username + password
  5. add the correct sub folder from the share
  6. repeat steps 3+5 to add all separate folders from each share
  7. indicate I use these shares for movies
  8. OK+OK+OK etc
The I get the question if I want to scan for new content. So I answer yes. In XBMC Gotham this worked like a charm. No there is no visual feedback so I started an extensive log. This is what the log says:
22:57:39 T:140557703706368 NOTICE: Thread VideoInfoScanner start, auto delete: false
22:57:39 T:140558593845184 DEBUG: ------ Window Init (DialogExtendedProgressBar.xml) ------
22:57:39 T:140557703706368 NOTICE: VideoInfoScanner: Starting scan ..
22:57:39 T:140557703706368 DEBUG: CAnnouncementManager - Announcement: OnScanStarted from xbmc
22:57:39 T:140557703706368 DEBUG: GOT ANNOUNCEMENT, type: 16, from xbmc, message OnScanStarted
22:57:39 T:140557703706368 NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:00
22:57:39 T:140557703706368 DEBUG: CAnnouncementManager - Announcement: OnScanFinished from xbmc
22:57:39 T:140557703706368 DEBUG: GOT ANNOUNCEMENT, type: 16, from xbmc, message OnScanFinished
22:57:39 T:140557703706368 DEBUG: Thread VideoInfoScanner 140557703706368 terminating
22:57:39 T:140558593845184 DEBUG: CGUIMediaWindow::GetDirectory (sources://video/)
22:57:39 T:140558593845184 DEBUG: ParentPath = [sources://video/]
22:57:39 T:140557703706368 NOTICE: Thread BackgroundLoader start, auto delete: false
22:57:39 T:140557703706368 DEBUG: Thread BackgroundLoader 140557703706368 terminating

Notice that the scan took ZERO seconds. Complete log is available. Have searched the forum for similar problems. I can browse the files when using the File option in Kodi. So I can individually assign a movie name, but that's tedious.

Also added files from the local disk instead of through SAMBA, but same result.

Anyone got an idea?

(EDIT: bump; another try and local files work......... baffled. I'm looking into the SAMBA problems and will post my findings for other users if I find an answer)
Ok, it seems that a subfolder on the SMB share that starts with double underscores doesn't work. So I moved all the files & folders one level up in the root of the share and now all seems well.