Kodi Community Forum

Full Version: Kodi firetv compatability question, advice please chaps..
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,
It's been a journey, but I'm at the point of sideloading 14.0 Kodi onto my new ftv,... but before I do could anyone please tell me if this firmware is compatible or not.... (I thought they were all compatible)..

51.1.4.0_user_514005520

I have three main update ports blocked with opendns, as I have read that the very latest update sticks a nice big banner onto the home screen.....

Would really appreciate any advice or help before I cock this up.... thanks chaps...

sadsack007..
Sideloading Kodi is supported on all firmware versions. You don't have to block updates or anything like that.
(2015-02-24, 22:30)Ned Scott Wrote: [ -> ]Sideloading Kodi is supported on all firmware versions. You don't have to block updates or anything like that.


Hi Ned,
Honestly mate thanks for replying......

I asked here because this is the best place to get a firm answer, ..... if you don't mind, have a look at this..... http://www.aftvnews.com/software/ and come down to the firmware that I have.... It's the 5th one down.
And also this, http://www.aftvnews.com/xbmc-kodi-incomp...514005520/

http://forum.xda-developers.com/fire-tv/...v-t2917248

and there's mention of it on here as well, 207081 (thread)

Could you tell if this is a confirmed problem please...... I ask as the homepage is not corrupted with sales banners at the moment, and from what I've read the most recent update does have this....

Thanks Ned for replying,
sadsack007....

p.s. As I'm always telling my boy,.... always do your homework son, .... measure twice and measure again before you cut. That's what I was always told and now I can't get out of the habit.
Yes, there were reports that the FW you have did have problems with XBMC/Kodi.

However, the same day another FW was released (51.1.4.0_user_514006420) which fixed that issue.

You said that you're blocking updates. So is your AFTV rooted or are you planning to root it?

If it is then just update to one of the custom pre-rooted ROMS here: http://www.aftvnews.com/roms/

If your not rooted, then follow this guide: http://www.aftvnews.com/start/ then update to a newer pre-rooted ROM.

If your not rooted and don't plan on rooting, then there is no need in blocking updates.
Thanks for the reply Tinwarble.....

If I was on 514006420 I wouldn't be asking for help mate..... it's just that Amaz()n have decided to start using the top part of the homescreen to push advertising, it's only a matter of time before we start seeing the highest bidders on there.

Not rooted mate,..... 51.1.4.0_user_514005520 cannot be rooted..... I was going to try and hang onto a lower firmware to see if and when root may become available.

I was kind of hoping that someone out there is using helix on my FW and can confirm there isn't a problem.
Yeah, I was just telling you that it was fixed by a "same day release".......it was just and FYI.

But sorry, I did forget which version number that it stopped being rootable.

However, there was some confirmation that Kodi (Helix and Gotham) had problems on the FW you are running. http://www.aftvnews.com/uk-fire-tv-relea...e-version/ see 3rd post down.

If you're waiting for a future root fix, you may be waiting some time.

Your only choice, if you're wanting to run Kodi now is to update the FW.