Kodi Community Forum

Full Version: File manager - move file problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi,

I have problem with with moving file in file manager. When I'm doing it in log I get:
Code:
DEBUG: FileManager: move /xxxxxxx -> /xxxxxx
ERROR: Rename - Error renaming file /xxxxxx
I don't see any reason of that. I'm moving files from one mounted resource to another.
If I don't have permission, copying files shouldn't work but it works fine. Does anybody have this problem??
(2015-02-26, 16:11)orzechszek Wrote: [ -> ]If I don't have permission, copying files shouldn't work but it works fine. Does anybody have this problem??

this assumption is not correct. You may very well have READ permission, but not WRITE permission
Yes, you're wright. I must check it. But something has changed because everything was fine on xbmc 13.2.
In file manager I'm moving files as a user who start kodi process??
I'm an owner of moved files, folders and destination folder and have rw permission
Has anybody an idea what could be wrong? As which user am I moving files - the same as kodi is started? Because this is an owner of moved folders.
yes, ofc same user as kodi is started as. How do you start kodi?
nothing else in Debug Log?
Information from log:
Code:
20:37:42 T:140515738040064   DEBUG: FileManager, processing folder: /xxxx/xxxx/xxxx/
20:37:42 T:140515738040064   DEBUG:   -- /xxxx/xxxx/xxxx/xxx.mkv
20:37:42 T:140515738040064   DEBUG:   -- /xxxx/xxxx/xxxx/xxx.nfo
20:37:42 T:140515738040064   DEBUG:   -- /xxxx/xxxx/xxxx/xxx.com.txt
20:37:42 T:140515738040064   DEBUG:   -- /xxxx/xxxx/xxxx/
20:37:42 T:140515738040064   DEBUG: FileManager, processing folder: /xxxx/xxxx/xxxx/
20:37:42 T:140515738040064   DEBUG:   -- /xxxx/xxxx/xxxx/xxx.mkv
20:37:42 T:140515738040064   DEBUG: FileManager: create folder /xxxx/xxxx/xxxx/
20:37:42 T:140515738040064   DEBUG: FileManager: move /xxxx/xxxx/xxxx/xxx.mkv -> /xxxx/xxxx/xxxx/xxx.mkv
20:37:42 T:140515738040064   ERROR: Rename - Error renaming file /xxxx/xxxx/xxxx/xxx.mkv
20:37:42 T:140516475647936   DEBUG: ------ Window Init (DialogOK.xml) ------
20:37:43 T:140516475647936   DEBUG: ------ Window Deinit (DialogExtendedProgress
Bar.xml) ------
20:37:55 T:140515636778752   DEBUG: ### [Qlock] - Delaying 240 secs
20:37:58 T:140516475647936   DEBUG: UPower: Received an unknown signal DeviceCha
nged
20:38:12 T:140515139901184   DEBUG: Thread JobWorker 140515139901184 terminating
(autodelete)
20:38:12 T:140515712861952   DEBUG: Thread JobWorker 140515712861952 terminating
(autodelete)
20:38:12 T:140514585196288   DEBUG: Thread JobWorker 140514585196288 terminating
(autodelete)
20:38:27 T:140516475647936   DEBUG: UPower: Received an unknown signal DeviceCha
nged
One thing I've noticed - destination folder has permittion 755 (folders in this folder have the same), folder from I'm copying 770, copied folder 775 - everywhere I'm an owner. Is a possibility that moving command try to force rights somehow and it can't be created properly due to differences in permittions??
if you are the owner(read the user kodi is running as), then the only reason I see for this to fail would be missing write permissions for the owner. You say that is not the case, so I'm out of ideas.

Does moving work on any other folder, did it work with an older xbmc/kodi version?
Did you try chmod 777 for a test?
Try it In the OS as the same user and see what happens. Ie on the commandline.

There is another thread somewhere recently with the same problem, can't find it right noe.
Yes, it worked in previous version of xbmc - 13.2. I've tested with 777 and still nothing.. with the command line it's working fine.
Any ideas?? It seems that something has changed in Kodi...
this smells like karlson2k's posixfile work.

EDIT: found, fixed and notified the offender.
Great !! This fix will occur in 14.3 version??
Hello guys! I have similar problem for quite some time. I'm using OpenELEC for several years. I tried on OE IRC channel but guys there told me it's a problem with kodi FileManager, not OE and to try to find help here. I tried kodibuntu 14 also and the problem is the same right after clean install.

I have OE 5.0.8 (kodi 14.2) installed on SSD and one additional HDD with data (one partition, EXT4 FS, owner)
On OE version 4.x (XBMC 13.x) everything works fine.

The problem occurs when trying to move files using kodi File Manager from one fs to another (from profile folder on SSD to Data partition on HDD).

Here are the logs: https://www.dropbox.com/s/j2js9enc1hbx26...7.zip?dl=0 and here is relevant excerpt from log on PasteBin: http://pastebin.com/JhX5YcrG

I hope this problem will be fixed soon. I'm stuck on old version of OE because of this problem. Smile

Thank you!
Pages: 1 2