Kodi Community Forum

Full Version: Vimeo v4.X.X - KODI 14.X Helix
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13
(2015-08-20, 11:58)bromix Wrote: [ -> ]Based on the log I can see no problem at all....can you try to switch to a lower video quality (addon settings). You're watching the videos in FullHD...just to compare the both cases and see if there is a difference.
I tried different quality settings - behavior the same. When playback starting - kodi closes.
Sad

Yesterday, Vimeo started falling for me.
Not all of it! Just the MY FEED section, returning only "VIMEO ERROR, CHECK LOG FOR DETAILS".

So I've uploaded my log here in case you feel like taking a look. As I say, everything else works fine! Hope it helps, running of the add-on starts about 3/4 down the paste. (I didn't have any good way to truncate the paste on this iPad).

http://pastebin.com/KhsDE0SF
Confused

Add-on Seemed to fix itself lately; (I was no longer getting the error when trying to view the MY FEED section).

But today, it lets me access the MY FEED, but I can't advance to PAGE 3 of the feed (the add-on is configured to show 50 results per page).

My first thought was to check the Vimeo site to see if it actually gives you more than 150 results (thought there might be a limit?) , but it seems to just keep going and going without a limit (or until your browser crashes under the pressure!) Big Grin

it's returning the same error as before. Here's a LOG:

http://pastebin.com/6yjXajuC
Why have you changed the default sort to "play count"? Can you please change it back to playlist? Though you seems to have made playlist sort worse too. Now it shows uploader first ("uploader - video name"). Is it really necessary to show the uploader at all? If I wanna know the uploader I can just use the context menu.

I was wrong, it seems the addon wasn't changed. Though it has to be updated to properly support 16.X.

Kodi 15.x
The addon has 4 sorts. Default (video title with duration, Date I guess), Duration, Title, Year

Kodi 16.x
The addon has 4 sorts. Play count (new "default"), Country, Playlist, Rating (new to 16.x, probably the reason sorts are messed up)
Vimeo / Group => Insufficient permissions The user does not have permission to do that
nothing displayed

Tried on 2 computeurs and 2 vimeo users

23:05:15 T:2136 NOTICE: [plugin.video.vimeo] Running: Vimeo (4.1.4) on Isengard (16.0) with Python 2.7.8
23:07:21 T:3560 NOTICE: Previous line repeats 3 times.
23:07:21 T:3560 NOTICE: Storing total System Uptime
23:07:21 T:3560 NOTICE: Saving settings
23:07:21 T:3560 NOTICE: stop all
23:07:21 T:3560 NOTICE: stop player
23:07:21 T:3560 NOTICE: ES: Stopping event server
23:07:21 T:3560 NOTICE: stopping upnp
23:07:22 T:332 NOTICE: ES: UDP Event server stopped
23:07:22 T:3560 NOTICE: stop sap announcement listener
23:07:22 T:3560 NOTICE: clean cached files!
23:07:22 T:3560 NOTICE: unload skin
23:07:22 T:3560 NOTICE: stopped
23:07:22 T:3560 NOTICE: destroy
23:07:22 T:3560 NOTICE: closing down remote control service
23:07:22 T:3560 NOTICE: unload sections
23:07:22 T:3560 NOTICE: special://profile/ is mapped to: special://masterprofile/
23:07:22 T:3560 NOTICE: destroy
23:07:22 T:3560 WARNING: Attempted to remove window 10013 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10014 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10015 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10016 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10017 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10018 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10019 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10021 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10107 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10115 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10104 from the window manager when it didn't exist
23:07:22 T:3560 NOTICE: closing down remote control service
23:07:22 T:3560 NOTICE: unload sections
23:07:22 T:3560 NOTICE: application stopped...
23:07:22 T:3560 ERROR: dllFreeLibrary - Invalid hModule specified

Nothing found in any forum :-(
(2016-03-05, 00:15)pascal92 Wrote: [ -> ]23:05:15 T:2136 NOTICE: [plugin.video.vimeo] Running: Vimeo (4.1.4) on Isengard (16.0) with Python 2.7.8

side note: Why does it say Isengard? It's actually called Jarvis.
Hmm, Vimeo has been removed from github. What's going on?

edit: Ah, bromix's not maintaining it anymore. Also, nobody forked it. Though I guess it's trivial to upload the latests release to a new project.

Lol, it seems I forked it by accident last year. I think it's the latest code. So, if someone want to maintain the addon you can fork it from here
Though I don't know why it's a fork from freeman212.

From the Youtube thread:
bromix Wrote:Because of private reasons I'll stop maintaining the addons at the end of this year (2015). Please fork the projects from GitHub or rewrite them completely. But I haven't the time or motivation anymore to do so, because other things in life got more important for me in the past 2 month.
Anybody have copy of endpoints? or fork of:
https://github.com/bromix/plugin.video.v.../Endpoints
Hi,

Fantastic to be able to use Vimeo on my Raspberry Pi3 OSMC in glorious 1080p...AMAZING.

Just one question though,is it possible to get videos in my feed to autoplay the next video?

When I bring up the contextual menu for the video,the only option I get is 'Play only this',which I'm assuming it should automatically be playing the the next video.This however is not the case,it only plays the one video I select.
(2016-01-28, 10:19)ioncype Wrote: [ -> ]Why have you changed the default sort to "play count"? Can you please change it back to playlist? Though you seems to have made playlist sort worse too. Now it shows uploader first ("uploader - video name"). Is it really necessary to show the uploader at all? If I wanna know the uploader I can just use the context menu.

I was wrong, it seems the addon wasn't changed. Though it has to be updated to properly support 16.X.

Kodi 15.x
The addon has 4 sorts. Default (video title with duration, Date I guess), Duration, Title, Year

Kodi 16.x
The addon has 4 sorts. Play count (new "default"), Country, Playlist, Rating (new to 16.x, probably the reason sorts are messed up)

I'm got the problem too :

In the watch later playlist, on kodi 15.x, the default sort showed the last added videos on the top of the list... now with Kodi 16 I cannot retreive this sort (very annoying) I just can sort by name, country, etc.... there's is no way to retreive the last added items on the top.
hi i am using vimeo on the following set up:
rpi3 - openelec 7 - kodi 16

i have a question about subtitles for videos on vimeo.
there are some videos on vimeo that can have subtitles, when watched from a web browser.
but the same videos from the vimeo addon in kodi do not have the subtitles.

is there something wrong in my vimeo addon settings or simply the addon cannot fetch the subtitles?

thanks a lot
:-(
Started experiencing Playback Error messages using 4.1.4 :-(

(Osmc 15.1) anyone else?
Is there a way to pass a vimeo video link to vimeo addon (through different addon) and play a vimeo video ?

'plugin://plugin.video.vimeo/?path=/root/explore/hd&action=play_video&videoid='+unicode(extracted_videoid)
Err... not quite clear what you're asking but here something I do...

On an android, use the app FILMO, is a good vimeo app. Find a vid you like, hit share, play on Kodi.
Hi PantsOnFire,

No actually we want to open link from Kodi addon and play with in Kodi ?

Is that possible ?
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13