Kodi Community Forum

Full Version: [SOLVED] Proper EPG character encoding for Hungarian
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have wrong characters displayed in EPG for my provider. It is a DVB-S2, and I believe they do not follow the DVB specification, that is the cause of the problem.
The language is Hungarian. How can I set the correct encoding for Hungarian language in VDR or to convert/force the encoding?

I read about charset override for vdr: export VDR_CHARSET_OVERRIDE="ISO-8859-15" but I'm not sure if this is needed for Hungarian language and where should I add this on OpenElec?
Using vdr-server + vdr-vnsi addon.

The other Hungarian provider I tested has proper EPG encoding.

Please help me, it is so annoying to have symbols displayed instead of Hungarian special characters, letters with accents like: ű ü ő ö í

EDIT: a quick question, related to EPG. I have a rotor system. Will vdr server move the rotor to grab epg when idle or will only grab epg when I select a channel on that satellite to watch?

VDR_CHARSET_OVERRIDE should be placed in the startup script of VDR. Since I don't use OE and not familiar with it, I can't give any advice on it.

Regarding the second question. Interesting question. I think so but can't try myself because I only have a single sat system.
(2015-03-07, 09:47)FernetMenta Wrote: [ -> ]VDR_CHARSET_OVERRIDE should be placed in the startup script of VDR. Since I don't use OE and not familiar with it, I can't give any advice on it.

Regarding the second question. Interesting question. I think so but can't try myself because I only have a single sat system.

Thanks! It is harder to follow these things on OE, so it doesn't matter at the moment. I will migrate vdr to a dedicated backend on Ubuntu server, so there I will be able to add charset override following your instructions. I believe that should be easy. Will return to this once I moved to backend server.

The PVR vnsi-addon does have and option: Character set conversion (Link) maybe that is the same option?

Anyway, for correct Hungarian charset I need to use the VDR_CHARSET_OVERRIDE="ISO-8859-15" line too, or it is just for German language?

Regarding the EPG scanning, we should ask it in the VDR forum, but mostly German language there, and unfortunately I don't speak GermanSad
It is not too good if VDR is moving the dish always to collect EPG on each satellite position too frequently, as it involves lot of moving if you have 6-10 satellites configured (although I use 3, max 4 of them).
I think we can test this also using the Live plugin. I put a multi satellite channels.conf with let's say 3 satellites configured. Then I use only one satellite. Leave VDR running for some time, and login to Live and see if EPG data is available for the 2 other satellites I never used. If there are EPG data populated, then VDR moved the dish to collect EPG data. If not, then it will start collection once I tune first time to the channel. But this is just an assumption.

One more thing: I have an up-to-date channels.conf file, converted from enigma2 channel list. I set update to name only as i have a single tuner, and I do not want VDR to add new channels and transponders from that satellite. I only want the provider I use, but VDR would add all the providers available on that satellite which I don't use at all. Not sure about option 2, where PIDs are also updated -- what does this actually do? I only see German description and can't figure it out even with translate.
If I have set it to 1 - name only, but then I got OBSOLETE added to some of my channels, but those channels are working. Not sure what this mean either.
I tried to add charset override but it seams it doesn't work. I still get ? where Hungarian charcters with accents should be.
Any ideas what ISO codepage should I use instead of 8859-15?
The problem is that one provider complies to the 8859-16 codepage, but the other not. So now I have an EPG where one Hungarian provider's text is correct, but the other is not. Do you think it is possible to have both correct?
OK, an update on this issue, and basically how to resolve this. I'm sure there might be other ways too, but this one works nice.

It turns out that actually it is UPC Direct who send correct EPG data and Digitv not. Well, even UPC doesn't complies with the proper DVB standard, as they do follow it, but use a very odd encoding for special characters (in Hungarian these are letters with accents). Problem with the UPC EPG is that they use non-spacing characters: the character is printed together with next character. This should be avoided, but of course UPC doesn't care about this at all.

- adding VDR_CHARSET_OVERRIDE="ISO-8859-16" doesn't solve the problem. It makes UPC EPG wrong. Without any charset override the UPC encoding is fine, however, Digi is not.

- I was not able to configure plugin epgfixer to fix UPC EPG, but more importantly, it is Digi EPG that needs to be fixed. Anyway, leaving VDR with default, not changing charset override results in proper EPG for UPC.

- in case of Digi, it is a complete mess. They have their own channels that broadcast EPG not at all following the DVB standards. They use 8859-16. This is why if you use charset_override set to iso8859-16 then part of the Digi EPG (their own channels) are correct. Here comes the tricky part and the mess! The channels they take over from other providers use different encoding... So if you set all the Digi EPG to iso8859-16, only some of the channels will work. Nonsense.

Thanks to Matti, the developer of epgfixer, I managed to fix this. You don't use vdr charset at all. UPC will be fine. Then for DIGI's own channels and some other channels (have to check which channels exactly), you override the encoding with epgfixer to iso8859-16. And here goes the correct EPG for both UPC and Digi!

I recommend using Channel ID in epgfixer since this way if you change the order of the channels you don't need to configure config file again.

One more important thing regarding Digi EPG: if VDR's EPG fix level is set to default 3, then all the information are removed from the description. I had to put it to 0 to have proper description. I'm not sure if level 1-2 would work, didn't tested yet. Anyway, I'm sure that it is Digi's fault again and they are broadcasting something wrong.

A sample for epgfixer's charset.conf file with channel DigiSport 1 HD and Viasat History:

DIGI Sport 1 HD HU;RCSRDS:11823:hC56M5O20S1:S1W:30000:4076=27:4100=hun@4:0:1802,1880:4020:1:13:0
Viasat History;RCS:12723:hC34M2O0S0:S1W:27500:548=2:698=eng@4,714=hun,3005=slo:0;910,974,960:1802,1880,B1C,1882:1358:1:2:0

The format is: channel Id1, channel id2:iso8859-2

"source-nid-tid-sid-rid" or "source-nid-tid-sid" (rid is not needed if 0)

Edit charset.conf:


Hope this helps and I believe this can be useful for non-Hungarian users too. Hard part is to find out provider's epg broadcast pattern.
Hello, could you translate this for me into Hungarian language, please?
I have got a VU+ Duo2 receiver with latest VTI image, but with very bothering EPG characters.
Thank you. Koszonom.
Sent a PM
Hello, somehow I can not reply to your PM. I meant to translate your solution, how did you succeed to sokve the EPG problem, si that I could do the same with my receiver Smile thank you
OK, it was not clear from your post. It relates only to VDR and to VDR plugin EPGFixer. I don't think it would work on VU+. You should ask for help in VU+ forums.

The trick is to force porper encoding for some providers which doesn't follow the DVB standard, like Digi.