Kodi Community Forum

Full Version: Raspbian + KODI on rPI 2, MCE remote issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am using a brand new rPI v2 (the one with four USB ports). I installed raspbian from NOOBS via the installer from the rPI website and then followed these directions to install KODI over Raspbian:

http://michael.gorven.za.net/blog/2012/0...g-raspbian

XBMC comes up at boot and everything "basically" works, except for the remote which is a little wonky. I am using a VCR-1100 remote http://www.ortek.com/html/program/produc...144331.jpg and some buttons aren't working. Like up volume works but not down volume for example. LIRC doesn't seem to be a part of this setup, but I installed it and tried dpkg-reconfigure lirc and no menu came up.

Here is /home/kodi/.kodi/kodi.log: http://paste.debian.net/160572/ non-debug enabled in kodi (which I can enable and repost).

Anyone else having this problem?
Pretty sure that remote is recognized as a keyboard. Shouldn't need LIRC at all. Have you tried re mapping the keys with the keymap editor addon? That might be all you need to do.
Edit: Nevermind looks like all the guides for that remote do use lirc.
So is there some FAQ on how to configure lirc for raspbian? Every time I do dpkg-reconfigure it just returns without presenting me a menu to pick the remote...
It should work. I would re ask this question maybe title it "dpkg-reconfigure lirc" not working in the raspberry pi section. Since that usually works fine in ubuntu for me(86_64 machine).
Not sure if you read the wiki article for that remote here VRC-1100 (wiki).
I think this will be seen as a mce keyboard like calev has said so lirc won't help you.
Have you tried the keymap editor addon yet as its the easiest option unless you know how to write a keyboard.xml file
I had similar problems with mine and followed this guide
http://draptik.github.io/blog/2013/05/24...-hama-mce/
But like I say it didn't help as it was a keyboard Sad
That keymap editor plugin is great! I used it to solve a few other problems on my other XBMC box (OK during playback = display mode, back button during playback = rewind 7 seconds)
So does that mean you sorted it then Smile
Hi guys!

I have the exact same issue. (I also have OpenElec installed - everything works properly there.)
Any news on a possible solution for this?

Thanks!