Kodi Community Forum

Full Version: RPI1-512 Audio Dropout playing HD multichannel music
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6
@fritsch

Do you want
Set Output to Fixed, 5.1 channels, samplerate 48000
only,
or with hdmi_samples_limit=384000 as well?

@popcornmix
I'll test your just after
@MrNice: Should not matter.
@fritsch

I did the test:
From fresh image, update to OpenELEC Isengard build #0328

Set Output to Fixed, 5.1 channels, samplerate 48000
Play in file mode, no browsing
1 drop (@~25 s) during 4 minutes
Then change to full screen and no browsing for 4 more minutes
No drop
http://xbmclogs.com/pdnlhgcol
Okay, thx - now please continue with the tests popcornmix is asking for. I think what the firmware does, this "workaround" does fixed.
@popcornmix

I downloaded you zip. This is not a usual firmware update, what should I do with it?
I really am a newbie
Copy start_x.elf and fixup_x.dat onto boot partition (e.g. what you see when plugging the card into Windows machine), renaming to overwrite the existing start.elf and fixup.dat.
Test done

From fresh image, update to OpenELEC Isengard build #0328
Changed start.elf and fixup.dat

Added to config.txt:
hdmi_mai_thresh=0x1412
Play in file mode, no browsing
1 drop (@~10 s) during 4 minutes
Then change to full screen and no browsing for 4 more minutes
No drop
http://xbmclogs.com/prw9vskls

See you tomorrow
(2015-03-29, 17:15)popcornmix Wrote: [ -> ]It looks like setting buffermode=1 is fixing my issue, so I think the current issue I have is just down to the pretty high bitrate of the file (6Mbit/s), the limited buffering in paplayer and my not-great network (I'm going through a wireless bridge at the moment).

Any other way of increasing buffering in paplayer?

There are more users here who have buffering issues with paplayer that are fixed with buffermode=1.
One reports he has buffering with lossless music, but can play Blu-Ray without buffering (this is with a NUC using wifi). So it might be worth considering increasing the buffering paplayer has by default.
Can you try to read a multiply of PACKET_SIZE?
I did try:
Code:
#define PACKET_SIZE (3840*10)    // audio packet size - we keep 1 in reserve for gapless playback
While it worked, it didn't fix the issue (in the way buffermode=1 did).
That really smells, that VFS is broken in a very nasty way.
(2015-03-30, 15:36)fritsch Wrote: [ -> ]That really smells, that VFS is broken in a very nasty way.

What is VFS?
(2015-03-30, 15:33)popcornmix Wrote: [ -> ]I did try:
Code:
#define PACKET_SIZE (3840*10)    // audio packet size - we keep 1 in reserve for gapless playback
While it worked, it didn't fix the issue (in the way buffermode=1 did).

that only defines max packet size to be read. won't help here
It does, if vfs has an issue with returning / fetching small values ... and it seems it had an effect.
(2015-03-30, 17:29)fritsch Wrote: [ -> ]It does, if vfs has an issue with returning / fetching small values ... and it seems it had an effect.

My comment was saying that increasing PACKET_SIZE didn't have any visible effect at all.
It didn't break anything, but it didn't fix the underflow issue (perhaps my comment was ambiguous).
Pages: 1 2 3 4 5 6