Kodi Community Forum

Full Version: Search function is broken?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Here is the one link from the search results.
and the error produces


You don't have permission to access /forum/showthread.php on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Thats the error I get trying to use the search.

For example I searched for "Search: Key Word(s): filezilla.xml, ftp, users"
It came up with 23 results and no matter what linked result I clicked on I recieved that error. At 1st I was not logged in, so then I logged in and still got the same error. So then I tried : "Search: Key Word(s): filezilla, ftp, users" and still got the same error.

Something is wrong server side and moving and merging this thread into some old thread is not going to fix the problem.
After some more investigation I've found a work around, which should also lead to a fix on the server.


This is the link the search turns up for this thread. If you look at the link you'll see '&highlight=FileZilla+Server.xml+ftp+users' at the end of the link. Now if you remove the highlight command portion of the link you wind up with http://forum.xbmc.org/showthread.php?tid=22218 and it works properly.
I tested this in seamonkey, ie6, and ie6-64bit and all of them had the same results. Then I found another interesting detail. If I searched for"FileZilla Server.xml ftp users" none of the result links worked. Then I searched
for"FileZilla, Server.xml, ftp, users" and all the links worked. For some reason the comma separating the search terms is the determining factor whether the search results work.

So there you go, i've done your work for you.
we were just too lazy to respond

issue was investigated yesterday and it was found that SERVER blocks GET requests if they contain certain KEYWORDS. it has nothing to do with search, it is "only" the highlightning that is affected.
The search and highlight works fine if you use comma's to separate the words.

So if you can't fix it just put a note on the search page: 'Use comma's to separate search terms if the search results don't work properly.'
i could take a look in the code and write a patch to use commas instead of +'s, but it will take some time to find the right portion of code.
Google.com search engine just uses spaces between words, and so does vBulletin (the forum engine we use). Also the same as google is the use of "AND" and "OR", nither of those should change http://www.google.com/intl/en/help/refinesearch.html
So what is the correct syntax to enter?

Just tried to search for "ftp AND speed"
It gave me a results page,
but then returns the 403 when I try to access any of the links

I also tried inserting commas; they were simply encoded into the resulting links as %2C and the links still didn't work (403 error).
ftp is a banned GET word on xbox-scene servers, so you cant do a search with it in the url, but you can use the search function on the forums its self, which uses POST.