Kodi Community Forum

Full Version: CEC settings being forgotten
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I seem to have a bit of a CEC issue where Kodi/OE isn't sticking to what settings are set. The behaviour seems inconsistent.

Setup is
HP Chromebox running OE 5.0.7 (happened with 5.0.6 too)
Pulse Eight CEC adapter (running on a powered USB hub to prevent booting issues)
Onkyo TX-SR309 (Chromebox attached the HDMI input 1)
Panasonic TX-P50ST60B (AVR attached to HDMI input 2 due to ARC)

When everything is working the CEC settings page shows the option to pick what the HTPC is connected to (AVR or TV), so it is set to AVR and HDMI port 1.

Every few reboots or resumes it will seemingly forget it is connected to an AVR and send the signal to change the TV to HDMI input 1.

When I go into the CEC settings the option to pick what it is connected to has disappeared.

Is this down to an HDMI handshake issue? It seems to be a fairly recent thing, because for some time I had everything working smoothly with regards to CEC.

Any ideas on this?

Is it possible to have the settings stick no matter what Kodi sees? To force it to think it's connected to an AVR?
I've also tried changing Physical Address to 5 and it doesn't save. Every restart it is back to 0.

Updated the CEC adapter to the latest v4 firmware.
Yeah I have a similar setup and have seen the same thing.

ASUS Chromebox (was OpenELEC 5.0.6 but switched to another distro for now)
Pulse Eight CEC adapter powered by hub
Onkyo HT-R393
Panasonic TC-L55E50

Someone has a different combo and just reported a bug so it doesn't seem to be just Onkyo + Panasonic:


I just got the HDMI handshaking to work reliably by using a custom kernel. Once I had that working I turned off CEC on everything and switched to a flirc + Logitech 650 so I didn't have to hear the dreaded "the tv's not working again".

My memory is foggy because of all the messing around/changing things up I've done but:

- I think connecting to the TV and just using ARC 100% of the time worked a lot better.

- I tried using a Raspberry Pi 2 for a bit and it seemed to be more reliable but had issues of it's own. CEC input would be laggy for like 15 seconds after turning the TV on. Also Panasonic requires being in "recorder" mode to enable the bottom media buttons on the remote but it would randomly go into "player" mode and those buttons would be disabled.

I do need/want to get CEC working reliably so I can use the TV's built-in Netflix/Amazon players.
Will hopefully have time to debug this weekend. Will let you know what I find out.
It would be great to see if you make any progress.

I've gone for a bit of a hacky fix for this, not sure why it works (someone may be able to explain).

I've got a few boot scripts/commands anyway to fix HDMI handshake problems. I now have two scripts in /storage/.config/sleep.d/ - both to restart Kodi and there is no real lag when resuming so no complaints.


case "$1" in
    systemctl restart kodi


case "$1" in
     sleep 2 && systemctl restart kodi

These seem to have solved the resuming issue. It's clearly a bodge but at the moment things are back to working so I don't have to hear the dreaded "the tv's not working again" either!

I personally don't want to use the TV remote. I've got a HP MCE remote which I like and use through an MCE IR receiver. My main reasons are to only have to use one remote (the MCE remote), to have everything turn on/off as required and to be able to control the AVR volume through Kodi.

I definitely felt I had things working smoothly until this hickup.
Hello mates,

This is me, who reported the issue 71 on libcec github. I have a different hardware setup and the common thing between us having this problem is ARC on the receiver.

I believe the problem is at libcec library level, rather than at Kodi, as I am reproducing the same behavior on both Kodi and libcec-daemon.

When I have ARC explicitly turned OFF - both Kodi and libcec-daemon reconnect to TV just fine after switching TV on.
But, with ARC being ON - both fail to reconnect after TV on. Kodi screensaver would not turn off until I select the hdmi cec source Kodi in TV source list - only then Kodi screensaver would go away and TV remote would work in Kodi.
If I restart either Kodi or libcec-daemon - CEC connection will be restored, so same scenario as you, Thomas.

I had this problem since I bought Pulse Eight cec adapter few years ago and on various OS (Windows/Linux), XBMC/Kodi versions, so this is not something that has recently been introduced. It never worked with enabled ARC properly in the first place.

Can you try disabling ARC on your Onkyo receiver and try to reproduce the problem again? Thanks
I only have it on the ARC HDMI input to allow me to very occasionally use the Smart features on the TV.

I'll try again without ARC and on different inputs.
I've also been having this same issue with Kodi, a Panasonic TV and a Denon AVR. I also have ARC from the TV to the receiver. It's still present in Kodi 17.0rc2 with libcec 4.0.1.