Kodi Community Forum

Full Version: tvheadend upgrade
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

I have a linux mint 17.1 laptop with Kodi 14.1 and I had tvheadend 3.4 installed and set up with Kodi and it worked except for channel mapping, a known issue. I upgraded to tvheadend 3.9 and I can set up the channels fine and the mapping works but I now can not get Kodi to see tvheadend. Any thoughts on this issue?

Thanks
Jon
Not without a log file, really... my guess would be that your access control has been borked somewhere in the upgrade, so Kodi no longer has username/password that matches anything that the tvh backend recognises. If that's the case, you'll have 'access rejected/denied'-type messages in your log file, plus tvheadend should see Kodi try to connect and then go away again. To get tvheadend's messages, open the web interface, click the arrows in the bottom right to view messages, click the little cog to enable debug mode.
When I first upgraded to Kodi Helix I found that the TVHeadEnd PVR addon no longer worked. However if I went into Synaptic and searched for packages with the word Kodi in them, there were PVR addons that could be installed there, one of which was for TVHeadEnd, and that one worked. So that is just a thought that may or may not be helpful.

Normally the TVHeadEnd addon doesn't require a login and password unless you have set up TVHeadEnd to require them, which most people don't if their backend will only be accessible from the local network, but I would make sure that the IP address of the backend hasn't changed.
Firstly I did check my tvheadend log and this is what it says.

2015-04-02 07:40:42.136 htsp: Got connection from 127.0.0.1

2015-04-02 07:40:42.136 htsp: 127.0.0.1: Welcomed client software: XBMC Media Center (HTSPv8)

2015-04-02 07:40:42.139 htsp: 127.0.0.1 [ XBMC Media Center ]: Identified as user jonsteckelberg

2015-04-02 07:40:42.139 htsp: 127.0.0.1 [ jonsteckelberg | XBMC Media Center ]: Privileges raised

2015-04-02 07:41:21.412 htsp: 127.0.0.1 [ jonsteckelberg | XBMC Media Center ]: Disconnected
Not sure what the "Privileges raised means?

xbmclinuxuser I was on Kodi before I started this and I do have the Kodi tvheadend addon. I have user name and password in tvheadend set and it was working before I upgraded my tvheadend.

Any more ideas to try? I probably need to post a kodi error log?

Thanks
Jon
Here is my Kodi log.
http://pastebin.com/RHLYYgnJ
Thanks