Kodi Community Forum

Full Version: Intel G45 VAAPI Deinterlacing (BOB) Support H264 & MPEG2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Guys,

I have configured the following system with Kodi 14.2.

System: Debian Jessie 3.16.0-4-amd64 x86_64

HP DC7900 Ultra Slim Desktop PC

CPU: Intel® Core™2 Duo CPU E8400 @ 3.00GHz

lspci:
Code:
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e12] (rev 03)
    Subsystem: Hewlett-Packard Company Device [103c:3036]
    Kernel driver in use: i915

Xorg.conf

Code:
Section "Device"
  Identifier  "Device0"
  Driver      "intel"
  VendorName  "INTEL Corporation"
  # a user reported, that this could cause high jumping fps in the menus when running on Ubuntu Raring
  # in that case set it to "uxa" instead
  Option "AccelMethod" "sna"
  Option "EXAOptimizeMigration" "true"
  Option "MigrationHeuristic" "greedy"
EndSection

Section "Screen"
  Identifier  "Screen0"
  Device      "Device0"
  Monitor     "HDMI1"
  DefaultDepth  24
  SubSection "Display"
    Depth       24
    Modes     "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]"
  EndSubSection
EndSection

Section "Monitor"
  Identifier  "HDMI1"
  HorizSync   14.0 - 70.0
  VertRefresh 24.0 - 62.0
  Option      "DPMS" "true"
  # you might have to tune the 23.97 modeline it is a bit of trail and run
  ModeLine         "[email protected]" 74.175 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
  ModeLine         "[email protected]" 74.400 1920 2558 2602 2758 1080 1084 1089 1124 +hsync +vsync #INTEL
  ModeLine          "[email protected]"    148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
  ModeLine          "[email protected]" 148.352 1920 1960 2016 2200 1080 1082 1088 1125 +hsync +vsync
  ModeLine          "[email protected]"    148.500 1920 2008 2056 2200 1080 1084 1089 1125 +hsync +vsync
EndSection

Section "Extensions"
  # fixes tearing
  Option      "Composite"           "Disable"


glxinfo | grep 'OpenGL version string':

Code:
OpenGL version string: 2.1 Mesa 10.3.2


vainfo:

Code:
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/local/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_37
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.37 (libva 1.5.2.pre1)
vainfo: Driver version: Intel i965 driver for Intel(R) Q45/Q43 - 1.4.1.pre1 (1.3.2-72-g2b002e2)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :    VAEntrypointVLD
      VAProfileMPEG2Main              :    VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:    VAEntrypointVLD
      VAProfileH264Main               :    VAEntrypointVLD
      VAProfileH264High               :    VAEntrypointVLD


VAAPI only runs fairly good with this configuration.

I can't select in H264 and MPEG2 the deinterlacing method, only with Xvid. What can I do?
I need deinterlacing mainly for live TV.
Post a Debug Log. Most likely no one has ever tested VAAPI-BOB on your hardware. I would suggest: "Disable Prefer VAAPI Render Method" - then you should be able to select normal Bob or even yadif (Deinterlace) for that CPU.
I would have liked to use hardware decoding. Am I the only one who an onboard graphics from Intel GMA 4500 used?

Below is the debug log file.

kodi.log

Not be disturbed by the xvdr error message had no tv tuner connected.
What fritsch has said won't disable hardware decoding, just hardware de-interlacing. They are two separate processes. You can keep VAAPI decoding enabled, but disabling VAAPI rendering will allow for software de-interlacing.
@hogin86: You don't have another chance anyways. Your GPU does not support VPP at all. So the mentioned solution is everything we can offer.

Edit: And btw. you can keep the Prefer Render enabled. It will be automatically switched off, if BOB or Deinterlace is chosen.
Ok, I have to settle for that. I still thanks for the help. Wink

Is it possible to deinterlace method for Live-TV regardless of the rest to define? I imagine that went with an older version XBMC.
I did not get that last question, you can always set "Save for all movies". Don't set Deinterlace to On, always use Auto