Kodi Community Forum

Full Version: On-Disc Subtitles
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm running Kodi 14.2 on an Amazon Fire TV to play ripped DVDs and Blurays (full disk images), and all's generally good there.

One difference compared to a Windows-based version though is that the control bar (the one that comes up when you hit the "Back" button with a playing video) has the navigation controls on, but AFAICS none of the icons for bringing up the windows for managing on-disc subtitles, audio/display options, etc... Similarly there doesn't seem to be a way of setting the default on-disk subtitle handling in the main System menu area.

This means that if a video's started and the subtitle setting turns out to be incorrect there's no quick way of changing it - you have to go back to the main disk menu and configure things from there.

Am I missing something here, or is changing the subtitle setting on a playing movie a feature that's not available on the Android version of Kodi?
These settings are exactly the same on Android as they are on Windows, Mac OS X, and Linux.
(2015-04-04, 21:07)Ned Scott Wrote: [ -> ]These settings are exactly the same on Android as they are on Windows, Mac OS X, and Linux.
Thanks for getting back to me, and sorry about the delay in my response (Easter rather interfered). While the settings might be the same as in the Windows version, I'm afraid I can't see any way of accessing them in Android.

While on Windows the control bar looks like this:

Image

...and clicking the icon highlighted in the previous image gives you the window with all the settings I'm after:

Image

...there's no such item on the Fire control bar, just the video playback buttons and a "Full Screen" option:

Image

And that window doesn't seem to be accessible from the general Settings area in either version. Unless I'm missing something here?
In the second screen shot you have exited the fullscreen window and are looking at the video playing in the background. Press the "Fullscreen" button and then you should be able to bring up the on-screen-display controls by pressing "select" on the FTV remote.
(2015-04-08, 08:05)Ned Scott Wrote: [ -> ]In the second screen shot you have exited the fullscreen window and are looking at the video playing in the background. Press the "Fullscreen" button and then you should be able to bring up the on-screen-display controls by pressing "select" on the FTV remote.
Ah - thanks Ned, that was (of course!) exactly what I needed to do...controls now accessible.

(Where I'd gone wrong was to stumble across the controls displayed in my third screenshot, then assume that was the only control option, and a replacement for the similar display under Windows. Which it wasn't. Thanks again!)