Kodi Community Forum

Full Version: Media importing and library integration (UPnP, Emby, Plex, ...)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2016-11-03, 20:59)Montellese Wrote: [ -> ]
(2016-11-03, 13:38)Hedda Wrote: [ -> ]
(2016-11-02, 12:43)Montellese Wrote: [ -> ]
(2016-11-02, 12:32)Hedda Wrote: [ -> ]@Montellese, not sure if forbidden topic but this concept could also work great with Plex Media Server too right?

That is, code for Kodi that imports metadata from Plex's MediaServer API, maybe ported from PlexKodiConnect (or PleXBMC), rather than UPnP?

https://forums.plex.tv/discussion/210023...your-plex/ ( https://github.com/croneter/PlexKodiConnect )

http://forum.kodi.tv/showthread.php?tid=92310 ( https://github.com/hippojay/plugin.video.plexbmc )
I actually looked at Emby and Plex Media Server but the Emby API is much better documented with swagger-ui so trying it out and using it was much easier. Apart from some unofficial documents and the existing Kodi addons I couldn't find any information about the API of PMS. I did some "reverse engineering" and managed to login, retrieve movies, tvshows etc. which should be enough but those were only manual tests and I first want to get the Emby import working properly before looking at PMS again. But it's certainly possible.
Missed it before but looks like Davilla have already written a client for Plex for the McMC project, see:


Perhaps that could be ported more easily then looking at the addons?
Yes I've been made aware of this as well this week. Thanks for pointing it out.
Just read here https://kodi.tv/plex-add-on-for-kodi/ and here https://www.plex.tv/blog/plex-media-play...kodi-said/ and also here https://www.plex.tv/apps/computer/kodi/ that an official Plex client addon has made it into the official Kodi repository. Nice surprise to hear that Plex too are still interested in Kodi as a frontend media player in their ecosystem.

So, sounds as if also Plex developers would now have a stake in seeing this work on media importing and library integration making it into Kodi's master core code, and maybe they would even be willing to step-up in assisting or and develop a such Plex client themselves?
Hi @Montellese, trying with latest Milhouse build, unfortunately it doesn't seem to work.
I added the upnp source (my other RPi in the Kitchen) to my Living room Kodi, but no import happens.
you write in your first post:
"Go to Settings -> Media sources -> Media imports -> By media providers and you should see a list of detected media providers by their name"
so in estuary I tried "Settings->Media Settings -> Manage Sources -> Videos -> Add Videos" and then chose the correctly detected upnp Provider, and saved.
But then nothing happens.
I also tried under "Settings->Media Settings -> Video Library -> Import library" and chose the upnp Provider (the other Rpi in my kitchen also with the latest Milhouse Build, still nothing happens.
So the question is:
How does "Go to Settings -> Media sources -> Media imports -> By media providers" translate to Kodi v18 (Milhouse wipupnp Builds) with Estuary skin?
(2016-12-18, 16:22)indri Wrote: [ -> ]How does "Go to Settings -> Media sources -> Media imports -> By media providers" translate to Kodi v18 (Milhouse wipupnp Builds) with Estuary skin?

You need to go to Settings -> Media sources -> Media imports -> By media providers
Sorry but I don't have that option in Estuary.. am I missing smth?
Are you using these on both machines?

Do you have Settings -> Media sources?
sadly no.. I have "settings" -> "media settings" and in "media settings" I have "manage sources"
that should not be the case. The Media import branch is using a modified version of estuary which should have an "Extra Setting" called Media Sources. Try reinstalling.
BTW @Montellese, which skin files are changed or added for Media Import?
There's no such option with this build, just reinstalled on both Pis:
Do you also have this build?
Yes on a RPi 2. It has the Media Sources as the last entry, bottom right. Column 4, Row 3
Make sure you do not have some manual update installed for Estuary
Thanks Martijn, I actually do have the latest git of Estuary manually updated.
well there's your problem