Kodi Community Forum

Full Version: Media importing and library integration (UPnP, Emby, Plex, ...)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2019-11-20, 19:29)LongMan Wrote: [ -> ]The New API is in the latest Beta of Emby Server, found Here. Choose Beta Channel
Thanks I've integrate
  • looking up the version of the Emby server
  • comparing it against 4.3
  • using the new UserData endpoint
(2019-11-21, 03:21)LongMan Wrote: [ -> ]My apologies. It does crash with debug logging. Steps
  • Media Providers
  • All Providers or Active Providers (no difference)
  • EmbyServer
  • Select Manual
  • Select User (TestSystem in my case).
Kodi Crashes immediately.

Logs Here

NB. It does not crash if the user is typed in. (Which I had started doing) 

Thanks for reproducing and investigating the issue. I've tried to reproduce your issue (I even completely deleted the media provider and re-discovered it) but everything works fine here  Undecided

I'll try to add some more debug logging so maybe we get some information before it crashes...
How can I obtain the zip file for the addon from your fork without downloading the entire repo?

(2019-11-22, 04:02)LongMan Wrote: [ -> ]How can I obtain the zip file for the addon from your fork without downloading the entire repo?

Unfortunately Github doesn't support this out of the box. AFAIK there are some helper tools / scripts which do this for you.
These logs show EmbyCon using the same user TestSystem connecting to the server.

After a fresh install of Kodi 19.0-ALPHA1 Git:20191121-3dff49d1d7 (Python-3 based), I downloaden the 'repository.beta.emby.kodi-1.0.9.zip' repository and installed Emby for Kodi 4.1.16 as instructed, but error-on-error occured and after reading the log, it as clear:
2019-11-23 21:51:21.613 T:8268   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <class 'AttributeError'>
                                            Error Contents: 'str' object has no attribute 'decode'
                                            Traceback (most recent call last):
                                              File "C:\Users\Huiskamer\AppData\Roaming\Kodi\addons\plugin.video.emby\default.py", line 15, in <module>
                                                __base__ = xbmc.translatePath(os.path.join(__addon__.getAddonInfo('path'), 'resources', 'lib')).decode('utf-8')
                                            AttributeError: 'str' object has no attribute 'decode'
                                            -->End of Python script error report<--
2019-11-23 21:51:21.625 T:7868   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.emby/?content_type=video
2019-11-23 21:51:21.630 T:1264   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.emby/?content_type=video) failed

probably due to a bug ?, please help !
Thanks & best regards,
@Peerke, Emby for Kodi will not work with Kodi 19 Alpha. Emby for Kodi only supports Kodi 18, right now.

Emby for Kodi forum is here.

Also this thread is for Media Import, a more generalized form of what Emby for Kodi does. We would welcome your helping us to test it. Stick around I think you will like it

I've uploaded a new test build at http://mirrors.kodi.tv/test-builds/windo...03-x64.exe.

You need to delete your MyVideos117.db file because the schema has changed.

I've made the following changes:
  • A video item can now contain the same actor in different roles. Before this was not supported by Kodi but Emby supported it which lead to unnecessary updates of video items during synchronization.
  • I've fixed setting / updating the playcount provided by Emby in the Kodi database.
  • The Emby mediaimporter add-on now tries to use the new API to update playback metadata if the Emby version is 4.3+.
  • There is now a "Test authentication" button in the media provider settings which will try to authenticate with the provided credentials and then shows a dialog with the result.
  • For the previous point I had to rework the whole integration of settings in the python API but it's now much more generic and could also be extended for other add-on types.
Can you post a link for the addon as well? I want to make a post in the Emby forums pointing here.
(2019-11-27, 03:14)LongMan Wrote: [ -> ]Can you post a link for the addon as well? I want to make a post in the Emby forums pointing here.
I'll provide the add-on as a separate ZIP download with the next test build.

I actually started working on a media importer add-on for Plex based on https://github.com/pkkid/python-plexapi. Having an already tested API wrapper makes it a lot easier to implement the media importer part of the code. I had to make a few adjustments to the python add-on API and to the internals but overall it worked quite well. I already implemented authentication using "Plex Link" (no username / password necessary in Kodi) and media importing. I haven't worked on auto-discovery, live observation or updating metadata on the Plex Media Server yet but I'll work my way through it one at a time.
Sweet. Happy to see it progressing. I had used plex previously so i think I can still post on the forum, so it would be good if you could post both addons. We should be able to get other testers.

I am a little distracted right now, trying to complete a project. However I have set up a machine with fresh install of windows to test with. Want to rule out that there is a problem with the computer that I was using. Maybe I can find some time on the weekend.

Thanks again,
I've started a new test build at https://jenkins.kodi.tv/job/WIN-64/11286/. The builds should be available soon at http://mirrors.kodi.tv/test-builds/windows/win64/.

You need to delete your MyVideos117.db file because the schema has changed.

I've made the following changes:
  • I think I finally tracked down and fixed the deadlock which sometimes happend during media provider discovery / registration / activation.
  • I've fixed some bugs I introduced in the Emby mediaimporter concerning authentication. @LongMan this might actually fix your issues.
  • I've extended the possibilities for mediaimporter add-ons to support manually adding a new media provider. Before Kodi asked the user for the URL and then passed that to the add-on. Now Kodi just tells the add-on to add a new media provider. For Emby this means that it asks the user for the URL (like it did before). For Plex it follows a completely different workflow.
  • As mentioned above I've added a mediaimporter add-on for Plex Media Servers. It supports the following features:
    • It uses the https://github.com/pkkid/python-plexapi python library with a few changes / additions: https://github.com/Montellese/python-ple...mmits/kodi and MyPlexPinLogin
    • Discovering local (same network subnet) Plex Media Servers (using GDM)
    • Manually adding a media provider for a Plex Media Server
    • Authentication can happen locally (no credentials required) or through MyPlex using the PIN login
    • Importing movies, tvshows, seasons, episodes and music videos from a Plex Media Server. Music videos are not fully supported because Plex doesn't know that media type.
    • Updating mark watched / unwatched on the Plex Media Server when it changes in Kodi. For now updating last played or resume point doesn't work.
    • Processing updates of library items happening on the Plex Media Server without a full synchronization.
Concerning the Plex mediaimporter add-on I've only performed basic tests since I'm not a Plex user. I only tested it with a local Plex Media Server installation over HTTP. I plan to provide the MyPlexPinLogin feature as a pull request to the upstream python-plexapi project.

The mediaimporter add-ons can be downloaded as ZIP archives from:
I am not what I am doing wrong but it is still crashing.

Dang I'll try to get the stack trace working. I haven't seen it crash in a while Undecided

But can you get it working by manually entering the username? IIRC that wasn't working either for you last time right?
If I choose Manual and enter the username and password, i can continue but it does not sync. BTW the new Test Authentication button says successful.

To to be sure that a have the right database, i added a link. Database.

Really want to get this working. I know it can be frustrating when you are so close. I am sure we will get there.