Kodi Community Forum

Full Version: Trying to make it work :)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I'm really intrigued by the whole RetroPlayer development.
Now, I was trying to test this (and perhaps just use it already), but I can't figure it out...

I tried building the project, which worked partially. The generated setup installs Kodi just fine, but it seems not all addons are succesfully built.

Also, when opening the Controller Configuration window (keyboard:T), I get the following error shown:

Image

Can anyone shine a light on what it is I'm doing wrong - or what I should (not) be doing in the first place?

PS: I'm not at all comfortable with all the "building" aspects, so all this CMAKE etc is really just crazytalk to me :$
First of all we need to know what platform you are building for.

Input/Controller addons and game emulator addons have to be built separately from Kodi right now so you'll need to perform some additional steps (which partly depend on your platform).
Since I'm working on a Windows laptop, i assume I can only build for windows? - which is what I did/tried Smile

I've followed the guide at http://kodi.wiki/view/HOW-TO:Compile_for_Windows, with the addition of running xbmc\tools\windows\prepare-binary-addons-dev.bat before compiling the installer.
(Honestly, I'm not really sure what I'm doing Confused I'm used to just downloading an install file and working with that :$)

My mediacenter itself is running OpenElec, so if I could compile for that, that would be nice as well of course. Or if I could compile in a VM or something, but I'm afraid I'll have to do even more things I don't understand... (Linux is not really my strong suit either...)

The more I think about it, the more it seems like a bad idea to even try all this Big Grin
I didn't know that you are working on a Windows laptop so I had to ask Wink And yes you can only build for Windows on Windows.

Running xbmc\tools\windows\prepare-binary-addons-dev.bat is not enough. It will create a Visual Studio solution at project\cmake\addons\build which you need to open and build to get the binary addons. But since the controller and game emulator addons haven't been integrated into our official binary addons yet that also has to be done manually. See the directories and files in project\cmake\addons\addons for how this is done for other binary addons. You will need at least https://github.com/kodi-game/peripheral.joystick for the controllers to work but it's broken right now.

So as you can see this is all still very much WIP and not for faint of heart.
Oke, that's clearing things up a little now...

However, I think I'll just sit this one out, and wait for a while untill a more "end-user-friendly" version is ready.

Keep up the good work guys, it still looks really really promising!
Hi!

I just had the same problem. Here some pointers which may help you:

1) make sure the peripherial.joystick addon is compiled and ready to use
2) make sure it is actually enabled. I noticed that in my configuration it was marked as "disabled" and I was not able to "enable" it. I think the state was wrong because at some point in the past the addon failed and was disabled automatically.

currently the only thing I end up with is a segfault though ;-)

*edit
I don't think I changed anything but after a couple of recompilations the segfault is gone. Current state: Game can be selected and played (with sound and joystick input) from the xbmc game menu, gamepad can be configured using kodi.
I decided to give it another go with Dippo's comments in mind, but still run into issue I cannot get my head around...

The addon build produces the following message(s):

Code:
1>------ Build started: Project: tinyxml (ExternalProjectTargets\tinyxml\tinyxml), Configuration: Debug Win32 ------
2>------ Build started: Project: kodi-platform (ExternalProjectTargets\kodi-platform\kodi-platform), Configuration: Debug Win32 ------
2>  Performing update step for 'kodi-platform'
3>------ Build started: Project: peripheral.joystick (ExternalProjectTargets\peripheral.joystick\peripheral.joystick), Configuration: Debug Win32 ------
3>  Building Custom Rule C:/kodigame/xbmc/project/cmake/addons/CMakeLists.txt
3>  CMake does not need to re-run because C:\kodigame\xbmc\project\cmake\addons\build\CMakeFiles\generate.stamp is up-to-date.
3>  Creating directories for 'peripheral.joystick'
3>  No download step for 'peripheral.joystick'
3>  No update step for 'peripheral.joystick'
3>  No patch step for 'peripheral.joystick'
3>  Performing configure step for 'peripheral.joystick'
3>  -- Checking to see if CXX compiler accepts flag -flto
3>  -- Checking to see if CXX compiler accepts flag -flto - yes
3>  -- Looking for include file syslog.h
3>  -- Looking for include file syslog.h - not found
3>  -- Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
3>  -- Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
3>  -- Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
...
3>  -- Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
3>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.CppCommon.targets(170,5): error MSB6006: "cmd.exe" exited with code -1073741571.

So the "peripheral.joystick" project building fails apparently, but I really have no idea to fix this. Any idea anyone? Confused

Thanks in advance.
A temporary fix for that issue is available here: https://github.com/Montellese/peripheral...mits/win32
But it means that a lot of joystick inputs won't work.