Kodi Community Forum

Full Version: Tried to make a seprate anime and TV series menus. Results are buggy.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm trying to get Kodi setup for the first time and one thing I wanted was separate menus for my anime and TV series. I've got these media on separate drives, so I was able to create smart play lists that only include media from select locations and from there, I made two favourites out of these playlists which I assigned to custom menus in Transparency!

There seems to be an issue with the menu though, I want it to be in fanart mode with banner icons, and this is how everything appears when I browse with the stock TV Series menu, like this:
Image

However, with my custom menus, it usually looks like this:
Image

The sub-menus are messed up too, it literally shows what folders are inside each series folder instead of showing each season with matching season cover art.

Sometimes it displays correctly, sometimes not. Sometimes it displays correctly if I browse via the favourites menu, sometimes not. Any idea how to solve this? Also, how do I mark a season/series/episode as watched? This was a two button affair on MediaPortal, but I can't work out how to do this in Kodi!
I think the second display is just the default set-up of a smart playlist and how it's handled. The background/fanart should be properly displayed if the jpegs are located in the folder with the media. Suggestion: instead of marking the playlist as a favourite, try marking the harddrive individual drives as TV sources and link that as a favourite and link that with the home page custom button.I've got these media on separate drives Just watch out you don't want to have the same source in more than one place in the library at the same time, or you will get duplicates.

Keyboard 'W' toggles the watched status, or using the 'C' context menu while a movie is in focus will offer unwatched/watched in the menu.
what type of smartplaylist did you create?
if you select the 'TV Shows' type, that fanart view with banners should work just fine.
(2015-05-31, 19:01)PatK Wrote: [ -> ]Suggestion: instead of marking the playlist as a favourite, try marking the harddrive individual drives as TV sources and link that as a favourite and link that with the home page custom button.I've got these media on separate drives Just watch out you don't want to have the same source in more than one place in the library at the same time, or you will get duplicates.
I've re-setup my favourites like this, but I'm still having the same problem. Sometimes when I open one of these favorites I get the fanart and banners, and sometimes it appears without the fanart and banners.


(2015-05-31, 22:49)ronie Wrote: [ -> ]what type of smartplaylist did you create?
if you select the 'TV Shows' type, that fanart view with banners should work just fine.
I didn't know there were different types of smart playlists :/ Either way, I tried simply choosing the video folder as a favourite instead of creating a smart playlist, but as above, I'm still having problems. Yes, both my TV shows and anime folders are set as "TV shows" hence the problem I'm having with both appears in the stock TV shows menu.
If you're creating a smart playlist inside T! using the make new smart playlist Smart playlists (wiki) you will see Type in the upper right a rolling menu for TV Shows, Episodes, Movies, Mixed or Music Videos. This will determine how the artwork will show and the listings. After you have created a Smart Playlist, check it for functionality, only when you're satisfied with it, do you make it a favourite... then proceed to favourites and see if it still functions well. With that part under your belt, you can make the link to the home page... at this point you should have sucess, if not then at which point was it failing?

My understanding is that, sometimes your graphics show up fine and it all works, then sometimes not? Even if you activate them from Favourites? How about directly as the source,in file mode? Something is not adding up, a debug log would help debug log (wiki)
(2015-06-01, 05:21)PatK Wrote: [ -> ]If you're creating a smart playlist inside T! using the make new smart playlist Smart playlists (wiki) you will see Type in the upper right a rolling menu for TV Shows, Episodes, Movies, Mixed or Music Videos. This will determine how the artwork will show and the listings. After you have created a Smart Playlist, check it for functionality, only when you're satisfied with it, do you make it a favourite... then proceed to favourites and see if it still functions well. With that part under your belt, you can make the link to the home page... at this point you should have sucess, if not then at which point was it failing?

My understanding is that, sometimes your graphics show up fine and it all works, then sometimes not? Even if you activate them from Favourites? How about directly as the source,in file mode? Something is not adding up, a debug log would help debug log (wiki)
Ah! That seems to have solved it, thanks a bunch! No idea why I didn't get these results when I tried smart playlist last time, maybe I wasn't setting the favorite correctly? I've also been able to solve the order of the custom menus by removing all the stock menus and making them all custom and putting them in the order I want.