Kodi Community Forum

Full Version: OneDrive for KODI (Officially in Kodi Addon Repository)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
@Jason1974 it's a known issue, and it's a Kodi issue. The kodi team is working on a solution.
I already reported it in this thread: https://forum.kodi.tv/showthread.php?tid=326622
Hello cguZZMan,

just tried to install the 2.01 but i get an "The dependency could not be satisfied...." when trying to install the zip file. I am using an Nvidia shield with SPMC http://spmc.semperpax.com/
Hi.
I just add this addon for google drive.

but I can't use in my TV.
TV can download app(kodi, and inside GoogleDrive for Kodi(your app))
but I can't add account because Authenticate(http://kodi-login.herokuapp.com) dosen't work..

here is the message.
"Your code is invalid. Make sure you entered the code displayed in Kodi and you're in the same network as your kodi device."
but I did type right code. and did 3 times..

How can I do?
(2018-02-21, 02:23)connou Wrote: [ -> ]Hi.
I just add this addon for google drive.

but I can't use in my TV.
TV can download app(kodi, and inside GoogleDrive for Kodi(your app))
but I can't add account because Authenticate(http://kodi-login.herokuapp.com) dosen't work..

here is the message.
"Your code is invalid. Make sure you entered the code displayed in Kodi and you're in the same network as your kodi device."
but I did type right code. and did 3 times..

How can I do?
This Addon is called "OneDrive for KODI"

Onedrive. Not Google Drive.
@jpdribbler SPMC is a Jarvis version. The addon was set to support Krypton and later. Let me see if I can upload a version supporting older versions of Kodi. Or you could change the addon.xml on both zips and it should work. See this post: https://forum.kodi.tv/showthread.php?tid...pid2689420

@connou Let's move the conversation to the Google Drive addon forum: https://forum.kodi.tv/showthread.php?tid=324784. Make sure you go to the URL displayed in your screen. It depends on the addon version you have. Also make sure you are connected to the same wifi as your kodi device. If you still have an issue, please post a message in the other forum thread.
OK Thanks.
anyway "Google dirve for KODI" auth page's support link page is here.

so if you can, fix link.
@cguZZMan:

Thank you. My fault. Do not invest too much time in it. I can switch to official Kodi or wait until SPMC has released a krypton version, they already started beta builds https://github.com/koying/SPMC/releases
hello to all,
my challenge is that i could not open folder.
working with kodi 17.6 with the addon 2.0.0 by carlos, the all main folder i can open.
only the final folder where are my photos located will not open, this is strage because i have on five different devices kodi and from all of them there is no problem to open this folder. there is no error or some massages the macine is just running and running without open the folder. the login cretitals are ok otherwise i could not open the main folders, i already deinstall and install again without success.
any tip or idea?
hello to all,
my challenge is that i could not open folder.
working with kodi 17.6 with the addon 2.0.0 by carlos, the all main folder i can open.
only the final folder where are my photos located will not open, this is strage because i have on five different devices kodi and from all of them there is no problem to open this folder (even it shows me the amout of files). there is no error or some massages the macine is just running and running without open the folder. the login cretitals are ok otherwise i could not open the main folders, i already deinstall and install again without success.
any tip or idea?
@trekstore can you tell me if you still have the issue? 
If so, can you please post the log of your Kodi so I can see what's happening? You can follow these steps: https://kodi.wiki/view/Log_file/Easy to upload your logs easily.
Then just paste here the link you your log file.
Hello I have this issues after enter the herokuapp code, onedrive login and password.

I replace some number and letter with XXXX because I don't know if it's secure.

Config : OSMC 17.6 on rasberry Pi 2.

I test with Firefox on my phone and Firefox PC and edge on PC, same problem.

Sorry for my poor english.

Page : https://kodi-login.herokuapp.com/callback

Authentication failed:

{"error":"invalid_request","error_description":"AADSTS90002: Tenant XXXXXXXXXXXXXXXXXXXXX not found. This may happen if there are no active subscriptions for the tenant. Check with your subscription administrator.\r\nTrace ID: XXXXXXXXXXXXXXXX\r\nCorrelation ID: XXXXXXXXXXXXX\r\nTimestamp: 2018-04-06 11:12:52Z","error_codes":[90002],"timestamp":"2018-04-06 11:12:52Z","trace_id":"XXXXXXXXXXXXXXXXXXXX","correlation_id":"XXXXXXXXXXXXXXXXXXXX"}
@JohnJohn45 Can you please post the complete log of your Kodi so I can see what's happening? You can follow these steps: https://kodi.wiki/view/Log_file/Easy
And then paste here the link you your log file.
Hi,

I coded my app to use OneDRive as source and got this error:

20:20:46.696 T:5756 NOTICE: VideoPlayer: Opening: http://localhost:8585/Bata%20Band/Public...00/001.mkv
20:20:46.696 T:5756 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
20:20:46.911 T:5756 ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 104 for 1.
20:20:46.911 T:5756 ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 105 for 1.
20:20:46.911 T:7360 NOTICE: Creating InputStream
20:20:47.315 T:7360 ERROR: CCurlFile::Open failed with code 404 for http://localhost:8585/Bata%20Band/Public...00/001.mkv
20:20:47.722 T:7360 ERROR: Previous line repeats 1 times.
20:20:47.722 T:7360 ERROR: XFILE::CFileCache::Open - failed to open source <http://localhost:8585/Bata%20Band/Public/bataband_mkv_song_folder/00/001.mkv>
20:20:47.722 T:7360 ERROR: CVideoPlayer::OpenInputStream - error opening [http://localhost:8585/Bata%20Band/Public...00/001.mkv]
20:20:47.722 T:7360 NOTICE: CVideoPlayer::OnExit()
20:20:47.737 T:5756 ERROR: Playlist Player: skipping unplayable item: 0, path [http://localhost:8585/Bata%20Band/Public...00/001.mkv]
20:20:47.754 T:5756 NOTICE: CVideoPlayer::CloseFile()
20:20:47.754 T:5756 NOTICE: VideoPlayer: waiting for threads to exit

Can someone give me a hint of what's wrong and how to correct this.

Thanks so much.
@caosu

Please read and follow the instructions for posting logs and snippets: Do not post logs in the forum. Use https://paste.ubuntu.com/ or similar. Thanks.
@Klojum  - Sorry to include a tiny portion of the log.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20