Kodi Community Forum

Full Version: Forced Subtitles
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a question about forced subtitles. I have several MKV files containing forced subtitles. Normally the behaviour of Kodi is as I would expect it:

If I have e.g. a file containing the following subtitle tracks:
- German, Default No, Forced No
- German, Default Yes, Forced Yes
- English, Default No, Forced No
- English, Default No, Forced, Yes

...the default audio track is German, the German subtitle track with forced subs is automatically activated.

When I switch the audio track to English, the English subtitle track containing forced subs is automatically activated.

Excellent behaviour, just as expected.

But if I have a file containing the following subtitle tracks:
- German, Default No, Forced No
- English, Default No, Forced No
- English, Default No, Forced, Yes

...the default audio track is again German, but the English subtitle track with forced subs is automatically activated.

Why is that? The track is neither marked as default, nor is it matching the language of the selected audio track.

Is there any way to change that behaviour, so that the English subtitle track containing forced subs is only activated if the English audio track is selected?

AMiGAmann
In the wiki (Subtitles (wiki)) I found the following description:

Quote:As of Gotham, Kodi recognizes and respects the forced flag for showing subtitles (even if subtitles are turned off by default, the forced flag will trigger them being turned on). This requires that the user have set the default languages in Settings in order to function properly. If there are multiple forced subtitles, Kodi will select the forced subtitles that match the default playback language.

But should Kodi not take the language of the selected audio track into account? Like in the example described above: if the language of the audio track is German there is no need to automatically show forced subtitles of a different language when there are no German forced subs.

AMiGAmann
Nobody with a hint why Kodi is displaying the (in my opinion) wrong subtitle track automatically?
No idea, but maybe as it works when you set a default flag, you should do the same with the mkv which doesn't have a default flag.
You can edit this without having to remux the whole movie.
Of course if you have a lot of movies with that behavior it could take a while.
Using a script with mkvtoolnix could do the trick.
Possibly because everyone thinks the default behaviour should be different, so something has to be chosen.

But it is just one remote button press to change to the next subtitle track...
Quote:No idea, but maybe as it works when you set a default flag
But the subtitle track actually is not default, because it does not belong to the default audio track.

Quote:Possibly because everyone thinks the default behaviour should be different
But why? Audio track with default-flag is chosen and subtitle track of different language with forced flag = true? Strange IMHO...
I believe the behavior is that if there are two forced tracks, then language is used to figure out which one is the correct one. If there is only one forced track, then language is not used and that track is played. The rational behind this is, why else would you have a forced track there? Either embedded or externally? If there is a forced track then it is assumed you want at lease something to be, well, forced. That is the point of a forced track.

Maybe this is the wrong logic to have. I don't really have an opinion on it.
In the first posting I said

Quote:...the default audio track is German, the German subtitle track with forced subs is automatically activated.

When I switch the audio track to English, the English subtitle track containing forced subs is automatically activated.
I don't get this to work with current Kodi anymore. My settings:
- Preferred Audio Language: Original Stream's Language
- Prefer default Audio Streams: Enabled
- Preferred Subtitle Language: Original Stream's Language

When I have a file containing the following subtitle tracks:
- German, Default No, Forced No
- German, Default Yes, Forced Yes
- English, Default No, Forced No
- English, Default No, Forced, Yes

default German/German is selected. But when I switch the audio track to English, the English forced subs are not selected (anymore).

Did the handling meanwhile change?
Nobody else fighting with forced subs?
I have feeling that the overall handling on language selection has not changed yet.
Perhaps you can open a ticked at https://trac.kodi.tv with all possible info.
(2018-09-21, 19:48)AMiGAmann Wrote: [ -> ]I did: https://trac.kodi.tv/ticket/18050#ticket

I can't get Leia 18.4 to obey forced subtitles at all. I have to manually select them. Not a great pain but it does mean stopping the film, finding and enabling the forced sub track, rewinding and replaying the bit with foreign audio. No good when it's film night!

Krypton works fine, so I'm reverting to that.
@Yearofthegoat

Read here... 2861861 (post)

Forced - <VideoFileName>.eng.forced.ext - Kodi will load this automatically
Default - <VideoFileName>.eng.default.ext - Kodi will load this automatically if Forced subtitles are not available
Other- <VideoFileName> .ita.<unique>.ext - Will be available for selection from the Subtitles list. <Unique> is just anything to make the filename unique and allow more subtitle files to be added.
(2019-10-16, 23:49)Karellen Wrote: [ -> ]@Yearofthegoat

Read here... 2861861 (post)

Forced - <VideoFileName>.eng.forced.ext - Kodi will load this automatically
Default - <VideoFileName>.eng.default.ext - Kodi will load this automatically if Forced subtitles are not available
Other- <VideoFileName> .ita.<unique>.ext - Will be available for selection from the Subtitles list. <Unique> is just anything to make the filename unique and allow more subtitle files to be added.
Hi, thanks but these aren't subs in a separate file e.g. .SRT, they're from the blu-ray disc in an .MKV container. (sorry if I've misunderstood).


(P.S. @Karellen sorry for the duplication in the other thread; IIRC I found this afterwards which seemed more relevant)