Kodi Community Forum

Full Version: HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Post #205 (setup for 4k) shows pictures for MPC-BE settings.  The 1st couple pics are for remote commands.  I should change the 2nd picture.  Although it really doesn't matter for me, in your case it MIGHT.  I prefer to stop before I kill for some testing purposes but for others it's not critical that I know of.  Notice where it shows the 'stop' key is 'X' and the 'exit' key is 'Alt + F4'.  They should both be 'X' or they should both be 'Alt + F4' not a mix.  Look for any other instances of Alt + F4 or X.  They too will need to be changed.  Try each.  My Harmony is not an Ultimate.  It's a 900.  They work differently.  Alt + F4 on the 900 kills any window that is in focus including MPC.  Kodi is under it so now it becomes focused and ready for use.  Your Alt + F4 command is just closing instead of killing.  Perhaps because Alt + F4 needs to be (pressed) at the same time and not in sequence.  Changing the key settings in MPC may help you with this.

I don't know about your specific display and color reproduction?  One thing is for sure, if your dedicated player using the disc and your file setup look identical, and you have taken your AVR out of the equation, your display settings are at fault.  I assume you are not using long cables?  If you are, temporarily move your HTPC and/or your dedicated player, or your display closer to each other and use ANY cable 6' or under to test.  If it improves, it's your longer cables.  If it doesn't, it's your display settings.
(2018-01-21, 21:24)gotham_x Wrote: [ -> ]
(2018-01-21, 19:26)bsoriano Wrote: [ -> ]Do you know if there is anyone that is playing 4K HDR movies through Kodi the way we are, using a LG OLED TV hooked via an AVR? I ask, since I am looking at a 55 inch LG OLED B7.

Anyway, thank you so much for your help.

Regards,

Bart
 All my 4K / HDR movies they are reproduced through Kodi ,  obviously , with external players  as MPC-BE , MPC-HC and PotPlayer and maybe even with PwerDVD , my GPU connection it's direct  to a TV OLED LG-55C7  from one of the 2 doors HDMI  of my graphics card  nVidia 1080 Ti. The second  and remaining door  HDMI of the  GPU is connected to a AVR Pioneer , just to pass the audio multimedia HD. with HDMI 1.4 it passes only 4K to 30Hz. is unprovided of  passthrough video HDR , not having door HDMI 2.0 and HDCP2.2. with cables HDMI High-Speed .
Then , It depends on the specifications of your AVR. If HDMI 2.0 and HDCP2.2 they are not supported on the AVR , I believe it is the only solution to be adopted .

Thanks gotham_x!

My Yamaha RX-V683 AVR has HDMI 2.0, HDCP2.2 in multiple HDMI ports, including the one to use as the one connection to the TV, so perhaps I could do just one connection.

Are you happy with the colors, saturation and HDR of your HDR movies? Could you share what settings you are using in your TV that you had to change from the defaults?

Thanks again.

Regards,

Bart
My Oled panel is still in the running-in phase , after 200 hours of use it is waiting for a calibration , anyway , for 4K / HDR content the panel automatically selects the HDR image mode ,  the only change I've made is , Cinema (User)  at most , lower the contrast to 85 from 100 , do not touch absolutely , oled light and  brightness and ACTIVATE Deep Color for AVR and oled panel. Then  , first thing to do is to turn on Deep Color for the HDMI port where you intend to connect your HDR UHD , The beginning of  Passengers is  joy for the eyes .

I see my 4K / HDR content beautifully , and with a cable length  HDMI High-Speed of 10 meters from PC to Oled TV.
(2018-01-22, 00:32)gotham_x Wrote: [ -> ]My Oled panel is still in the running-in phase , after 200 hours of use it is waiting for a calibration , anyway , for 4K / HDR content the panel automatically selects the HDR image mode ,  the only change I've made is , Cinema (User)  at most , lower the contrast to 85 from 100 , do not touch absolutely , oled light and  brightness and ACTIVATE Deep Color for AVR and oled panel. Then  , first thing to do is to turn on Deep Color for the HDMI port where you intend to connect your HDR UHD , The beginning of  Passengers is  joy for the eyes .

I see my 4K / HDR content beautifully , and with a cable length  HDMI High-Speed of 10 meters from PC to Oled TV.
 Thank you gotham_x!

Once I change my tv, I will post my results.

Regards,

Bart
(2018-01-21, 21:45)brazen1 Wrote: [ -> ]Post #205 (setup for 4k) shows pictures for MPC-BE settings.  The 1st couple pics are for remote commands.  I should change the 2nd picture.  Although it really doesn't matter for me, in your case it MIGHT.  I prefer to stop before I kill for some testing purposes but for others it's not critical that I know of.  Notice where it shows the 'stop' key is 'X' and the 'exit' key is 'Alt + F4'.  They should both be 'X' or they should both be 'Alt + F4' not a mix.  Look for any other instances of Alt + F4 or X.  They too will need to be changed.  Try each.  My Harmony is not an Ultimate.  It's a 900.  They work differently.  Alt + F4 on the 900 kills any window that is in focus including MPC.  Kodi is under it so now it becomes focused and ready for use.  Your Alt + F4 command is just closing instead of killing.  Perhaps because Alt + F4 needs to be (pressed) at the same time and not in sequence.  Changing the key settings in MPC may help you with this.

I don't know about your specific display and color reproduction?  One thing is for sure, if your dedicated player using the disc and your file setup look identical, and you have taken your AVR out of the equation, your display settings are at fault.  I assume you are not using long cables?  If you are, temporarily move your HTPC and/or your dedicated player, or your display closer to each other and use ANY cable 6' or under to test.  If it improves, it's your longer cables.  If it doesn't, it's your display settings.
Thanks brazen1!

I tried having both Close and Exit be Alt+F4, but MPC-BE did not seem to like this and highlighted one of them and did not let me save the settings.  I will try other keys for both Close and Exit, that do not involve Ctrl or Alt, just in case the behavior of my Harmony Ultimate is not correct.

What device are you using for the keyboard in your Harmony configuration?

I do have a 15 ft cable going from my AVR to my TV, so testing with shorter cables is something I will try and see the results.  I recently ordered new cables which have the certified premium label and are listed in the HDMI site.  Once I have them I will test and post my results.

Thanks again,

Bart
I seriously doubt MPC-BE won't let you change a key.  I don't think you went about changing the key in MPC correctly.  You should be selecting 'clear'.  After that you click the little box to the right.  Then type exactly what key(s) you want, in this case, press ALT + 4 and it fills in.  Then save.  I think there is only one MCE Keyboard.
(2018-01-22, 18:21)brazen1 Wrote: [ -> ]I seriously doubt MPC-BE won't let you change a key.  I don't think you went about changing the key in MPC correctly.  You should be selecting 'clear'.  After that you click the little box to the right.  Then type exactly what key(s) you want, in this case, press ALT + 4 and it fills in.  Then save.  I think there is only one MCE Keyboard.
Thanks! I will try tonight when I get home.

Regards,

Bart
I have everything working for iso 3D playback via PDVD but my issue is if I want playback a sbs or ou mkv or mp4 in the Kodi player, the resolution is staying at 4K and the 3D options in my TV menu are not available as the resolution is not supported for 3D. Has this issue been discussed in this thread ? It's hard to search on "sbs" as the string is not long enough.

Am I better of playing sbs content via PDVD as well if I have Kodi setup for 4K?
I've never heard of this problem before?  What make and model display are you using?
SBS or TAB default to Kodi videoplayer.  (they also work with MPC-BE) 
I select the title, it opens, my display switches into SBS or TAB mode automatically (I can select '3D' mode on my display if it didn't) and the title plays at 3840x2160 24Hz.
I don't recommend playing mkv with PowerDVD because refresh rate will not match so they only play at 60Hz.
So I finally got a chance this week to sit down and finagle with the various options & propositions to do with getting UHD HDR MKV playback to work on my GT 1030 / i5-2600K machine with Kodi. 

Ultimately, in a nut shell, the following is what I was able to achieve.

#1
Windows HDR --> OFF
Under LAV Video Configuration -> Hardware Acceleration
If I set "Hardware Decoder to use" to "DXVA2 (Native)"
This method allows LAV/MadVR/MPC-BE to playback UHD HDR MKV flawlessly! No skipping. No lag. No frame rate or choppy playback issues. Playback is absolutely smooth. 
HOWEVER -- The PQ is just not that great! Colors are no different then watching a non-UHD, non-HDR media. 

#2
Windows HDR --> OFF
Under LAV Video Configuration -> Hardware Acceleration
If I set "Hardware Decoder to use" to "DXVA2 (Copy-Back)"
This method allows LAV/MadVR/MPC-BE to playback UHD HDR MKV with choppy playback issues. Playback is jerky. It's not as bad as I originally encountered. This is more like when you try to play 24p video on a 60Hz refresh rate - maybe a little more jerk then that.   
HOWEVER -- The PQ is phenomenal! Colors are great! I can tell it's very different then non-HDR media. 

For both above tests,
"Trade quality for performance" all boxes were checked;
almost all other options were either the "default" MadVR or the ones suggested by brazen1 in post #205. 
Chroma upscaling was Cubic
Image downscaling was Cubic
Image upscaling was Lanczos

I tried some other settings randomly but they only made playback worse. 

Lastly,

#3
Windows HDR --> ON
Playback UHD HDR MKV in PowerDVD 17
Absolutely flawless media playback - Smooth - No choppiness/jerk.
Absolutely phenomenal PQ. Superb colors. I can tell HDR is working properly. 

The only drawback of this issue is, I have to turn HDR in Windows Display Settings On & Off manually before & after media playback. 

----------

If I had to pick a method to use on my machine today, I would most certainly go with method #3. Despite having to turn HDR On & Off, as I get absolutely flawless media playback with superb PQ & Colors. 

Ideally, I would love if method #2 could work - if I could somehow get rid of the choppiness and jerk in motion. Since no manual HDR On/Off intervention is required. 

I don't seem to quite understand why LAV/MadVR/MPC-BE cannot play back the same media on the same machine and produce the exact same picture quality & colors --- that PowerDVD can? In other words, why does GT 1030 fail to produce the exact same results in MPC-BE/MadVR, but produces brilliant results in PowerDVD? I've compared the PQ between the DXVA2 (Copy-Back) method & PowerDVD method and neither of the two is superior - they are pretty equal. So I have to relent that GT 1030 is fully capable of UHD HDR MKV playback. 

Really wish I could get method #2 to work. But for now, I'll stick with method #3 unless I can figure out otherwise. 

Thanks.
Hello brazen1,

Just to report that I got everything working great, thank you for all your help and advice.  I changed the Exit key to be just one key (I am using F7) and that works great now to exit MPC-BE.  I am also using the arrow keys to jump forward and backward, and Home to jump to the beginning of the movie.  I also find useful seeing how much time is left in the movie, and I am using I for that. Play/Pause with space bar works great too.

I replaced my HDMI cable from the AVR to the TV, and the one from my HTPC to the AVR with premium certified cables, and they definitely made a difference, since when I play 4K HDR movies the colors are now great! I have been able to even see when a 4K HDR rip is not really HDR, which is good.  I also replaced my GTX 1050Ti with a GTX 1060 6GB, and now the render times in MadVR are under 20ms.

Any advice on "higher" MadVR settings I could use to take advantage of the extra power of the GTX 1060? Again, I am only playing 2160p media with MadVR, so no upscaling is being done.

Thank you again!

Regards,

Bart
For 2160p, I turn everything in Image Upscaling down as far as possible since no upscaling is needed and save resources.  Then turn everything in Chroma up as high as possible using NGU Sharp High and not Very High since there is no gain for the extra RAM that would be used.  (exactly the opposite of 1080p and lower)  Then, if further refining is desired, you could experiment with Image Enhancements in processing/artifacts tab.  I can't use them with 2160p since my GPU isn't strong enough.  Curious if you can enable any of them with that GPU whether you use them or not.

When customizing key assignments, try to correlate them with Kodi, PDVD, MPC, and any other players so they all work the same with each other.

Fwiw, here are the values I entered for skip forward and skip back using arrow buttons under Miscellaneous:  3000, 10000, and 60000.  If you pause, and press the ^ key, you now have single frame advance.  Holding it down is real time as well.     

Don't forget to set up subtitle positions under rendering:   Enable Override Placement.  50 and 92 works well for me.  I also changed the font to Tahoma.
(2018-01-29, 17:49)brazen1 Wrote: [ -> ]For 2160p, I turn everything in Image Upscaling down as far as possible since no upscaling is needed and save resources.  Then turn everything in Chroma up as high as possible using NGU Sharp High and not Very High since there is no gain for the extra RAM that would be used.  (exactly the opposite of 1080p and lower)  Then, if further refining is desired, you could experiment with Image Enhancements in processing/artifacts tab.  I can't use them with 2160p since my GPU isn't strong enough.  Curious if you can enable any of them with that GPU whether you use them or not.

When customizing key assignments, try to correlate them with Kodi, PDVD, MPC, and any other players so they all work the same with each other.

Fwiw, here are the values I entered for skip forward and skip back using arrow buttons under Miscellaneous:  3000, 10000, and 60000.  If you pause, and press the ^ key, you now have single frame advance.  Holding it down is real time as well.     

Don't forget to set up subtitle positions under rendering:   Enable Override Placement.  50 and 92 works well for me.  I also changed the font to Tahoma.
Thanks brazen1, I will try these settings and let you know how it goes.  I had already set the subtitle positions as per your guide, and assigned the green button in my remote to S, which is next subtitle in MPC-BE.  The red button in my remote I assigned to T, which turns subtitles on/off.

Regards,

Bart
Hello brazen1,

I tried some of the settings (NGU Sharp High for chroma, I turned on some of the image enhancements), and now the rendering average is about 34ms, but goes as high as 45ms.  There are a lot of dropped frames (for example, 134 in the first 6 minutes of Ghost In The Shell), and the image, in my eyes, is not noticeably better.  Perhaps I need to try a specific combination of the image enhancements.

I will turn off all of the image enhancements and see how that goes.  When you mentioned earlier to turn down upscaling as much as possible, what would that look like for the "doubling" setting? Right now I have NGU sharp for that.

Thanks!

Bart
I don't think 2160p needs to be doubled unless you are using an 8k display so I just have mine on Jinc for scaling since there is no 'none' to select.  I also don't think you need any image enhancements but I was curious if using any with 6GB's of RAM even made difference.  Evidently the same happens to you as me using 4GB.  When 8k comes around, this might have some meaning but not now imo.  Are you able to select even one enhancement such as RCA?  I can't or I drop frames.