Kodi Community Forum

Full Version: HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
found it. Autoplay OFF. How many redundant places do they have to put settings ?!?

But MPC-BE complains "disc F: not mounted" when I cleary find it mounted, and if I use the menu to open it, it actually does play. I think I need to slow the MPC-BE bootup down a bit.
Yes, you do have a problem.  For diagnosing (no Kodi involved, no code files involved, everything is manual), I right click an iso within Windows Explorer and select 'Open with'.  Then I select 'Mount files with Virtual Clone Drive'.  The files mount and nothing else occurs and that's all that should occur.  No idea why PDVD then automatically opens for you?  Have you tried simply double clicking your iso and let Windows mount it, bypassing VCD?  Does PDVD open then too?  It shouldn't.  I understand you have went through settings and determined nothing is associated with PDVD and iso's but it sure sounds like something is.  Right click an iso.  Select 'Open with' and then 'Choose another app'.  'Windows Explorer' should be at the top of the list and 'Always use this app to open iso files' should not be checked.  I'll bet PDVD is selected there.  Type 'autoplay' in your search box.  Make sure everything is off.  On the right hand side is 'Default app settings'.  Make sure 'Video player' is MPC-BE x64.  Now scroll down to 'Set defaults by app'.  Select PDVD 'Manage'.  There should not be any instance of PDVD in that list of files but plenty for MPC-BE, Photo Viewer, Movies and TV, etc.  'iso' should be defaulted for 'Windows Explorer'.

Whoops.  I see you answered your own question and now you have a new one.  Change the value here in the MPCBE3DISO.bat to 3 or 4 if it's a 3D.  You didn't say?  "timeout /t 2".  Maybe MPC-BE is launching before your data drive is fully spun-up and mounted.  I would bet a subsequent attempt works just fine indicating your drive is fully spun-up the 2nd attempt.
Yes, I agree with that theory. The MPC is so fast it's almost blinking before I press the button (lol.) But AnyDvd flashes after the error saying it's done reading the drive. It's maybe 0.5 seconds behind MPC.

I've tried quite a few things - swapping the VirtualCloneDrive line above the Nvidia line. I've tried the timeout to be 15 on the Nvidia line (just to see.) I've tried adding timeouts to the MPC and the Virtualclonedrive lines but all I get are errors as if it's a command being passed to them that neither understands as opposed to being a timer before executing either.
UHD HDR with full menus is working proper using DVDFab Media Player 3 as are most other files.  I have not tried them all.  I have not tried v.5.  I've tested a few iso's and mkv's.  HDR turns on and off automatically as expected.   The player will open Full Screen even if you last closed it windowed.  Subtitles are selectable and working too.  I also tried an external.srt and it appeared and worked as intended which was a pleasant surprise.  Suggest you turn the font down to 16.  All audios are also working well.  The picture is very good.  In general it appears to be working quite well.  Imo, it is similar to PowerDVD although it DOES NOT require any special hardware.  My GTX 960 4GB appears more than sufficient and overall it's pleasing to playback with full menus.  There are also settings to skip warnings and/or go directly to main menu playback automatically.  As usual, titles will be marked 'Watched' after using any external player including this one.

3D frame packed MVC is not working for me.  I understand it may be a new option in v.5.  SBS.mkv is working and 3D mode auto switches on/off.  I will not be using DVDFab Player v.3 for 3D.  Those that desire it can request code if they wish.

I use the same mapped remote control keys for all the various players.  Most are harmonious with a few special keys for special players.  DVDFab Player keys are different than what I currently have programmed so virtually nothing works unless using a keyboard with their hotkeys.  I may rearrange things in the near future to harmonize at least some of the basics.  DVDFab Player used to offer keymap changes but sadly does not in the v.3 I'm testing.  This may not be true for v.5?

Automatic Adjust Refresh Rate is also not working so I adjusted their code so it does and it appears to be working flawlessly.  I changed:

C:\Program Files (x86)\DVDFab Media Player 3\system\settings\settings.xml using notepad++ and must be saved after changing by accepting admin mode and then saving again.

Line 404 should be at 'level' 2.
Change line 405 to <default>2</default> <!-- ADJUST_REFRESHRATE_ON_STARTSTOP -->

Add this to playercorefactory.xml.  It will not be default without making other changes to existing code but it will be selectable in the C (Context Menu) when you select 'Play Using':

<player name="DVDFab" type="ExternalPlayer" audio="false" video="true">
       <filename>C:\Program Files (x86)\DVDFab Media Player 3\FabPlayer.exe</filename>
       <playcountminimumtime>1140</playcountminimumtime>
     </player>
(2018-02-05, 22:02)brazen1 Wrote: [ -> ] Yes, press C or bring up the context menu from your remote.  Select 'Play Using' and a list of the players will show.
All players have a configuration for using 3D and for automatically selecting the preferred method of 3D formats.  If you don't want to watch a 3D format using a players preferred method, change it to off.  This works fine for a 3D Frame Packed MVC iso for example.  I don't know what you're going to do with a 3DSBS.mkv for example?  It's probably going to show two side by side images.  This is yet another reason I use Full Frame Packed rips in an iso.  Maybe someone else knows how to play a 3D.mkv in 2D simply.  I don't.  A quick google search led me to this though https://play3d-2d.blogspot.nl/2014/02/3d...layer.html but I didn't try it as I have no use for 3D in 2D personally. 
 Hi brazen1

Thanks once more for your Help Smile

Now i have everything working as it should Big Grin
I'm back to fiddling with this. I've got it working really well with a few exceptions I'm "living with."

I'm playing .iso through VCD , and I do have to press an extra enter in PowerDVD to play. The file is mounted and displayed but doesn't play automatically. I've had it happen in prior installs (perhaps prior updates) where I thought it played automatically.

MPC-BE still complains "F: was not found please insert media containing this file." I tried switching to pathname "f:/=*.iso" with the same result. But Windows explorer shows the image mounted, and I can file/open disc and see the .iso right there and click on it. I've tried various timeout options on the line "C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable timeout /t 15" to no avail. The "F: not found" message (as above) presents a RETRY box that just flashes back to this prompt. I tried changing drive letters with vcdmount to go to A: but I can't seem to get that syntax right, either.

The only variation I really have is that I added *.uhd to playercorefactory since my 4k hdr files are actually on the server with *.uhd in filename

<rules action="prepend">
    <rule filename=".*uhd.*|.*HDR.*|.*hdr.*" player="MPC-BE"/>
No idea why you have to "fiddle" with anything?  Years ago when I used W7 and W8, VCD was required to mount an iso and then play it through most players including PDVD.  It mounted and the player began playback from the menu.  When W10 was released, it included a built in mount and simplified iso playback negating the need for VCD and also simplified code here when integrated with KODI.  As in the past, you press play or enter on a title in the KODI library and your code adjusted default player or manually selected player of choice is called for that particular type of file.  For an iso using PDVD, that player opens, it auto mounts using the internal mount included in the player or via VCD if it's an older version of the player or O/S, and begins playback from the BD menu.  Once the trailers, etc. are finished, you are presented with the BD menu navigation and have the option to press 'Play title' as with any Full ripped iso.  I never encountered anything in the past or to date I have to "live with".  I included the 'timeout' addition in the code for systems that may execute a player faster than VCD could mount the iso.  This could be for various reasons such as a hard drive containing the iso takes time to spin-up and mount while the player installed on a C: drive might be immediate especially when the C: is on a SSD and the data is on a sleeping normal HDD.  Perhaps there is a drive letter conflict or a system has priority background tasks running or it's just slow?

Since PDVD and MPC both show symptoms that they did not 'see' the iso mounted, I would assume slowing them down from loading (giving ample time for VCD to load, find, call, and mount your iso) the 'timeout' function would cure your slow mounting problem.  Perhaps try the iso directly from the C: to eliminate any sleep or drive letter conflict problems as part of your diagnosis.  What happens if you close MPC or PDVD and immediately try again?  Does it work the 2nd time now that 'everyone' is at attention?  Do you have other things going on we're not aware of like one of these add-ons for pre-movie presentations like a theatre?  Did you actually assign drive letter 'A' for VCD as outlined in the guide?  If you selected another drive letter, did you update all the related codes to reflect that change you made? 

There is nothing in any of the codes I've supplied you need to alter in order to make things work although your rule change looks fine.  All the codes have been tested and used extensively for lengths of time until upgrades were made and codes were improved reflecting those upgrades.  It would help me help you if you included your specs.  There is nothing in your signature.  O/S version, GPU, Resolution, Software versions like PDVD and KODI, pertinent settings, the actual codes you are using, 2d or 3D or HDR, Pictures, etc.  Understand, I can't recreate your problem if you're using older stuff but from early posts in this thread and memory of when I did use older stuff perhaps I can help you better.  The fact you are still using VCD and those old .bats hints you are using older stuff.  Also, I notice you are referring to a .bat for 3D which will have no bearing on a 2D file.  Is this for a 3D problem or 2D?  Nevertheless, they should perform just as they did for me and others in the past.  If using modern stuff, I should be able to assist you immediately.
I'll go through those questions but the "3d bat" you referenced is a line from post #205. That's literally what I'm using as my template the only thing that's different is adding *.uhd to the MPC-BE filename. Are there different .xml .bat files I should be basing on? For 3D I'm just using PowerDVD for it to detect from the iso whether 3d set is needed or not.

Oh, I also had to edit your A: from VCD drive to F:

I can't tell VCD which drive letter to use - I was trying to get it to A exactly as in your script to no avail just to get everything as close as possible to your directions. The only thing I see for VCD in the GUI is '1' for one drive.

Windows 10. Kaby Lake chipset / CPU w/ Nvidia 1050Ti. PowerDVD for blu ray movies (& 3D). MPC-BE for 4K. Internal Kodi for .mkv TV eps.

Also I am auto-running anydvd HD because I thought it was needed to eliminate Cynavia but I am fuzzy on the knowledge there.

I fixed the PowerDVD problem. The issue was I didn't edit the A in the powerdvd.bat file to F. Once I did that movies, autoplay now. However, they all play in 3D. Even 2D movies. Sigh. That's not related to the change made in this paragraph but to something else I guess I broke fiddling with this.

I am now running 100% exactly the files in post 205. This will not run my UHD files but I want to get HD 2D & 3D ISO running before I worry about 4K 2D ISO.
I'd bet you didn't assign VCD a drive letter based on what you just wrote.
Post #1 of this thread, 3rd paragraph.  It says:

I have assigned drive letter 'A' for the virtual mount but you can assign what you prefer. Navigate to Administrative Tools/Computer Management/Disc Management.
On the bottom graph, locate the virtual CD-ROM, right click it, select 'Change drive letter and paths'. Select change. On the right is a radio button that reveals available drive letters. Be certain any external drives are on as Windows will make their letters available if they are off and not present.

In W10, right click the start button and select 'Disc Management'.  Use the lower graph and at the very bottom on the left is your virtual cd rom drive aka VCD.  Right click and assign or change driver letter.

Once you have assigned drive letter 'A' or whatever you prefer, VCD will always open using that drive letter.  If you change the letter to something other than 'A', you'll have to change the code as well.  That too is outlined in the guide.  So you choose 'F'.  Change the code you're using from any and all instances of 'A' to 'F'.  If you are using MPC to open a UHD iso, yes, you need to also use the MPCBE3DISO.bat.  If you are using PDVD for 3D iso's, you will need to use PDVD3DISO.bat also.

If for some reason the timing is off, change the timeout in each .bat.  It shouldn't be but just in case it's too fast, increase the number.
You will notice I've been posting through here for a year with large breaks. Back last year, the problem wound up being that the 3D MKV Intel 630 graphics BeeBox NUC could not properly render 3D. The Kaby Lake chips have well documented issues with HDR and 3D. After realizing it wasn't my fault, I gave up and just used an Android TV device. They have their faults also. After living with their faults, and realizing I could do better with more options and more configuration, I came back over here.

While trying to fiddle with the "why is everything in 3D now with PowerDVD" problem that started - and the ONLY thing I was touching was the 3D settings within Kodi and the Nvidia Control Panel - I'm back to where I was. PowerDVD does no longer auto-execute. Changing the drive to A: (and the .bat) does not help. The screen displays A:Birdman (for instance) but it just doesn't play automatically without that extra keypress (it did for about 4 different tests until I rebooted.)

So after four hours I'm actually worse off then when I started. When I started I really only had the MPC-BE problem and the autoplay issue. Now I have 3d always playing in 2D thrown in. (Maybe Post 46 will fix that?)

If I can find the energy to uninstall and just reinstall everything from scratch starting with Post 205 I'll do that. You're saying there's info in Post 3 that I missed. Ok...is there any sequence of messages to read to retry?
Sorry, I don't remember your history here?  Are you using nVidia, AMD or Intel graphics?  Are you using an HTPC or a Device?  Fwiw, I can't help you with any of the devices like an NUC.  I can't help you with anything but the official KODI build.  Are you using W10?  What media do you require PDVD to play?  What related settings in PDVD are you using like TV or PC mode?  What version of PDVD are you using?  What changes did you make to your working PDVD that no longer works after you rebooted?  Same with your MPC problem(s).  It would help me help you if you included your specs.  There is nothing in your signature.  O/S version, GPU, Resolution, Software versions like PDVD and KODI, pertinent settings, the actual codes you are using, 2d or 3D or HDR, Picture to reference, etc.  I keep asking but you aren't providing.  How am I supposed to assist you without the least bit of information?  I've went as far as guessing.  Without any confirmations of my guesses pertaining to existing complaints, you move on to others and still provide nothing I requested previously to help you. 

I'm here to help in the event something is wrong with the code or the procedure to set things up just in case something is out of whack and no one including me has caught the fault and needs correcting.  It's difficult for me to pinpoint what you may have done wrong outside of following the directions exactly.  Though you may think you have followed instructions perfectly in your many attempts over a year, I don't think you have?  You are giving me no ammo to support that you have setup correctly and haven't provided evidence of a problem no one but you has.

I didn't mention anything about post #3?  I wrote post #1 - paragraph 3.  (You didn't setup VCD correctly because you didn't read the first post in the guide)  Failing to follow this simple instruction (twice) and compound more confusion because of it is more than I want to donate.  This is being made out to be much more difficult than it actually is and starting to get rather complicated.  I suggest you start on page one and begin reading slowly.  Figure out which section of the guide pertains to you and your unique particular hardware and to your unique and particular software preferences.  Cut and paste some notes for yourself if you find it confusing.  When finished, you should have a 100% working system provided you followed instructions.  If you can show me something that is preventing you from having a 100% working system, I'd be happy to correct it.  Show me one problem at a time and everything in detail you have done step by step regarding that exact problem so that the culprit can be isolated.  In other words, list the exact procedures you did to set that facet up.  You can write it out.  You can upload pictures.  Any number of things.  Convince me you have properly installed what ever it is at this point.  Again, help me help you.  Don't forget I need to know what hardware and software you are working with too.

I admit it can be confusing because it is pretty thorough with lots of extra details although the outline is not the best and that is my fault.  Adding in the updated developments in hardware and software over the years further adds to the 'mess'.  I keep all the old things in this guide for those that hold on to their old stuff.  This adds to the confusion for those with newer stuff which suffers chronologically and isn't front and center on the first post requiring some back and forth reading when unfamiliar with the basics or first time installs.
I feel that you have asked me those questions and I have answered. For instance "Windows 10. Kaby Lake chipset / CPU w/ Nvidia 1050Ti. PowerDVD for blu ray movies (& 3D). MPC-BE for 4K. Internal Kodi for .mkv TV eps." The NUC I mentioned was returned, thank goodness I bought it from Amazon.

For now, I think I'll just stick to very short tiny messages instead of blowing an entire hour worth of work into two paragraphs trying to lump everything together and answering questions.

So in the last hour, I have figured out your timeout command will help the autoplay with PowerDVD. I just wasn't cranking it up high enough. For some reason (SSD optimization?) PowerDVD loads instantly. I mean, it loads so fast I think starts loading when I think about it. But AnyDVD hangs slightly during the scan - probably reaching back across the network (which is physically about maybe 5 feet of cable but whatever. Currently a "timeout /t 15" on a line by itself has fixed that problem. I know I saw it as an argument to one of the other commands and that's what I thought I needed to do but when I moved it to a line on its own it works. I think I can back down off 15 I just have it set to a ridiculously high value for testing / proof. Load on the server / network can affect that scan time (such as simultaneously ripping a 4K UHD is going to slow that scan down.) Anyway, issue down. I am hoping when I get back to UHD that the timeout will solve that issue too, but one thing at a time, don't try to fix 4 at once then chase your tail in a circle trying to figure out what impacted what.

My most irritating is getting 3D to play in 3D and 2D to play in 2D. I'm having this problem outside of Kodi also. This wasn't the case yesterday, the only thing that happened was I installed a PowerDVD update. At this point I'll reinstall PowerDVD after I go back to post 46. I'm thinking the clue may be the 


"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable

command. perhaps I can disable upon exit and only enable upon load of a *.3D* in the filename. So, for now, I'll go through the 32 pages of messages specifically on that topic. hmm, not such a tiny message, LOL

Post 46 really sounds like the clue, for anyone else reading along through my self-flagellation here. Going to work through that and if it works one more tiny message (I promise) then back to the real world and .uhd tomorrow!
Well I got it working. Whew. Learned a whole lot too. I figure once I get it working as the thread outlined, I can tweak and go off into my own direction (slowly) such as maybe using MPC-BE more. I fully adore that player. If only it supported menus.

Post 205 doesn't seem to split out 2D & 3D ISO files. I didn't realize that until a few hours ago. Also post 46 is critical also. I might try disabling that task since I now have the xml & bat files correct - it causes a bit of flashing - maybe 3 in fact. 

But it works!
Ah, you edited your post as I edited my reply.  Ok, now we are on the same page. 

The timeout code already exists on its own separate line when using MPC.  Never had a need for it using PDVD but just updated and added it to code AFTER VCD mounts and PRIOR to PDVD opening.  Is this where you added it?  I assume this has now fixed your problem with PDVD required another press of play because the program started before the iso mounted?

I don't use AnyDvd but I know how it works.  If it's impacted like PDVD was (doesn't turn purple because it loaded before iso did) it too will need to be slowed down using timeout after VCD and prior to AnyDvd loading.  Maybe the slow iso mounts are due to NAS over network?  I don't use a NAS.  Everything is local.  Might be advantages to put a delay prior to the whole process beginning at title selection?  I've always assumed when you press play on a title in KODI, nothing happens until that title is accessible.  Everything else has always stalled out waiting including any navigation....

So, now you need to figure out why 2D and 3D using PDVD are not separate and we know it malfunctions testing in Windows Explorer.  You right click a 3d.iso to open with PDVD and it doesn't go into 3D?  And, you right click a 2d.iso to open with PDVD and it goes into 3D.  Correct? 

Code says a title that is a 3D file type is to open with PDVD.  Furthermore, when using PDVD it shall trigger the PDVD3DISO.bat.  In the event stereoscopic is turned off (this happens with Nvidia after HDR has been engaged and why the .bat is needed at all otherwise we could just use PDVD's internal mount) the .bat will engage stereoscopic which is what nvstlink.exe is.  It may be possible to eliminate VCD and let PDVD use its virtual rom feature but I know mounting it using VCD is faster and since VCD will be required for MPC I just incorporate it.  That is up until now that you have revealed it might be slowing YOU down.  Fwiw, MPC has no internal mount and the .bat for it is required.  The .bats also allow for other .exe's to run such as AnyDvd and there is no other way to automate them except to start with Windows.  To use PDVD virtual rom, its drive letter must be assigned also.  I think that is defaulted already  but since I removed the permanent drive letter to free it up for external drives I can't remember how it is packaged.  Yep, I'm out of drive letters.

So, provided this rule is correct:  <rule filetypes="iso|bdmv|mpls|m2ts|.*3D.*|.*.3D.iso|3D.*" player="PowerDVD"/>  and your display is smart enough to engage 3D when a 3D title is inserted into a dedicated player or a virtual rom, and stereoscopic IS engaged system wide via nvstlink.exe prior to playback, it should be working flawlessly.

Your 2nd immediate problem is 2D.iso plays in 3D using PDVD?  Post 46 is an old fix and updates have since straightened it out.  It was a problem with stereoscopic disengaging after reboot and didn't engage stereoscopic for 3D titles.  It isn't required anymore.  I think this was fixed in the spring W10 update and I know it works using the FCU presently.  This was also coordinated with GPU driver updates.

Code says when the file type is an iso, etc. PDVD should open.  Like 3D, it calls PDVD3DISO.bat even though it is 2D.  This is to utilize VCD and any additional exe's.  It still turns on stereoscopic even though it won't be used and there is no detriment.  PDVD distinguishes the 2d.iso is indeed 2D and does not engage 3D stereoscopic based on what the GPU is feeding it.  The file plays in 2D.  So, does your display engage 3D and prompt you to turn on glasses?  Is PDVD setting to 'play 2D as 3D' or is it unchecked?  Are you using FCU and newer GPU drivers?  I use v.385.69 fwiw but only because of madVR crashes using newer drivers when playing HDR via MPC.  Recently I'm using DVDFab v.3 for HDR.iso for menus but MPC, madVR work still.  There may be other reasons 2D plays as 3D but I can't think of them off the top of my head.  Get the 3D going proper.  Perhaps it will cure the 2D.  Please report back your findings.
Well, you posted while I was replying.  Glad you got it going.  "Post 205 doesn't seem to split out 2D & 3D ISO files."  I don't understand this?