Kodi Community Forum

Full Version: HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2018-10-07, 18:33)brazen1 Wrote: [ -> ]I installed KODI v.18 x64 nightly today and was met with a pleasant surprise - It's working now. 

In the past I used Estuary instead of Titan and vice versa during testing.  Now, if I use Titan, it still ends up reduced to a quarter size in the top left corner and is unresponsive after quitting an external player.  Switching to Estuary this does not occur.  I will be using Estuary until Titan is working again (if ever).  The original maintainer/designer of the skin has quit.  Perhaps someone can suggest another skin that is as highly customizable as Titan especially when it comes to vertical menus and a Netflix interface.  Though this sounds like a lot to ask, my customizing is actually very, very vanilla.  I'm not much of an eye candy guy desiring all the bells and whistles.  I just like the layouts.

So far in my limited preliminary testing, everything is much, much faster.  3D MVC switches in and out, as does HDR using iso's with PDVD, and both MPC players.  Subsequent playbacks of different players is also performing well.  Looking forward to switching over to v.18 as a daily driver now.  Please suggest skins compatible with v.18 and tia.
I always used and still using Estuary, but for me, even with latest nightly didn't change anything. Still ends up reduced to a quarter size in the top left corner after quitting an external player (MPC-BE).
In KODI settings, White List everything down to 720p or so.  Also, make sure your versions for everything are current including GPU drivers.  Use a Fullscreen window for everything.  Can't think of anything else right now.  As for the skins, there is no dev anymore for Titan.  A debug wouldn't do much good.  I'm battling between Estuary and Aeon Nox 5 Silvo after diving into the settings for what interests me on all the other skins.  Each has it's own pluses and minuses.  Right now I have NOX pretty decent except fanart won't rotate and custom color background does not respond.
I installed new nVidia 416.34 and new LAV Filters yesterday.  I modified the nVidia drivers to use the older audio drivers again.  I didn't bother checking if I needed to.  HDR now launches in FSW and not only FSE now using madVR.  Same with 3D.  I have never been able to use FSW with 3D.  Best of all, it appears DVDFab Player v.3 HDR is working again.  V.5 HDR is now improved although I don't understand how?  Windows HDR no longer has to be engaged and the panel is not switching into HDR mode but the video looks dark (no HDR) and is not desaturated looking.  It's not in HDR>SDR mode either.  Still drops frames.  Anyway, an improvement but I won't be using it for HDR.
For the extrafanart problem in Aeon Nox, check to see if the all of the appropriate fanart has been downloaded:

Image

Then enable Extra-fanart in the left side blade:  

Backgrounds

Image

If some of the fanart spots are blank, run Artwork Beef from the Programs section and delete these entries, so they can be downloaded again. There could be some issue integrating Artwork Beef's fanart with your existing fanart.

Remove artwork for media type...

Image
(2018-10-12, 04:52)brazen1 Wrote: [ -> ]In KODI settings, White List everything down to 720p or so.  Also, make sure your versions for everything are current including GPU drivers.  Use a Fullscreen window for everything.  Can't think of anything else right now. 
I white listed everything as you said and updated everything to the latest versions but nothing changed for me. When I play an HDR or a 3D movie, KODI still ends up reduced after quitting MPC-BE. The only time that KODI is working properly (full screen after quitting MPC-BE) is when I play a plain 1080p or 720p movie with MPC-BE. Unfortunately I don't have a 2160p movie without HDR to test, but I suspect that it would behave the same... All these are happening with all settings in madVR to default, except checking every box in stereoscopic 3D (and of course 3D display mode is on in Windows Display Settings).
(2018-10-12, 17:12)brazen1 Wrote: [ -> ]I installed new nVidia 416.34 and new LAV Filters yesterday.  I modified the nVidia drivers to use the older audio drivers again.  I didn't bother checking if I needed to.  HDR now launches in FSW and not only FSE now using madVR.  Same with 3D.  I have never been able to use FSW with 3D.
Since 385.28 I was always playing HDR and 3D without enabling FSE in madVR... Maybe different behaviors in our systems caused by different hardware (I have a GTX 1060).
I guess settings are very fickle one system vs another although I can't understand why?  I doubt your 1060 vs my 960 is a reason.  Each uses the same drivers.  Our panels are different.  I suppose they might EDID handshake differently?  I updated to yesterdays nightly.  All good fwiw so it's not the nightly version.  I have made some changes to my madVR settings but nothing radical?  I suppose I should update those changes in this guide though.  I suggest you start trying some combinations and see if you can arrive at something.  Can't remember what madVR default settings are but try FSE vs FSW.  Also try MPC-HC vs BE.  If you happen to have PDVD or FAB, try those too.  If all else fails for you, you can always give 385.28 a shot with the new Windows update.  The strange thing is, this only happens to you for 3D and HDR titles.  Those involve the panel switching mode side of things vs players imo.  In the past when I had this problem, it didn't matter what was played.  Could be as simple as a cable length issue.  You did install the 64bit version of KODI 18 I presume?

Thanks for the tips Warner.  I have existing extrafanart and already had the options checked to use them but it just uses one and doesn't rotate through them.  I've always used just one fanart.  I see in your pics you have many fanarts.  Perhaps my old artwork just isn't formatted, named, or what ever to use with this?  I'll have to try artwork beef and see if it can sort it out.
(2018-10-13, 17:08)brazen1 Wrote: [ -> ]Thanks for the tips Warner.  I have existing extrafanart and already had the options checked to use them but it just uses one and doesn't rotate through them.  I've always used just one fanart.  I see in your pics you have many fanarts.  Perhaps my old artwork just isn't formatted, named, or what ever to use with this?  I'll have to try artwork beef and see if it can sort it out.
 Your existing extrafanart is no longer officially supported by Kodi. If you want, you can actually use Artwork Beef to delete it.

You only need to enable multiple fanarts in Artwork Beef to download the extrafanart.

Image

The fanart should be labelled fanart1, fanart2, fanart3, fanart4, etc.
(2018-10-13, 17:08)brazen1 Wrote: [ -> ]I guess settings are very fickle one system vs another although I can't understand why?  I doubt your 1060 vs my 960 is a reason.  Each uses the same drivers.  Our panels are different.  I suppose they might EDID handshake differently?  I updated to yesterdays nightly.  All good fwiw so it's not the nightly version.  I have made some changes to my madVR settings but nothing radical?  I suppose I should update those changes in this guide though.  I suggest you start trying some combinations and see if you can arrive at something.  Can't remember what madVR default settings are but try FSE vs FSW.  Also try MPC-HC vs BE.  If you happen to have PDVD or FAB, try those too.  If all else fails for you, you can always give 385.28 a shot with the new Windows update.  The strange thing is, this only happens to you for 3D and HDR titles.  Those involve the panel switching mode side of things vs players imo.  In the past when I had this problem, it didn't matter what was played.  Could be as simple as a cable length issue.  You did install the 64bit version of KODI 18 I presume?

I do agree about different panels can cause different behaviors. Maybe my problem is there, because as I can remember, I always had KODI resizing, even on Krypton (although not in the top left corner). In the next days I will try to connect my HTPC to another LG (not OLED) TV we have and report.
I also used every possible combinations in madVR and tested MPC-HC, but with no luck. I have PowerDVD and FAB but I won't test them because there is no need for me to use them, as I don't  have iso's with menus and PowerDVD can not play MVC 3D mkv, in my system.
When Microsoft give again the new 1809 update I will test it with 385.28 and with newer drivers and report too.
Warner, I've successfully got fanart rotating.  I also edited some NOX code to rotate them faster (2ms).  I'm also refining artwork beef settings to my preferences and have run a couple scans.  Still been reluctant to use any of the delete functions but I'm getting closer to trusting those settings and their actions.  It appears nothing actually deletes but gets moved to a KODI temp folder.  I see adding a 'delete all artwork' function can be added to context menu.  I wish it could be adjusted to 'delete all artwork' EXCEPT posters for example.

I noticed artwork beef suggests NOT to add animatedposter.gifs to its list of file types to d/l because it conflicts with skin helper service add-on.  Still trying to get my head around that since I use them.  Thankfully there are other options to scrape them myself.  The more I use NOX with AB, the more I like them. 

Still some issues trying to get around, for instance:  I created a main menu MOVIES.  (this shortcut points to my sources).  Then a submenu RECENT, GENRES, SETS.  These work fine.  I also created Main Menu shortcuts to HDR MOVIES and 3D MOVIES.  (these are source locations).  When I enter either of those, select a title, and then bring up the context menu, it is missing 'Play Using' and quite a few other normal context menu items.  Is this true for you?

zxaura1, if 17.6 was resizing for you, I never experienced that and have no other suggestions except - Are you certain 'use a fullscreen window' is enabled in the official versions of KODI 17.6 and/or v.18?  Interested in your report once you can update everything...
I'm not missing "Play using..." but I'm not on v18. I didn't know this was possible. Those example shortcuts should be created with smart playlists. I'm not sure if there are settings in smart playlists that can affect the context menu.
I see.  Not much to compare if you aren't using v.18.  I also noticed that attempting to play a trailer with Silvo NOX 5 results in an immediate crash.  Estuary is ok.  Hmmm?

Just found this:  Custom_home_items/Aeon_Nox_Silvo (wiki)
Ok, added custom main menu item per that guide using smart playlist method per your suggestion and still no 'play using' in context menu.  This may be a KODI v.18 bug and not the skin.  I'm noticing the same thing using Estuary when I select the custom folder in files.  I see nothing in smart playlist edit for it pertaining to context menu items but I'm not an expert with smart playlist options.
Best to report the crash when playing trailers to Mike Silvo. These calls can change over time and need to be updated. It might be fixed already in the GitHub source.

If you downloaded the repository, you should get automatic updates. If this is the case, you should also save a copy of any .xmls you edited so they aren't overwritten by future updates of the skin.
Funny you should mention.  I installed 6.1.4 from the zip provided at the thread.  All is well.  Then noticed a newer version was available, announced near the end of the thread and d/l from the link.  Went to install and was met with 'failed'.  Installed his repo and attempted to d/l again through repo.  Failed.  Quickly looked at log and all the errors are from skin helper service and lots of em'.  I suppose I need to let things mature.  V.18 is working better (and good enough) than it ever has.  Still struggling with artwork beef and the skin.  I've basically removed all the artwork I once had and let AB replace it.  Now I'm tediously editing one at a time - animatedposter.gif's the most time consuming.  If I was to make one suggestion, don't 'export' your library using the KODI function.  Find another way to mass create nfo's and add new ones.  I haven't looked into how to create new ones easily yet.  If you or anyone else knows, please advise.  Thanks.
(2018-10-16, 01:06)brazen1 Wrote: [ -> ]Funny you should mention.  I installed 6.1.4 from the zip provided at the thread.  All is well.  Then noticed a newer version was available, announced near the end of the thread and d/l from the link.  Went to install and was met with 'failed'.  Installed his repo and attempted to d/l again through repo.  Failed.  Quickly looked at log and all the errors are from skin helper service and lots of em'.  I suppose I need to let things mature.  V.18 is working better (and good enough) than it ever has.  Still struggling with artwork beef and the skin.  I've basically removed all the artwork I once had and let AB replace it.  Now I'm tediously editing one at a time - animatedposter.gif's the most time consuming.  If I was to make one suggestion, don't 'export' your library using the KODI function.  Find another way to mass create nfo's and add new ones.  I haven't looked into how to create new ones easily yet.  If you or anyone else knows, please advise.  Thanks.
You could perhaps try Ember Media Manager.
Mike Silvo might also want to know about the broken repository if this issue is common. Having the GitHub source could possibly conflict with the repo, but this doesn't sound like the issue. The GitHub source is always the most recent. The other releases are only made available when Mike decides it is unlikely there are any bugs and pushes a new version from GitHub.