Kodi Community Forum

Full Version: HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2018-11-18, 20:52)brazen1 Wrote: [ -> ]I removed the test because the post is too long - just quoted so that u know to which post I am referring.
 Hi!

Thx for this lengthy reply.

Since I do work a lot I don't have a whole lot of time for PC related stuff so I really try to cut my posts short - this obviously can lead to some misinterpretation on top of the fact that english is not my native language.

In no way I wanted to imply that your guide is rubbish, BS or whatever. You wrote an impressive guide to get ppl, including myself, as easy as possible to a working HDR setup and myself and all others here appreciate that. In addition to the guide you actively post and help if issues arise - that is a lot more than ppl could actually ask for.

Even though you have put a tremendous amounts of time into the guide there will always be users who will have issues, new hardware driver or whatever. With my post all I wanted to say is that for my setup I have had a problem and I wanted to share my work around for that in case someone else will encounter the same issue - nothing more and nothing less.
But I should have made it clear that I deviated from you instructions and also should have stated the reason - then no one would think that it is a guide issue.


So for the guide you wrote there are some differences from your setup to mine:

1) I dont' use Leia because it doesn't yet work with my Control4 system. So I use Krypton with a skin from the Kodi repo (Titan) until Leia is supported (so it is a skin from Kodis repo and a official Kodi built).
Since I don't use Leia I can't take advantage of the new resolution switching/whitelist that Leia offers - I am not aware that Krypton does automatically switch to lower resolutions, i.e. from a standard 2160p desktop resolution to a 1080p resolution if it plays a 1080p movie or SD PVR channel (so standard movie with internal player - no external player)
So the reason I run 1080p is that I don't use Leia and I want my TV do as much upscaling as possible since it is much better than Kodis upscaling algo (including Shaders and Lanzcos/Spline) - I am not inclined to install Kodi DSPlayer to let MadVR do the processing since it is a really heavy mod.

So this is the reason why I try to stick to 1080p standard desktop resolution and deviate from your instructions.

2) Even though you state AMD is used besides Nvidia I seem to be the only one recently using an AMD GPU as the search shows no results for "Raven Ridge, RX480, RX580, Vega" in this thread - so most ppl here seem to use Nvidia.
This could also account for some differences in regard to Kodi - but also maybe not :-)

In regard to the resizing issue I talked about I wanted to point out that the one you described is not the one I was experiencing because Kodi always resized and worked just fine.
In my case MPC-BE movie was running in a small 1080p section of a UHD screen - so in my setup obviously MadVR somehow fails to go fullscreen with MPC. So my workaround is to put MPC already in 2160p before MadVR kicks in and that seem to work.

As soon as I switch to Leia I will change the setup back to your guide and see how it goes - until then I will stick to my dirty work around :-)

again, thx a lot for your guide as without I would not have HDR now !
(2018-11-18, 20:52)brazen1 Wrote: [ -> ]I've mentioned the Windows Audio Properties bug many times since it's inception many moons ago:  I've been editing the nVidia driver installation to workaround it.  You'll notice it also doesn't auto switch from stereo to multichannel when you turn the AVR off/on and vice versa.  Folks told me not to turn the AVR off and to me that's ridiculous.  You'll also notice when the AVR is off, and it's stuck on 7.1 (multichannel) you can't play videos such as youtube unless you manually switch it to stereo.  Here's what to do:

Driver 416.94 is problematic for 3D using MPC-BE but not other players.  It reduces the player resized to upper left corner.  I use 416.81 at the moment.  Hopefully the driver and the player coordinate again some time in the future.  Don't use 24 bit 96000 Hz.  Use 24bit 48000.  Download nVidia driver version 388.59.  This is the last working audio driver bug free.  Every version after this is broken. 

Create a 'new folder' on your desktop. 
Unzip the driver installation to 'new folder' on your desktop. 
Don't install driver once it is done examining your PC. 
Copy 'HD Audio' folder from 'new folder' you just unzipped to your desktop and save it for future driver installs. 
Delete 'new folder'. 
Create a new 'new folder'. 
Download v.416.81 and unzip it to your new 'new folder'.  It will examine your PC and ask to start the installation.  Don't. 
When it pauses, RENAME 'new folder' to something different. 
Replace the 'HD Audio' folder with the one you saved earlier. 
Cancel the installation.  Now the 416.81 unzipped install folder won't auto delete because you renamed it midstream installation. 
Run the setup.exe in your folder that now has the old but working 'HD Audio'.
Once installation is complete, audio problem will be fixed.
After using the edited install folder, it will never work again after using it once.  If you screw something up, you'll have to do it over again.  Same with next time you update unless they fix the audio driver.  But save that working HD Audio folder you extracted in step one to speed things up next time.
All of this is already covered in the guide.
Then , I started willingly in applying the various steps in audio reconstruction provided by you , I think I have left nothing to chance in following the various steps , but, unfortunately, it is not working , if I set 7.1 multichannel and 24 bit 48000 Hz I apply and save, Audio, returns to a stereo position after the output from the audio setting of Windows 10 v. 1809.
I would like to point out when I installed the 385.28 driver version with bug-free audio , with version of windows 10 1803 ,Audio set 7.1 multichannel and 24 bit 96000 Hz 385.28 driver nVidia it worked perfectly ,what does not happen now with Win10 1809 and nVidia 385.28 driver.
Are you getting stereo with some sources or all sources?
With all the sources , if by sources you mean contents.
Does the Windows sound test play all channels? In other words, did you go through the sound configuration wizard?
Yes sure , does the Windows sound test play all channels , with AVR on multi-channel audio setting 7.1
Control Panel -> Sound -> Configure Speakers

Image


When you select Test, do you hear a tone from all speakers?

Try playing something with the default Kodi VideoPlayer. It may produce a different result than MPC.
Make sure you don't have another audio driver installed in Device Manager.  Realtech is a common one folks unknowingly install with chipset drivers for their Motherboard.  Uninstall if present.  This would also show in Windows Audio Properties.  While you're in Device Manager, scroll down to Sound, Video and Game Controllers.  Make sure only nVidia is present.  Open its properties by double clicking it.  My driver version shows 1.3.35.1.  Right click audio icon next to clock in tray.  This is important.  With AVR off, select 'Stereo'.  With AVR on, select 7.1.  Reboot.  Any time you toggle AVR on/off, the stereo vs multichannel should change.  Check by right clicking the audio icon.  I'm on 1809 now and it worked previously with 1803 fwiw. 

If your Windows Audio Properties is stuck on 'Stereo', it will still switch to multichannel including Atmos, DTS:X, etc.  When using KODI VideoPlayer or any other player like MPC, there will be special audio situations where this is a complete failure though.  One example is when expecting multichannel audio for AAC.  AAC will only play stereo and never 5.1/7.1.  If you have none of these special audio situations, you'll probably be unaffected.  If you never turn your AVR on/off, you'll probably never be affected.  If it isn't stuck in 7.1, you'll still be able to play web based audio and video.  If you don't mind manually switching the audio property, you'll be unaffected.  Personally, all of this affects me and I just want it to be correct. 

The Windows test tone is fine for checking output to your AVR but whether it survives a reboot or auto switches back to stereo when the AVR is off and returns to multichannel when turned back on is a different story.  The auto switching is the key thing to fix imo, and is why I use the old audio driver that indeed does this for me.  This should be true for you too.  Provided you did it correctly, and have reported it doesn't work for you, leaves me baffled.  We use the same O/S version and audio/video driver.  Hardware differences in PC components, displays, AVR's, etc., should not matter.  I am using W10 pro.  Perhaps all this behavior is different when using 'home or school' or something though?  I wouldn't know but common sense tells me I doubt it.
I redid the whole procedure taking into account the latest indications provided by brazen1 , as recommended , I uninstalled the driver of the Realtech , not only but also (eliminates the driver software for the device) from what little I could verify with 7.1 multi-channel content and stereo 2.0 content , my AVR accepts the switch from multichannel to stereo , i'm very tired for be objective to say , if everything works well ,rather , I noticed that , if I apply a multi-channel 7.1 setting with 24 bit 48000 Hz audio quality, it is not maintained in Control Panel -> Sound -> Configure Speakers the windows 10 , but back in mode 16 bit 48000 Hz , this is what I have verified , at the current time , I can not say that the problem is solved completely , for sure I can assure you that I left nothing to chance of all that was suggested to me by Brazen1 and Warner 306.
I know you're trying to be precise and there's a language barrier.

When you turn your AVR off, does windows audio icon show stereo?
When you turn your AVR on, does windows audio icon show 7.1?
Does this happen even after you reboot?  It should.

I'm not sure if it makes a difference (it shouldn't) but instead of going to Control Panel -> Sound -> Configure Speakers (check a different way).

Windows start menu button/settings icon/system/sound/device properties link/spatial sound format
7.1 with AVR ON
Stereo with AVR OFF
Make sure 'Disable' is unchecked.

The way I always set this up:
Right click audio icon next to clock in taskbar.
In the list will be stereo or 7.1 selected - depending if AVR is on/off.
When you highlight the mouse pointer over it, another submenu opens.
At bottom is 'Advanced Setup'.
Select it and audio properties window opens.

Set your audio properties as recommended with your AVR ON.

Only your AVR using HiDef nVidia should be showing.
If more shows, Right click on it. 
Uncheck anything that is checked.
Make certain it shows 'Default device' with green checkmark.
While it's highlighted, select 'Configure'.
Select 7.1.
Uncheck 'full range speakers'.  This is so low frequencies are sent exclusively to your subwoofer and not shared with your other speakers even if they can handle the range which should be 80Hz.
Finish the setup.
Double click the AVR icon instead of just highlighting it.
Under 'Enhancements' tab, disable all.
In 'Advanced' tab, 24bit 48000Hz.
Check both Exclusive modes.
Press Apply and Ok.
Reboot.

Check Stereo shows when AVR off and 7.1 shows when AVR on.
Repeat a few times.
Report back if it is switching correctly now and that it retains 24bit 48000Hz.
Note:  When AVR is off and it's in 'Stereo' 24bit 48000 is only going to be 16bit 48000Hz. 
I recommend you do not change Stereo settings to match 7.1 settings. 
Leave it at default.

I think you are confusing 7.1 with Stereo in windows audio setup.
If you make changes while in Stereo with the AVR OFF, it will not be the same when you turn the AVR ON and it's in 7.1.

Turn AVR ON.
Open Windows audio properties setup.
Double click your AVR that is showing.
Now turn AVR OFF.
Panel flashes.
Now you see 'Device you are configuring has been removed'.
This is because 'Stereo' is actually your TV speakers and it is one device.
7.1 is your AVR and it is another device.
I think you are setting up your stereo device and expecting the settings to be the same for your 7.1 device.
Brazen1.
You,  are infinite, and inside to these new information you have provided to solve the problem you notice we see that put all your knowledge . Now , with a little' more time available I see if I can solve , Meanwhile , everything you did to help me ,for my part it is much appreciated.
I've installed nVidia driver 417.01.  It presents the same new problems as the previous driver introduced and clings to the same older problems as well.  There are some new additions to the control panel for gamers such as Game Ratings and a couple 3D mode choices (something to do with multi monitors) that are of zero relevance to me.  I suppose the driver updates are advancing for gamers but declining for HTPC movie playback.  They are now in a new x17.xx branch now so any hopes of advancement for what we do is now looking dismal imo.
Hi,

If the goal is to just have UHD-HDR on my system through kodi (not really worried about 3D and menus since I have it setup in a way that works and I'm used to it), would it be resonable to just use DVDFab or did I not understand your tutorial right.

I have Win 10 64bit installed on i7 8700k, 16gb, RTX2080, and audio is over HDMI to an HDR capable reciever then TV (HDR works fine from windows player, or from amazon fireTV)

Thanks
This guide explains how to launch any external player of choice from KODI and return to KODI when finished seamlessly.  Choices in players are up to each individual.  DVDFab Media Player(s) are one brand of player and they offer 2 versions, each extremely different from one another.  You stated your interest is only UHD-HDR and you don't desire menus.  That increases your choice of player(s) to handle the task since only a couple are capable of handling any type of menus.  Differences, pros, cons, etc., are described in the guide.  Your equipment is more than adequate.
Tried new nVidia driver v.417.22 released today.  DVDFab v.3 no longer switches into HDR mode along with the previous problems that keep getting introduced.  I reinstalled v.416.81 along with the audio driver mod and all is well again.