Kodi Community Forum

Full Version: HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2016-10-11, 02:55)brazen1 Wrote: [ -> ]Read the entire 1st post. If your setup is identical, follow it. If your setup is different, you will see links to other posts for those differences.
I know I need to update the 1st post and make it easier. At some point I might.

Windows 7, 8, or 10?
Normal KODI build or afedchin?
1080 or 4K?
Nvidia, AMD, or Intel?

If refresh rate isn't working for you, backup and undo all your code changes and start from the beginning so we can see where your mods went wrong.
Install whatever applies to you, confirm that it is working, then perhaps we can modify from there.

Since you are a 1080 user and not 2160 (4k), you should not pay attention to post # 112 and instead start at post #1, referencing #46 & #96 if need be. (No idea what O/S or build you are using)
If you'd like to guinea pig try it with what you have, follow post #112 exactly.
Change this line:
) + ' /x 3840 /y 2160 /r:' + (refreshRate >= 59 ? 24 : 60), 0, true);

TO

) + ' /x 1920 /y 1080 /r:' + (refreshRate >= 59 ? 24 : 60), 0, true);

I have no 1080 hardware to test with anymore so that's up to you but I'm sure it will work.
Get a working setup installed and then I'll know what to mod for you.

Hmm! What confused me was Post #112. I thought that was the UPDATED Post #1. I understand now it's not. I'll revert back to Post #1 and look at #46 & #96.

Some of the missing info:

Windows 10 Pro x64 (Anniversary Update) Build 1607
KODI v17 "Krypton" Nightly Build (BETA2 GIT:20160909-138de50-dirty)
1080p Only
CPU: Intel "Broadwell-E" i7-6800K (OC: 4Ghz)
GPU: nVidia "Pascal" ASUS Rog Strix GTX 1080 (nVidia Driver 373.06)
RAM: G.Skill 16GB DDR4 (OC: 2400Mhz)
PSU: EVGA 1050W
Epson 5010 1080p 3D Projector
Yamaha RX-A2000 Receiver
HDMI 1.4b Cable Connections

Thanks!
Wait for a bit.
There is a whole new setup coming today that is much easier to configure.

You got me thinking:
There is no reason to call up a 2D vs. 3D configuration for an external player anymore.
They can now work together so no .bat files are needed.
It appears PDVD internal mounter now works reliably as well so no need for a 3rd party mounter.
All that will be required is a playercorefactory.xml.

"Segregate" and checking out your playercorefactory mod did the trick. Thanks.
(2016-10-11, 17:12)brazen1 Wrote: [ -> ]Wait for a bit.
There is a whole new setup coming today that is much easier to configure.

You got me thinking:
There is no reason to call up a 2D vs. 3D configuration for an external player anymore.
They can now work together so no .bat files are needed.
It appears PDVD internal mounter now works reliably as well so no need for a 3rd party mounter.
All that will be required is a playercorefactory.xml.

"Segregate" and checking out your playercorefactory mod did the trick. Thanks.

REAL GOOD!! I will most certainly wait - no rush!! Thank you so much for all your help.

Very, very happy to have been of help. Smile
See updated post #112 and try 1st method.

Working decent for me after testing 4k: Not positive about 1080 (no test hardware)
3D iso MVC with PDVD. Default.
3D iso with Kodi as 2D playback only. Context Menu.
2D iso Kodi and PDVD. PDVD default.
3D mkv TAB and SBS. Kodi default.
3D mkv TAB and SBS. Context menu PDVD. (manual 3D mode switch required but Kodi is default which does auto switch 3D mode)
2D mkv, mp4, and avi. Kodi default.
2D mkv, mp4, and avi. Context menu PDVD does not switch to match refresh rate but Kodi is default which does match.
HEVC Kodi and PDVD.
60FPS mkv Kodi and PDVD.
Hardcode subs and externals working.
(2016-10-11, 18:54)brazen1 Wrote: [ -> ]See updated post #112 and try 1st method.

Working decent for me after testing 4k: Not positive about 1080 (no test hardware)
3D iso MVC with PDVD. Default.
3D iso with Kodi as 2D playback only. Context Menu.
2D iso Kodi and PDVD. PDVD default.
3D mkv TAB and SBS. Kodi default.
3D mkv TAB and SBS. Context menu PDVD. (manual 3D mode switch required but Kodi is default which does auto switch 3D mode)
2D mkv, mp4, and avi. Kodi default.
2D mkv, mp4, and avi. Context menu PDVD does not switch to match refresh rate but Kodi is default which does match.
HEVC Kodi and PDVD.
60FPS mkv Kodi and PDVD.
Hardcode subs and externals working.

Attempting very shortly - will get back to you with results.

Thanks!
(2016-10-11, 18:54)brazen1 Wrote: [ -> ]See updated post #112 and try 1st method.

Ok, so I started from scratch and followed your instructions to the 't', and unfortunately I'm back to the problem for which I had created the thread [Link] where you originally found me.

After setting up the system EXACTLY as you detailed, If I leave my Windows running @ 1080p, 60Hz, after setting up & enabling Stereoscopic 3D in nVidia Control Panel:

- When I play a 2D Movie within Kodi, my display switches to 3D 24Hz
- When I play a 2D ISO in PowerDVD, it plays @ 60Hz causing stutter
- When I play a 3D ISO in PowerDVD, it plays fine.

The only way I'm able to play a 2D media within Kodi & PowerDVD, properly @ 24Hz with no stutter, is to leave my Windows @ 1080p, 24Hz, and leave Stereoscopic 3D disabled, and enable 3D just before playing a 3D ISO in PowerDVD using nvstlink.exe /enable, and nvstlink.exe /disable when exiting.

I followed these exact instructions:

Code:
PowerDVD 16:
[b]Enable Match Refresh Rate when you see the pop-up for the 1st time and choose not to show you again.[/b]
Enable Hardware Acceleration.
Turn off all enhancements.
Enable High Perf Mode.
Select Non-Decode High Def Audio/Full Dynamic Range.
Enable Play 3D media in 3D.
You may need to press pause to engage PDVD 3D mode (bug).
Although PDVD opens via Kodi script(s), it will not close automatically upon title completion. I mapped alt + 4 to my remote. This kills it and returns you to Kodi still in focus and in fullscreen as you left it.

Nvidia:
In this exact order,
Download driver, create new desktop folder, and point it to unzip there. Delete folder after install unless you have a reason to keep it.
Choose Custom Install/Clean Install.
Uncheck 3D Vision Controller Driver unless you need it for some reason.
Uncheck Experience unless you want to add a Windows Credential and be reminded for updates.
Open Control Panel.
Adjust Image Settings with Preview. Quality. Apply.
Set Up Stereoscopic 3D Enable.
The Vision Test Window will open. Select Next and Next again.
Your panel will engage 3D. Select the proper images in the next 2 screens including the scrambled box with a pop-out box inside it.
Finish.
You will return to the desktop in low res 3D mode.
Select Change Resolution in Control Panel.
You will see HD 3D 720 is selected. Change it to HD 3D 1080. Change resolution to 23 or 24 Hz (Doesn't matter). Change Color Format, Depth, and Range to RGB, 12bpc, and FULL.
Select Apply and keep changes before reverting.
[b]Now select your native resolution for Ultra HD, HD, SD. Mine is 4k x 2k 3840 x2160. Change Refresh Rate to 60Hz. Select Apply.[/b]
Make sure RGB Full is still set. Depth will be blank. It's ok. It will revert to 8, 10, or 12 bit depending on the content it's fed in the future.
Remember to play a 2D title, pause it, minimize the player, and readjust these settings if need be. Do the same for 3D and Windows desktop, all individually. Adjust TV settings at the same time. For example. You are playing a 2D title in KODI or PDVD. Check your panel INFO button. It should show you are playing at 24Hz. Minimize it while paused. Check Nvidia Control Panel color format, depth and range. You should still be at RGB Full. Change if needed. It will remember and you will never have to do it again. Check your TV settings are proper. This too will change depending on what you have input but will remember so you don't have to do it again.

KODI:
Adjustments remain the same. Resolution remains Native. In my case, 3840 x 2160 @ 60Hz. You should always be using 60Hz.
There is no need for any add-on to auto switch 3D modes. Smart TV's do this automatically now.
There is no need for Advanced Launcher to trigger nvstlink.exe toggle anymore or map it to your remote.
Do not enable limited 16-235 color space. Keep KODI matched with your other components at full.

I used Adjustments for KODI EXACTLY as described on Post #2 on Page 1 of this thread.

My Playercorefactory.xml looks like this now:

Code:
<playercorefactory>
<players>
   <player name="PowerDVD" type="ExternalPlayer" audio="false" video="true">
     <filename>C:\Program Files (x86)\CyberLink\PowerDVD16\PowerDVD.exe</filename>
     <args>"{1}" /fullscreen /close</args>
     <hidekodi>false</hidekodi>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
   </player>
</players>
<rules action="prepend">
   <rule filetypes="iso|bdmv|mpls|m2ts" player="PowerDVD"/>
</rules>
</playercorefactory>

So what am I missing? Why is this not working for me?

Can you see anything I may have done wrong in the above?

Thanks.
I don't know? Perhaps your Epson 5010 does not have 'Smart' enough capabilities?
If that's the case, one of the other methods will work.

Since PDVD does not match refresh rate with a 2D, something is really whacked. Set the desktop and Kodi at 60Hz period! Changing these to 24Hz are not going to help diagnose your problem. Under general tab in PDVD, reset never show again dialogs. Start a title and match refresh rate prompt will appear. Enable it and retry.

Are you using a fresh install of Kodi during these tests?
Backup your original and install a nightly so nothing is carrying over.
Adjust Kodi per post #1.
Add some titles including 3D with proper naming per post #1.
Just trying to eliminate anything obvious overlooked.
Are you using an advancedsettings.xml with anything related to 3D control in it?
If so, you need to edit it out or set the whole advancedsettings.xml aside for now.
That may be the only problem? If not, continue.....

Since a 2D is switching to 3D, then you have to control Nvidia nvstlink.exe using the original setup post #1 with both 2D and 3D .bats and playercorefactory (post #3) for non-smart.
You will also need to setup task scheduler post #46.
Nvidia stereoscopic will always be off and everything at 60Hz only changing to 24Hz during playback. You will have to manually turn stereoscopic on for 3D titles and off when finished. Here is how I used to do it:

Create 3D ENABLE.bat. I placed mine in the Documents folder.

@echo OFF

"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable

EXIT


Create 3D DISABLE.bat also in the Documents folder.


@echo OFF

"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /disable

EXIT

Install plugin.program.advanced.launcher-master https://github.com/angelscry/plugin.prog...d.launcher
There is nothing to configure. Open the app. Select default. Select context menu (Keyboard C). Select Create New Launcher. Navigate to 3D ENABLE.bat you just created. Do the same for 3D DISABLE.bat. These now appear as links in Advanced Launcher. Select context menu again and add each link to Favorites. I created a 3D MOVIES folder in my main menu. I then created a favorites link in 3D MOVIES submenu. When I want to use an external player to render a 3D title, I navigate to this submenu and select 3D ENABLE before I start the external player and select 3D DISABLE when finished.

This method should work for you. Let me know.....
(2016-10-12, 17:21)brazen1 Wrote: [ -> ]I don't know? Perhaps your Epson 5010 does not have 'Smart' enough capabilities?
If that's the case, one of the other methods will work.

Since PDVD does not match refresh rate with a 2D, something is really whacked. Set the desktop and Kodi at 60Hz period! Changing these to 24Hz are not going to help diagnose your problem. Under general tab in PDVD, reset never show again dialogs. Start a title and match refresh rate prompt will appear. Enable it and retry.

Are you using a fresh install of Kodi during these tests?
Backup your original and install a nightly so nothing is carrying over.
Adjust Kodi per post #1.
Add some titles including 3D with proper naming per post #1.
Just trying to eliminate anything obvious overlooked.
Are you using an advancedsettings.xml with anything related to 3D control in it?
If so, you need to edit it out or set the whole advancedsettings.xml aside for now.
That may be the only problem? If not, continue.....

Since a 2D is switching to 3D, then you have to control Nvidia nvstlink.exe using the original setup post #1 with both 2D and 3D .bats and playercorefactory (post #3) for non-smart.
You will also need to setup task scheduler post #46.
Nvidia stereoscopic will always be off and everything at 60Hz only changing to 24Hz during playback. You will have to manually turn stereoscopic on for 3D titles and off when finished. Here is how I used to do it:

Create 3D ENABLE.bat. I placed mine in the Documents folder.

@echo OFF

"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable

EXIT


Create 3D DISABLE.bat also in the Documents folder.


@echo OFF

"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /disable

EXIT

Install plugin.program.advanced.launcher-master https://github.com/angelscry/plugin.prog...d.launcher
There is nothing to configure. Open the app. Select default. Select context menu (Keyboard C). Select Create New Launcher. Navigate to 3D ENABLE.bat you just created. Do the same for 3D DISABLE.bat. These now appear as links in Advanced Launcher. Select context menu again and add each link to Favorites. I created a 3D MOVIES folder in my main menu. I then created a favorites link in 3D MOVIES submenu. When I want to use an external player to render a 3D title, I navigate to this submenu and select 3D ENABLE before I start the external player and select 3D DISABLE when finished.

This method should work for you. Let me know.....

Unfortunately we're back to where I had originally started in the thread I mentioned earlier. Much of what you suggested here has already been done by me before I even made the thread or used your instructions. The only instructions I had borrowed from you were the playercorefactory.xml/playiso.bat for launching PowerDVD as external player.

I already had 3DEnable & 3DDisable batch files from a solution I found at Anandtech a couple weeks ago, which I had been using in the interim while I tried to figure this out. In fact my method is simpler. I have the two batch files mapped to two unused buttons on my remote control. I don't need to install or use the Advanced Launcher to enable/disable 3D using nvstlink. I'm able to do that at the press of a button on my Remote Control.

I'm not sure what you're using the Task Scheduler for because I didn't see any need for it. All my 2D media runs at 24Hz, My desktop & games run at 60Hz, and when I want to watch 3D, I press the button on my Remote Control to switch to 1080p 3D @ 24Hz, and once I'm finished watching 3D, I press the other button which switches me back to 24Hz.

Let me also clarify something else, this has absolutely nothing to do with my Epson 5010 Projector or it's 'smart capabilities', which is something both me & Host505 were trying to mention in the other thread.

Here's why:

I've been using the EXACT SAME hardware - from my Epson 5010 & Yamaha RX-A2000 to the HDMI Cables, the HTPC and everything else in between - for the last 6 years!! I never had this issue - I never had to switch between 2D & 3D using buttons or batch files or go through these tedious setups. Everything worked flawless. Heck! 6 years ago I had little knowledge of refresh rates and frame rates and stuff. All my HD Media played at 24Hz - Smooth & Stutter free. All my 3D Media played in 3D, smooth & stutter free at 24Hz, in PowerDVD. All the Refresh Rate switching happened automatically - I had no intervention whatsoever.

There is 1 thing and only 1 thing which changed between all of those flawless 6 years and last month: nVidia GTX 1080.

For 6 years I had Intel HD3000 Graphics (The embedded chip in the Intel i5 Processor). Last month I replaced Intel HD3000 with nVidia GTX 1080 and suddenly all of these problems started.

So this has absolutely & only to do with nVidia GTX and it's drivers. Not my projector, not my receiver, and not my setup.

I also already did the Reset on the Dialog boxes in PowerDVD to make sure I match refresh rate in PowerDVD.

Again, using all of the instructions you provided, after making all the necessary adjustments, I'm still where I started.

If I leave "Stereoscopic 3D" enabled in nVidia Control Panel:

- 2D within Kodi tries to match refresh rate, switching it to 24Hz, which does not exist in "2D" Resolutions in nVidia Control Panel, only in 3D, and therefore my display switches to 3D.
- Same thing happens trying to play 2D in PowerDVD.
- 3D in PowerDVD works flawlessly.

If I leave "Stereoscopic 3D" disabled in nVidia Control Panel:

- Everything else works fine; Desktop, Kodi, Games & all run at 60Hz. All 2D Media runs smooth at 24Hz as Kodi matches Refresh Rate. All 2D media runs smooth at 24Hz in PowerDVD as PowerDVD matches Refresh Rate.
- However, PowerDVD does not switch display to 3D Automatically -- which used to happen with Intel HD3000. Now, I have to do it manually using Remote Buttons.

I have no doubts your instructions are working for you and others --- I still believe in your skills, knowledge & capabilities far more then mine -- and therefore I don't understand why it doesn't work the same way for me -- but it's not a Projector issue. It's an nVidia GTX 1080 issue. I've even come in contact with other people using nVidia having the same issues; while other using either AMD cards & Intel chips don't have this issue.

Again - Not trying to say you're wrong or your instructions don't work; just trying to be specific, they are not working for my setup, and its' not a Projector issue.

I'm actually to take some time to try your instructions one more time.

I have 2 questions for you:

i. In your instructions for PowerDVD, where you say:
Code:
PowerDVD 16:
[b]Enable Match Refresh Rate when you see the pop-up for the 1st time and choose not to show you again.[/b]
Enable Hardware Acceleration.
Turn off all enhancements.

Does it matter if you play 2D media or 3D media? Or should I play one or the other & then hit 'Yes' on the match refresh rate?

ii. In your nVidia Control Panel instructions below:
Code:
Nvidia:
In this exact order,
Download driver, create new desktop folder, and point it to unzip there. Delete folder after install unless you have a reason to keep it.
Choose Custom Install/Clean Install.
Uncheck 3D Vision Controller Driver unless you need it for some reason.
Uncheck Experience unless you want to add a Windows Credential and be reminded for updates.
Open Control Panel.
Adjust Image Settings with Preview. Quality. Apply.
Set Up Stereoscopic 3D Enable.
The Vision Test Window will open. Select Next and Next again.
Your panel will engage 3D. Select the proper images in the next 2 screens including the scrambled box with a pop-out box inside it.
Finish.
You will return to the desktop in low res 3D mode.
Select Change Resolution in Control Panel.
You will see HD 3D 720 is selected. Change it to HD 3D 1080. Change resolution to 23 or 24 Hz (Doesn't matter). Change Color Format, Depth, and Range to RGB, 12bpc, and FULL.
Select Apply and keep changes before reverting.
[b]Now select your native resolution for Ultra HD, HD, SD. Mine is 4k x 2k 3840 x2160. Change Refresh Rate to 60Hz. Select Apply.[/b]
Make sure RGB Full is still set. Depth will be blank. It's ok. It will revert to 8, 10, or 12 bit depending on the content it's fed in the future.
Remember to play a 2D title, pause it, minimize the player, and readjust these settings if need be. Do the same for 3D and Windows desktop, all individually. Adjust TV settings at the same time. For example. You are playing a 2D title in KODI or PDVD. Check your panel INFO button. It should show you are playing at 24Hz. Minimize it while paused. Check Nvidia Control Panel color format, depth and range. You should still be at RGB Full. Change if needed. It will remember and you will never have to do it again. Check your TV settings are proper. This too will change depending on what you have input but will remember so you don't have to do it again.

Do you leave Stereoscopic 3D "Enabled" or "Disabled" in the control panel. In a previous instruction you had mentioned Disable it after making all the adjustments. However, in this post you didn't mention that. Just wanted to clarify.

Thanks again for your help.
Quote:I'm not sure what you're using the Task Scheduler for because I didn't see any need for it.

Because after you reboot Windows, you will see it enables stereoscopic even though you turned it off prior to rebooting.
So, you have task scheduler turn it back off for you.
As I wrote, in your case you want stereoscopic off at all times otherwise 2D is going to play in 3D. This is why you need to manually enable stereoscopic just prior to playing a 3D title, either from the Kodi GUI or mapping your remote to toggle nvstlink.exe.

Quote:There is 1 thing and only 1 thing which changed between all of those flawless 6 years and last month: nVidia GTX 1080.

Windows 10 wasn't released until July 29, 2015. That changed. Yes, it makes a HUGE difference in setups. You have to determine your hardware/software and use your best judgement in all these posts to set something up for yourself. Everyone has different combinations.
Are you using:
1080 or 4k?
W10, 8, or 7?
Smart or dumb hardware?
Which Kodi build?
There is a different method for all of these variables. I don't think there is difference in Nvidia models. I used a GTX 650 and now a GTX 960 and both work. I don't think your 1080 would be any different.

I can read your frustration. Been there done that. Eventually I worked it out using the various methods in this thread. As time goes by, so does O/S upgrades, hardware, etc. thus why there are so many methods to accomplishing..... and the confusion. Toss in user variances and here we are. I'm not dissing your PJ or telling you to upgrade or anything. I can tell you this so you understand. Was running the same setup for years just like you. Upgraded to W10, had to make a bunch of changes. Worked for a year perfectly. Upgraded to smart 4k and had to make a bunch of changes. I could literally swap the HDMI cable from dumb 1080 Samsung panel to smart Samsung panel and Nvidia went crazy. It was then I learned ALL the mods to make dumb 1080 and Nvidia work were because my dumb 1080 was inhibited. The moment I plugged HDMI from Nvidia into the smart panel, all those mods went out the window because everything just worked in harmony with 4k. Thus, Nvidia and it's drivers are not a problem. The problem is forcing Nvidia to continue playing nice with older hardware and forcing it to do what the hardware cannot. This is why this thread has so many variables. One of the methods will work. We are trying to diagnose what does not work, why, and how to 'fix' it.

Quote:Does it matter if you play 2D media or 3D media? Or should I play one or the other & then hit 'Yes' on the match refresh rate?

Doesn't matter, once it understands 24Hz, it's set.

Quote:Do you leave Stereoscopic 3D "Enabled" or "Disabled" in the control panel. In a previous instruction you had mentioned Disable it after making all the adjustments. However, in this post you didn't mention that. Just wanted to clarify.

In your case, disabled. You always want it disabled, thus the task scheduler and nvstlink.exe toggle.

We are trying to establish a 100% working setup starting from scratch. If you are integrating codes from elsewhere, modding what's here, etc. I can't help you.
Although it's cumbersome, I'm fairly certain if you follow my instructions, you will eventually get everything in harmony. Don't assume or cut corners. Once you have a working setup, mod from there. You tried method 3 from scratch following to a 't'. Okay, it didn't work. As, stated, you would be testing that one. Now I understand the consequences of what went wrong. 2D as 3D etc. Nvidia thinks 24Hz is 3D. Your PJ won't tell it otherwise. Time to intervene.

You say you already tried:
Since a 2D is switching to 3D, then you have to control Nvidia nvstlink.exe using the original setup post #1 with both 2D and 3D .bats and playercorefactory (post #3) for non-smart.
You will also need to setup task scheduler post #46 because W10 is going to turn on stereoscopic at reboot and you want it off.
Nvidia stereoscopic will always be off and everything at 60Hz only changing to 24Hz during playback.

Again, don't assume or cut corners or copy old files etc. Follow the instructions fresh exactly and let's see what you end up with.
My last response came out rather harsh, due to my frustration with this setup and somewhat traveling in circles, but considering it was a response to someone who's going the extra mile to lend a helping hand with nothing in return, I must apologize.

I completely understand your point about tiny little changes in software & hardware throwing all of your specifications and mods and settings out the window! I've been there, done that, so yes, I agree with you.

I should have mentioned this during my previous rant about the 6 flawless years, but I did switch to Windows 10 last year sometime in August, which didn't create any problems at all with my existing setup w/ Intel HD3000 and the rest. For the 5 preceding years w/ Windows 7 then 8, and from Aug, 2015 through July, 2016, with Windows 10, everything worked flawlessly until my GTX 1080 arrived in July this year. Never had to worry about refresh rates, 2D/3D switching or stutter.

Either way, I understand your point and I have to work with the current setup and come to the best solution.

So, I did actually start from scratch all over again, and I have some results to share.

(2016-10-12, 20:43)brazen1 Wrote: [ -> ]
Quote:I'm not sure what you're using the Task Scheduler for because I didn't see any need for it.

Because after you reboot Windows, you will see it enables stereoscopic even though you turned it off prior to rebooting.
So, you have task scheduler turn it back off for you.
As I wrote, in your case you want stereoscopic off at all times otherwise 2D is going to play in 3D. This is why you need to manually enable stereoscopic just prior to playing a 3D title, either from the Kodi GUI or mapping your remote to toggle nvstlink.exe.

As strange or surprising this may sound, this is not the case on my system at all! Once I disable Stereoscopic 3D in the nVidia Control Panel, it doesn't turn back on upon reboot. I just tested this. I unchecked that box, hit apply, made sure it was off. Reboot my PC. Opened nVidia Control Panel, and the box was still unchecked. The 3D resolutions were not available. I'm not sure why the difference, but on my system the Stereoscopic 3D does not automatically re-enable upon reboot.

Which explains why I wasn't understanding the necessity for the Task Scheduler.

(2016-10-12, 20:43)brazen1 Wrote: [ -> ]Again, don't assume or cut corners or copy old files etc. Follow the instructions fresh exactly and let's see what you end up with.

Agreed! So here's where I am at now:

Just out of completeness, I started from scratch and followed all of the steps as detailed in your updated Post #112.

- Configured PowerDVD as defined in Post #112.
- Configured Kodi as defined in Post #2
- Configured nVidia Control Panel as defined in Post #112.
- After making all necessary adjustments in nVidia Control Panel, disabled Stereoscopic 3D and set resolution to 1080p, 60Hz
- Reboot PC & made sure Stereoscopic 3D was still disabled. It was.

- Using "playercorefactory.xml" from Post #112 as follows:
Code:
<playercorefactory>
<players>
   <player name="PowerDVD" type="ExternalPlayer" audio="false" video="true">
     <filename>C:\Program Files (x86)\CyberLink\PowerDVD16\PowerDVD.exe</filename>
     <args>"{1}" /fullscreen /close</args>
     <hidekodi>false</hidekodi>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
   </player>
</players>
<rules action="prepend">
   <rule filetypes="iso|bdmv|mpls|m2ts" player="PowerDVD"/>
</rules>
</playercorefactory>

And here's the result:

- Windows Desktop, Games, Kodi, everything runs beautifully at 1080p 60Hz
- All 2D Media in Kodi plays back beautifully at 1080p 24Hz. Kodi is successfully matching frame rate & changing it to 24Hz.
- All 2D ISO's in PowerDVD play back beautifully at 1080p 24Hz. PowerDVD is successfully matching frame rate & changing it to 24Hz.
- After playback stops, either in Kodi or PowerDVD, frame rate returns back to 60Hz unless media is played again.

All of the above works well.

- As before, 3D ISO's in PowerDVD do not switch display to 3D, and playback in 2D only.

For this, the two remote buttons I have can be used to enable & disable 3D 24Hz using the batch files I stated earlier. They are completely identical to what you posted here earlier. Essentially using /enable or /disable with "C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe"

Although this is acceptable if it's the best I'll get, I'd still like to explore the option of enabling / disabling nvstlink.exe automatically via scripts as you provided in Post #1.

I know I can revert back to the other "Playercorefactory.xml" and use it in conjunction with "PlayISO.bat" like so:

Code:
:playiso
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 %1
"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable
timeout /t 3
"C:\Program Files (x86)\CyberLink\PowerDVD15\PowerDVD.exe" A:
"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /disable
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u
GOTO end

... but before I do that, I wanted to ask you, is there any way to execute nvstlink.exe /enable or /disable via "playcorefactory.xml" itself, without the need of PlayISO.bat?

Other then that, if you can suggest anything else, I'm all ears.

Thanks again for all your help!
Quote:everything worked flawlessly until my GTX 1080


Of course. Everything changes going from Intel to Nvidia.

Quote:I'm not sure why the difference, but on my system the Stereoscopic 3D does not automatically re-enable upon reboot.


Perhaps the upgrade to Anniversary build addressed that issue?
Ok. Now we know you don't need any task scheduler. Turn off stereoscopic and delete the task.

Quote:Using "playercorefactory.xml" from Post #112 as follows:
As before, 3D ISO's in PowerDVD do not switch display to 3D, and playback in 2D only.


Nope. Use post #3 playercorefactory.xml. Also use both .bats. Notice the 3D.bat has the nvstlink.exe switch and the 2D doesn't. This is why. You only want it to enable for a 3D session so it has it's own bat called up only for a 3D title.

You are going to have to continue manually pressing the nvstlink mapped button on your control prior to 3D playback I think? Maybe not. I didn't have to in the past. If the nvstlink switch via the bat doesn't auto control this for you, not sure what else could.
We are getting closer.
Switch playercorefactory and install both bats.
Let me know.
(2016-10-13, 01:19)brazen1 Wrote: [ -> ]
Quote:I'm not sure why the difference, but on my system the Stereoscopic 3D does not automatically re-enable upon reboot.

Perhaps the upgrade to Anniversary build addressed that issue?
Ok. Now we know you don't need any task scheduler. Turn off stereoscopic and delete the task.

Yes! Very likely. Agreed & done.

(2016-10-13, 01:19)brazen1 Wrote: [ -> ]Nope. Use post #3 playercorefactory.xml. Also use both .bats. Notice the 3D.bat has the nvstlink.exe switch and the 2D doesn't. This is why. You only want it to enable for a 3D session so it has it's own bat called up only for a 3D title.

Understood! That makes total sense. I'm assuming that the way playercorefactory.xml detects whether or not the ISO is 3D is by looking at the filename - so I must have "3D" in the ISO's filename (Which I do), correct?

(2016-10-13, 01:19)brazen1 Wrote: [ -> ]Switch playercorefactory and install both bats.
Let me know.

I'll try this today & report back.

Thanks!
(2016-10-13, 01:19)brazen1 Wrote: [ -> ]Nope. Use post #3 playercorefactory.xml. Also use both .bats. Notice the 3D.bat has the nvstlink.exe switch and the 2D doesn't. This is why. You only want it to enable for a 3D session so it has it's own bat called up only for a 3D title.

Two quick questions as I'm setting this up:

I'm trying to understand the "3D" rule in the filename as you have defined:

Code:
".*.3D.*|.*.3D.iso|3D.*"

All my 3D ISO's do have the word "3D" in the filename, basically at the end in parenthesis. For example:

Code:
Avatar (3D).iso
Gravity (3D).iso

Will this standard of file naming be picked up by the rule:

Code:
<rule filename=".*.3D.*|.*.3D.iso|3D.*" player="3D"/>

Or do I need to modify the rule to pick up "(3D)" at the end of filenames?

And lastly, you have a very beautiful /fullscreen and /close in the newer version of playercorefactory within the <args> tag, like so:

Code:
<args>"{1}" /fullscreen /close</args>

Can I still implement the same using the older playercorefactory.xml?

Thanks!!
I think bracketing gets ignored but try your naming and see.
This is what works for me:

Avatar (2009) .3D for full rips
Avatar (2009) .3D.SBS for side by side
Avatar (2009) .3D.TAB for top and bottom

and yes, the argument {1} is for iso container and fullscreen defaults so I doubt you need to add it. Try it.
Hi,

sorry for my english.

I have a gtx 1070 in W10 Pro. Now I use POWER DVD for 3d blu-ray isos, and kodi for all the rest.

I am confused about playing 3d iso with kodi, is it possible or it is necessary to configure an external player?

In this link --> (sorry, it is in spanish) " https://www.kodimania.com/viewtopic.php?...pic=4810.0 " seems to indicate that yes, that it is possible but may just with a raspberry pi.

Again, sorry for my english and I hope you can make it clear.

Thanks