Kodi Community Forum

Full Version: Failed building packages for pvr.vdr.vnsi
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Well i try to build the pvr vdr vnsi addon as far as i know the way it sould be done.

I called cmake in projects/addons like this: cmake -DADDONS_TO_BUILD=pvr.vdr.vnsi .
While here ends the information i went deeper into build(pvr.vdr.vnsi
Then i added a changelog to depends/

Finally i called debuild -us -uc -d

It fails with the following error:
Quote:-- Installing: /usr/src/xbmc-stuff/kodi/project/cmake/addons/build/pvr.vdr.vnsi/debian/tmp/usr/share/kodi/addons/pvr.vdr.vnsi/resources/skins/skin.confluence/720p
-- Installing: /usr/src/xbmc-stuff/kodi/project/cmake/addons/build/pvr.vdr.vnsi/debian/tmp/usr/share/kodi/addons/pvr.vdr.vnsi/resources/skins/skin.confluence/720p/Admin.xml
-- Installing: /usr/src/xbmc-stuff/kodi/project/cmake/addons/build/pvr.vdr.vnsi/debian/tmp/usr/share/kodi/addons/pvr.vdr.vnsi/resources/skins/skin.confluence/720p/ChannelScan.xml
make[1]: Leaving directory '/usr/src/xbmc-stuff/kodi/project/cmake/addons/build/pvr.vdr.vnsi/obj-x86_64-linux-gnu'
dh_install: kodi-pvr-vdr-vnsi missing files (usr/lib/*/kodi/addons/pvr.vdr.vnsi/pvr.vdr.vnsi.so*), aborting
debian/rules:10: recipe for target 'binary' failed
make: *** [binary] Error 2
dpkg-buildpackage: Fehler: Fehler-Exitstatus von fakeroot debian/rules binary war 2
debuild: fatal error at line 1376:
dpkg-buildpackage -rfakeroot -d -us -uc failed

Beside of this i wonder the following things:
1. even though kodi itself defaults for installation prefix to /usr/local why does the pvr.vdr.vnsi addon default to /usr
2. why is the pvr.vdr.vnsi addon not following different prefix configuration given my the correspodning cmake declaration. Other addons follow the configuration but this one has it hard coded at several points.

IBecause of this strange hard coded install prefix i forced kodi to /usr.

I tried building many (not all) of the addons and all build and package fine and follow the install prefiix configuration except pvr.vdr.vnsi.

I would be greatfull if someone can clarify what i'm missing and maybe fix this.[/quote]
don't use the in-tree build for deb builds, use standalone.

1) debuild https://github.com/Pulse-Eight/platform
2) debuild https://github.com/xbmc/kodi-platform
3) debuild kodi itself (it installs headers - stick these in a -dev)
4) you can now package each addon separately, exactly as you'd expect to do things.

the in-tree build is mainly for cross builds/non-linux platforms.
Building individual binary addons in tree works and is documented in https://github.com/xbmc/xbmc/blob/master...ADME.linux, not necessarily required to build as ironic_monkey pointed out though it works. Certainly compiling as OP is doing is not right.

Ive never tried the PVR addons that way but if it fails it should then only need compiling https://github.com/xbmc/kodi-platform and then as readme says.
the compiling is not failing.. The packaging is failing.

debuild kodi itself is not working as it does not have a debian subdirectory. you may refere to a different branch containing this?

The issues are the same no matter if i do the in-tree build or the individual. anyhow, i will look into the posted links.

beside of that it remains annoysing why only the pvr.vdr.vnsi addon is hardcoded to /usr and ignores overriding.
In v15 binary addons install to where kodi is installed so if kodi is /usr thats where they will end up.
kodi packaging is in a separate repo.
(2015-07-01, 21:02)uNiversal Wrote: [ -> ]In v15 binary addons install to where kodi is installed so if kodi is /usr thats where they will end up.

kodi is /usr/local but the pvr addon refuses to be installed to that as i already wrote several times.
r r
anyhow, i managed to work around that and am facing another issue. the pvr addon for vnsi seems bugged. it stops working after 20s every time and claims a vnsi client error. this happens only with versions since juni or and of may. but recent kodi update enforces the new pvr vdr vnsi addon version.

i'll open a bug report with logs for that issue.
It's a personal issue for you ... vnsi works fine on all my machines, running latest and greatest ... same for OpenELEC which ships that version.
No Debug Log no problem ...