Kodi Community Forum

Full Version: Problems with PulseAudio
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am running Kodi on Ubuntu 14.04.2 LTS x86; install method is PPA (team-xbmc/ppa/ubuntu trusty main). My sound system is PulseAudio with all the settings on the defaults, outputting audio through the HDMI port of my graphics card. It works fine under Unity and Xfce.

In Kodi, on the other hand, I get no sound at all, but when I switch to the tty and back (Ctrl+Alt+F1, Ctrl+Alt+F7) – and only then – it suddenly works without any problems.

The log contains no audio-related errors or warnings and even when sound does not work, Kodi's audio output menu lists all PulseAudio output devices correctly.

Any ideas?

Ubuntu version: Ubuntu 14.04.2 LTS x86
Kernel: Linux hex 3.16.0-43-generic #58~14.04.1-Ubuntu SMP Mon Jun 22 10:21:00 UTC 2015 i686 i686 i686 GNU/Linux
Kodi version: Kodi 14.2 Git:7cc53a9
Graphics card: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)
Graphics driver: nvidia 304.125 (proprietary)
Full debug log: http://lpaste.net/137213
I upgraded to Kodi 15 and the problem is still there. Still no idea what causes it.
Provide: pactl list sink-inputs and pactl list sinks while playing in kodi

After that also provide you guisettings.xml
Interestingly, pactl list first gives me the error message
Code:
Failed to create secure directory (/run/user/1000/pulse): Permission denied
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

User 1000 is another user on my system; the kosi user has uid 1001. I deduced that XDG_RUNTIME_DIR was set to the wrong value and did the pactl list with ‘XDG_RUNTIME_DIR=/run/user/1001’. That worked and gave me the following outputs:

Initially (when audio does not work):
sink-inputs: http://pastebin.com/b4JMPDpG
sinks: http://pastebin.com/bBTN5ATY

After doing the Ctrl+Alt+F1/Ctrl+Alt+F7 trick (when audio does work):
sink-inputs: empty
sinks: http://pastebin.com/DL7rHmHv

guisettings.xml: http://pastebin.com/RRyN8pCe
Volume in kodi is a bit low
Quote:Volume: 0: 58% 1: 58%

Besides that - everything is fine. Your issue is not kodi related.

Post a kodi Debug Log _before_ it works and _after_ it works.
Debug log before it works: http://pastebin.com/cdZigZTf
Debug log after it works: http://pastebin.com/r0eJGtMG
Diff of the two logs: http://pastebin.com/1Emmfvbn
No idea - nothing the log would tell. Seems rather the hdmi device gets reinited when you switch the console ...

Do you start kodi from a window manager? Or do you boot directly into the session?
I use lightdm and its auto-login feature to log in the kodi user automatically, which also starts Kodi automatically.

However, the same problem also occurs when I exit Kodi and log in the Kodi user manually.

I'd be fine with a dirty hack to makes this work, such as reinitialising the HDMI device from a script or something a few seconds after Kodi is started, if you think that might do the trick.
Please get me the same logs from a user session. Also a log from a session when you run vlc.

I need: pactl list sinks and pactl list sink-inputs
Sorry, what do you mean by "user session"?
Login to a desktop session, does this reveal the sampe issue? Does paplay with a wav directly work after login or same issue?
Okay, I logged into a ‘normal’ desktop session with the Kodi user and it turns out audio did not work there either. I then opened pavucontrol and changed HDMI output from ‘unplugged’ to ‘plugged-in’ (still haven't got any idea why that option exists in the first place).

Turns out that did the trick. Sound worked in the desktop session, and it also works in Kodi without a surrounding desktop session from the very beginning, without the Ctrl+Alt+F1 workaround.

I have no idea why this workaround actually worked and PulseAudio remains a mystery to me in general, but at least, my setup works now.


Thanks for the help and your patience!