Kodi Community Forum

Full Version: [SOLVED] Ctl + S works for screenshots, but not remote button
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a MCE remote with the record button mapped to the screenshot function. Here is the relevant part of my ~/.kodi/userdata/Lircmap.xml

<lircmap>
<remote device="mceusb">
<Screenshot>KEY_RECORD</Screenshot>
</remote>
</lircmap>


And when I run irw in a terminal and press the record button on my remote I can see that I mapped the correct button:

000000037ff07be8 00 KEY_RECORD mceusb

All my other remote buttons work fine. The Ctl + S key combo on my keyboard will take a screenshot perfectly well (although it no longer makes the camera shutter sound when taking a screenshot). The PrintScreen key on the keyboard does not work for screenshots, but I never used that key anyway.

The screenshot button (record key)used to work on this setup months ago when Kodi was still branded as XBMC, but stopped working some time after one of the upgrades.

Finally, when digging though the kodi.log I found this, but I am not sure where to proceed with the trouble shooting:

01:08:26 T:139800217532160 ERROR: CDVDMsgGeneralSynchronize - timeout
01:08:31 T:139800647600128 ERROR: Remote Translator: Can't find button screenshot
01:08:36 T:139800647600128 ERROR: Previous line repeats 14 times.


I'm currently running Kodi 15.0-1 on an 64 bit Arch Linux system with 4.1.2-2 kernel.
I think I fixed it. Apparently the contents of the ~/.kodi/userdata/keymaps folder has some influence on what buttons can work on the remote. My keymaps folder was empty so I copied /usr/share/kodi/system/keymaps/remote.xml into ~/.kodi/userdata/keymaps

Then I edited that new remote.xml file to have the following line:
<global>
<remote>
<record>Screenshot</record>
</remote>
</global>

I have no plans to use the record button for PVR functions, so I don't mind giving up the key

Then I had to put Lircmap.xml back the way I found it so the KEY_RECORD line was edited to be this:
<record>KEY_RECORD</record>

Now the record button on my remote takes screenshots again!