Kodi Community Forum

Full Version: Shows in SQL Library but Links Broken
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am so close to having two Kodis share the same library. Right now my main machine is hosting the library and the bedroom machine is reading it. Here is what happens.

1 - I can go in to videos and click on "Kodi" in the bedroom and access the machine via the network and play all the files.
2 - I can see the library on the bedroom machine. Even as I update the library in the main room the files appear in the bedroom. However if I try to play the file that was JUST added to the library in the bedroom it'll say the file is missing. The main room can play all the files though.

My only thought is that somehow from my existing library it's using that info and telling the bedroom to look on a USB port... I don't know... I'm confused as to why with me recreating the library it sees the library but can't access the location.

different source paths. E.g. On your main htpc, the path might be a local filesystem, lets say /media/movies
If your bedroom box doesn't mount the same files under the _exact same_ path, it won't work.

edit: a Debug Log will tell
99% sure I fixed the problem.

Like a fool I added in the library like I use to by scanning the folders on the main machine. Now I've added them as an SMB source and have started the scan on them as a network location. The wiki is great and got me almost there but this video really helped. So for anyone else in the same boat as me... Here you go.


P.S. Sorry about not posting a debug log. Whatever problem I encounter next will come with a debug or crash log.
Yep! That was the problem. It is now fixed and working. It was actually your post that got me thinking.

It really isn't that complicated to do but I've been running Kodi one way for 7 years and now I'm running it a completely different way. My old ways of doing things took over on the final step and I simply added the media as a local source instead of a network source.
simple: you mount the external drive on the main pc and then share it via samba just like any other dir.
I was literally being so ADD that I looked over the drive and went to "Movies" instead of clicking the drive. My incompetence was legendary here. I had complete tunnel vision.

I always work on these things before posting... sorry this post literally mounts up to me being an idiot.

With that said, the video posted is a great tutorial (basically walks you through the wiki) on how to get everything configured properly.
if it works now, please edit your thread title to solved.