Kodi Community Forum

Full Version: Rooster Teeth
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11
Hey, Thanks for the addon and your hard work. Just wanted to let you know that it seems the login credentials don't seem to work. I've have no issues on the site but won't work in add on.
Usually authentication problems are due to the case of the username not being correct. The web site doesn't care if you log on as nocase even if your account is actually noCase but it won't work in the addon.

Look up your profile on the RT web site and verify exactly how your account is named there, including uppercase letters. Make sure you configure the addon exactly the same way your account is configured on the web site (https://roosterteeth.com/settings/account/profile).
Usually I'd say you are 100% correct, but in this instance I don't believe that to be the case. I've tried every variation possible and it doesn't work. Example being that you need to be signed to watch "hedgehog for hire" aside from the newest episode, works on site not addon. Thanks for trying to help though.
Hmm, I think it's a problem with the RT web site. I tried that specific show and I'm able to watch the one episode posted in season 8 but episodes from previous seasons fail to play, but I don't get an error message, it just won't play.

That used to happen sometimes with older content, not sure why. I doubt it's an authentication issue because I'm able to watch First content without problem. May just be something special about how that specific show gets linked.
(2019-01-20, 12:43)Hamsterkill Wrote: [ -> ]I've been noticing that certain videos I play through this addon start about 4-5 seconds into the video. The RWBY series is the clearest example as they start partway through the opening themes. Not all RT videos may be prone to this problem, though. This is with "Adjust display refresh rate" off, by the way, and I can't seem to reproduce the issue outside of the RT addon. I've been able reproduce this issue with 17.6 for Windows and Android TV and with 18 RC5 for Xbox.

Debug log, if it helps: https://paste.kodi.tv/qaromavecu

Going back to this issue, A Kodi dev on the bug I filed for this suggested that the addon should use Roosterteeth's master m3u8 playlists, which are supported by inputstream.adaptive.
(2019-05-09, 17:05)Hamsterkill Wrote: [ -> ]
(2019-01-20, 12:43)Hamsterkill Wrote: [ -> ]I've been noticing that certain videos I play through this addon start about 4-5 seconds into the video. The RWBY series is the clearest example as they start partway through the opening themes. Not all RT videos may be prone to this problem, though. This is with "Adjust display refresh rate" off, by the way, and I can't seem to reproduce the issue outside of the RT addon. I've been able reproduce this issue with 17.6 for Windows and Android TV and with 18 RC5 for Xbox.

Debug log, if it helps: https://paste.kodi.tv/qaromavecu

Going back to this issue, A Kodi dev on the bug I filed for this suggested that the addon should use Roosterteeth's master m3u8 playlists, which are supported by inputstream.adaptive. 
The addon already uses a m3u8 playlist. You could try setting up vlc in kodi: https://kodi.wiki/view/External_players to see if that fixes the stuttering...
(2019-05-11, 07:13)Skipmode A1 Wrote: [ -> ]
(2019-05-09, 17:05)Hamsterkill Wrote: [ -> ]
(2019-01-20, 12:43)Hamsterkill Wrote: [ -> ]I've been noticing that certain videos I play through this addon start about 4-5 seconds into the video. The RWBY series is the clearest example as they start partway through the opening themes. Not all RT videos may be prone to this problem, though. This is with "Adjust display refresh rate" off, by the way, and I can't seem to reproduce the issue outside of the RT addon. I've been able reproduce this issue with 17.6 for Windows and Android TV and with 18 RC5 for Xbox.

Debug log, if it helps: https://paste.kodi.tv/qaromavecu

Going back to this issue, A Kodi dev on the bug I filed for this suggested that the addon should use Roosterteeth's master m3u8 playlists, which are supported by inputstream.adaptive.  
The addon already uses a m3u8 playlist. You could try setting up vlc in kodi: https://kodi.wiki/view/External_players to see if that fixes the stuttering... 

No, it's not a stuttering issue, it just starts 4 seconds in, and can't be rewinded before that.

But no, the suggestion was the use the master m3u8 playlists, which, if I understand correctly, are a playlist of playlists that allow for adaptive quality on the videos.

For instance, the addon provides: https://rtv2-video.roosterteeth.com/uplo...1080P.m3u8
While I think the suggestion is to provide: https://rtv2-video.roosterteeth.com/uplo...index.m3u8

I'm still trying to figure out the details of the suggestion, though, since the second URL still causes the issue in a strm file. If I can get what's suggested working in a strm file, I'll post again. For reference, the issue is here: https://github.com/xbmc/xbmc/issues/15278
(2019-05-11, 07:13)Skipmode A1 Wrote: [ -> ]
(2019-05-09, 17:05)Hamsterkill Wrote: [ -> ]
(2019-01-20, 12:43)Hamsterkill Wrote: [ -> ]I've been noticing that certain videos I play through this addon start about 4-5 seconds into the video. The RWBY series is the clearest example as they start partway through the opening themes. Not all RT videos may be prone to this problem, though. This is with "Adjust display refresh rate" off, by the way, and I can't seem to reproduce the issue outside of the RT addon. I've been able reproduce this issue with 17.6 for Windows and Android TV and with 18 RC5 for Xbox.

Debug log, if it helps: https://paste.kodi.tv/qaromavecu

Going back to this issue, A Kodi dev on the bug I filed for this suggested that the addon should use Roosterteeth's master m3u8 playlists, which are supported by inputstream.adaptive.       
The addon already uses a m3u8 playlist. You could try setting up vlc in kodi: https://kodi.wiki/view/External_players to see if that fixes the stuttering...      

Okay, it seems to be as I said, though Kodi also has to be told to use inputstream.adaptive with the inputstreamaddon=inputstream.adaptive and inputstream.adaptive.manifest_type=hls properties on the list item given to Kodi. Note inputstream.adaptive won't work with the current direct quality m3u8 URLs on the current release, but the code is already in inputstream.adaptive's git to work with them, too, per the conversation on the linked Github issue above.
I messed with it a bit and it seems that adaptive inputstream is working. I made a new TEST-version: https://github.com/skipmodea1/plugin.video.roosterteeth. Download and install the zip. Then restart Kodi. The RT addon now has a switch for adaptive inputstream. You could try to see if turning that on fixes your problem, since i can't reproduce your problem on my pc.
(2019-05-12, 11:35)Skipmode A1 Wrote: [ -> ]I messed with it a bit and it seems that adaptive inputstream is working. I made a new TEST-version: https://github.com/skipmodea1/plugin.video.roosterteeth. Download and install the zip. Then restart Kodi. The RT addon now has a switch for adaptive inputstream. You could try to see if turning that on fixes your problem, since i can't reproduce your problem on my pc.

Seems to work. Thanks. Once inputstream's release supports the direct quality m3u8's, you could even support the target resolution settings on it. It's interesting that you can't reproduce my issue, though. I've been able to reproduce it on default configurations for every platform I've tried. I wonder what could be different.
Ah yes, i can reproduce the problem after all. Anyway i'll prob release a new version of the addon soonish.
When I go to the Inside Gaming section I get the Funhaus section of videos showing up.
That's a bug, i will have a look.
(2018-04-07, 07:54)Skipmode A1 Wrote: [ -> ]Yeah, the site has no next-page option. It shows the last 30 items.

Any fix to this? So much material is missing from the addon, for example, Funhaus -> Gameplay -> 2016 is missing around 270 videos, as "Show more" is missing from the app, same with Red vs Blue seasons. I love this addon and use it daily, but so much is missing and I would just love to use this 100% for all Rooster Teeth videos. 

Thanks in advance!
It will have a look, it seems possible now.
Pages: 1 2 3 4 5 6 7 8 9 10 11