Kodi Community Forum

Full Version: skin helper service
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2016-03-13, 21:55)marcelveldt Wrote: [ -> ]
(2016-03-13, 21:07)tomer953 Wrote: [ -> ]1. it's not working, since your using two identical parameters - "action"
and for make search easier for you:
default.py - line 240
Code:
actions = params.get("ACTION").split("|")
replace the "ACTION" for something else, and let me know the new name.
2. please be aware that you have multiple places (yesno\ok\message dialogs) in the readme when you have a missing equal sign: header[yourheadertext]
3. thx

1) Now fixed on Git, please test...
https://github.com/marcelveldt/script.sk...ialogyesno

2) Yeah, it's the Git autoformatting for the text doing that...

it's working. thanks
(2016-03-13, 22:00)marcelveldt Wrote: [ -> ]
(2016-03-12, 18:20)Mike_Doc Wrote: [ -> ]Hi Angelinas,

Yes, saw you post in my thread, thanks. But this

$INFO[Window(home).Property(SkinHelper.AnimatedPoster)]

Doesn't work in layouts (item/focused)? well for me anyway?

Hi Mike,

I've now added the animatedposters to the webservice too:

https://github.com/marcelveldt/script.sk...nal-params

Please check latest Git.

Hi Marcel,

Thanks very much for adding this option, like Angelinas I'm just getting a static image but I've also noticed something else, this is in my poster var:

<value condition="Skin.HasSetting(SkinHelperAnimations)">http://localhost:52307/getanimatedposter&amp;imdbid=$INFO[Listitem.IMDBNumber]&amp;fallback=$INFO[Listitem.Art(poster)]</value>

If I remove the %amp; etc for the fallback then I get the animated poster but it is static and then I'm missing poster for any movie that doesn't have an animated poster. But with the full line I just get the fallback everytime i.e. ListItem.Art(poster)? Is there something wrong with my condition? Can't see anything but I'm getting this behaviour at the moment?

TIA,

Mike.
(2016-03-15, 21:08)Mike_Doc Wrote: [ -> ]Thanks very much for adding this option, like Angelinas I'm just getting a static image but I've also noticed something else, this is in my poster var:

<value condition="Skin.HasSetting(SkinHelperAnimations)">http://localhost:52307/getanimatedposter&amp;imdbid=$INFO[Listitem.IMDBNumber]&amp;fallback=$INFO[Listitem.Art(poster)]</value>

Well, I didn't test it myself but reading your reports I must believe that an animated gif is not supported inside a itemlayout...
You may as well try this by linking directly to the cached image in the Thumbnails folder:

Set this as path:

special://Thumbnails/animatedgifs/$INFO[Listitem.IMDBNumber]_poster_0_original.gif
Kodi limitation confirm.....not working AnimatedPoster In list, for kodi Krypton

Marcel leave this code in script for future......

Code:
ERROR: Texture manager unable to load file: special://Thumbnails/animatedgifs/tt0903624_poster_0_original.gif
Edit...Gade found missing part Smile
(2016-03-15, 22:57)Gade Wrote: [ -> ]Hell yeah!

I got
Code:
special://masterprofile/Thumbnails/animatedgifs/$INFO[Listitem.IMDBNumber]_poster_0_original.gif

to work inside containers. Remember to put "masterprofile" in the code...

Brilliant! Wink
(2016-03-15, 21:11)marcelveldt Wrote: [ -> ]Well, I didn't test it myself but reading your reports I must believe that an animated gif is not supported inside a itemlayout...
You may as well try this by linking directly to the cached image in the Thumbnails folder:

Set this as path:

special://Thumbnails/animatedgifs/$INFO[Listitem.IMDBNumber]_poster_0_original.gif

Hell yeah!

I got
Code:
special://masterprofile/Thumbnails/animatedgifs/$INFO[Listitem.IMDBNumber]_poster_0_original.gif

to work inside containers. Remember to put "masterprofile" in the code...

Brilliant! Wink


EDIT: Hmmm.. this leaves tons of errors in the log for each missing animated poster. Can't figure out a visible condition for this...
Hmmm if the direct path works so should the webservice....

Did you try this ?

http://localhost:52307/getanimatedposter&amp;imdbid=$INFO[Listitem.IMDBNumber]&amp;fallback=$INFO[Listitem.Art(poster)]

You can also try it with a webbrowser. Just leave Kodi open and on the same pc enter the path with some actual values e.g.:

http://localhost:52307/getanimatedposter&imdbid=tt1345836
Marcel PVR Art is out of order....menu things dont working window-properties.
https://github.com/marcelveldt/script.sk...properties
only work PVR inside list https://github.com/marcelveldt/script.sk...side-lists
Code:
23:57:06 T:2212  NOTICE: Skin Helper Service --> getPVRThumb for dbID: luckSKY ATLANTIC DE
23:57:06 T:2212  NOTICE: Skin Helper Service --> getJson - invalid result for Method PVR.GetRecordings - params: { "properties": [ "art", "channel", "directory", "endtime", "file", "genre", "icon", "playcount", "plot", "plotoutline", "resume", "runtime", "starttime", "streamurl", "title" ]} - response: {u'limits': {u'start': 0, u'total': 0, u'end': 0}}
23:57:06 T:2212  NOTICE: Skin Helper Service --> getJson - invalid result for Method VideoLibrary.GetTvShows - params: { "filter": {"operator":"is", "field":"title", "value":"Luck"}, "properties": [ "dateadded", "file", "lastplayed","plot", "title", "art", "playcount","sorttitle", "mpaa", "premiered", "year", "episode", "watchedepisodes", "votes", "rating", "studio", "season", "genre", "cast", "episodeguide", "tag", "originaltitle", "imdbnumber" ] } - response: {u'limits': {u'start': 0, u'total': 0, u'end': 0}}
23:57:06 T:2212  NOTICE: Skin Helper Service --> getJson - invalid result for Method VideoLibrary.GetMovies - params: { "filter": {"operator":"is", "field":"title", "value":"Luck"}, "properties": [ "dateadded", "file", "lastplayed","plot", "title", "art", "playcount","streamdetails", "director", "resume", "runtime","plotoutline", "sorttitle", "cast", "votes", "showlink", "top250", "trailer", "year", "country", "studio", "set", "genre", "mpaa", "setid", "rating", "tag", "tagline", "writer", "originaltitle", "imdbnumber" ] } - response: {u'limits': {u'start': 0, u'total': 0, u'end': 0}}
23:57:07 T:2212  NOTICE: Skin Helper Service --> getTMDBimage - TMDB match found for Luck !
23:57:08 T:2212  NOTICE: Skin Helper Service --> get fanart.tv images for type: tv - id: 219381
I use code Window(Home).Property(SkinHelper.PVR.Poster) for dialog,also have for cast in dialog...this is total out.
dbid also down for tvshow..
Code:
00:03:06 T:3084  NOTICE: Skin Helper Service --> getPVRThumb for dbID: 2brokegirlsPROSIEBEN DE
00:03:06 T:3084  NOTICE: Skin Helper Service --> getJson - invalid result for Method PVR.GetRecordings - params: { "properties": [ "art", "channel", "directory", "endtime", "file", "genre", "icon", "playcount", "plot", "plotoutline", "resume", "runtime", "starttime", "streamurl", "title" ]} - response: {u'limits': {u'start': 0, u'total': 0, u'end': 0}}
00:03:06 T:3084  NOTICE: Skin Helper Service --> getJson - invalid result for Method VideoLibrary.GetTvShows - params: { "filter": {"operator":"is", "field":"title", "value":"2 Broke Girls"}, "properties": [ "dateadded", "file", "lastplayed","plot", "title", "art", "playcount","sorttitle", "mpaa", "premiered", "year", "episode", "watchedepisodes", "votes", "rating", "studio", "season", "genre", "cast", "episodeguide", "tag", "originaltitle", "imdbnumber" ] } - response: {u'limits': {u'start': 0, u'total': 0, u'end': 0}}
00:03:06 T:3084  NOTICE: Skin Helper Service --> getJson - invalid result for Method VideoLibrary.GetMovies - params: { "filter": {"operator":"is", "field":"title", "value":"2 Broke Girls"}, "properties": [ "dateadded", "file", "lastplayed","plot", "title", "art", "playcount","streamdetails", "director", "resume", "runtime","plotoutline", "sorttitle", "cast", "votes", "showlink", "top250", "trailer", "year", "country", "studio", "set", "genre", "mpaa", "setid", "rating", "tag", "tagline", "writer", "originaltitle", "imdbnumber" ] } - response: {u'limits': {u'start': 0, u'total': 0, u'end': 0}}
now is Art all emty Sad
Image
before
Image
(2016-03-16, 01:09)Angelinas Wrote: [ -> ]Marcel PVR is out of order....menu things dont working

Did you try to reset the cache already ?
Is it giving issues for widgets only or also in the normal pvr windows ?
(2016-03-16, 00:57)marcelveldt Wrote: [ -> ]Hmmm if the direct path works so should the webservice....

Did you try this ?

http://localhost:52307/getanimatedposter&amp;imdbid=$INFO[Listitem.IMDBNumber]&amp;fallback=$INFO[Listitem.Art(poster)]

You can also try it with a webbrowser. Just leave Kodi open and on the same pc enter the path with some actual values e.g.:

http://localhost:52307/getanimatedposter&imdbid=tt1345836

Hi Marcel,

This worked for me in webbrowser http://localhost:52307/getanimatedposter&imdbid=tt1345836 but like I said only give static without fallback, with fallback I always get poster

Will try the masterprofile later and see what happens
For me, this

http://localhost:52307/getanimatedposter&amp;imdbid=$INFO[Listitem.IMDBNumber]&amp;fallback=$INFO[Listitem.Art(poster)]

only returns a regular poster (also tried it without the fallback), while this

special://masterprofile/Thumbnails/animatedgifs/$INFO[Listitem.IMDBNumber]_poster_0_original.gif

returns the gif when available and an error in the log for each gif that's unavailable.
Hello!
I have some problems that lead to Kodi freeze.

Skin.helper.service is something to do with it because, after the removal of KODI works well and so far without freezing. However I tested several different skins, as well as completely different linux installation. so do you have any

suggestions or information about what to do? P.S. KODI Dev team has seen the log's and did not find anything extraordinary.


http://pastebin.com/LvTJ9yNv

http://pastebin.com/ZCferFfU

http://pastebin.com/NgZ6eJkT

By the way i just installed older version and no crashes yet (1.0.43) + MADNOX RC1
(2016-03-16, 15:22)Mika Kiviniitty Wrote: [ -> ]Hello!
I have some problems that lead to Kodi freeze.

Skin.helper.service is something to do with it because, after the removal of KODI works well and so far without freezing. However I tested several different skins, as well as completely different linux installation. so do you have any

suggestions or information about what to do? P.S. KODI Dev team has seen the log's and did not find anything extraordinary.

http://forum.kodi.tv/showthread.php?tid=264308
(2016-03-16, 01:11)marcelveldt Wrote: [ -> ]
(2016-03-16, 01:09)Angelinas Wrote: [ -> ]Marcel PVR is out of order....menu things dont working

Did you try to reset the cache already ?
Is it giving issues for widgets only or also in the normal pvr windows ?
Yes I clear cache, and delete folder C:\Users\*****\AppData\Roaming\Kodi\userdata\addon_data\script.skin.helper.service\
same .....
PVR ART dont working for DialogPVRGuideInfo.xml when I press "i" in pvr channels or EPG Timeline

I use texture
$INFO[Window(Home).Property(SkinHelper.PVR.Poster)]
$INFO[Window(Home).Property(SkinHelper.PVR.Thumb)]
newest from github ,I dont know is this your try to fix issue but now working like this.
I dont have PVR Art $INFO[Window(Home).Property(SkinHelper.PVR.Poster)]
only have banner http://localhost:52307/getpvrthumb&amp;title=$INFO[Listitem.Title]&amp;type=banner

When I click on context menu
and click "refresh item (Auto Lookup), all back to normal for that channel ,also manual working too.
Image
but for next channel same,dont working till I click on auto or manual.
Something you set to manual for PVR Properties...In setting dont have button to change on auto...

fix that, this info are missing to me ....Smile

Image
Hi,
feature request:
same like "Toggle Kodi Settings"
but for strings and not for booleans. (ie: locale.language - resource.language.en_gb)

Wink