Kodi Community Forum

Full Version: skin helper service
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2016-04-12, 21:11)marcelveldt Wrote: [ -> ]...This will print verbose logging to the kodi log about the lookup process. Can you please share that logging with me ?
The kodi.log with enabled "verbose logging": https://dl.dropboxusercontent.com/u/5293279/kodi.log .
In the musicartcache folder a xml with the name 'Verschiedene Interpreten-Keltica 2' was build.
(2016-04-12, 21:38)AEOne Wrote: [ -> ]The kodi.log with enabled "verbose logging": https://dl.dropboxusercontent.com/u/5293279/kodi.log .
In the musicartcache folder a xml with the name 'Verschiedene Interpreten-Keltica 2' was build.

Sorry, I forgot to mention that Kodi debug logging must NOT be enabled...
(2016-04-12, 21:38)AEOne Wrote: [ -> ]The kodi.log with enabled "verbose logging": https://dl.dropboxusercontent.com/u/5293279/kodi.log .
In the musicartcache folder a xml with the name 'Verschiedene Interpreten-Keltica 2' was build.

Your log is missing the part where the details for Keltica 2 are retrieved, the data was retrieved from the cache.
Did you use the contectmenu --> refresh on that album ?
(2016-04-12, 21:57)marcelveldt Wrote: [ -> ]Sorry, I forgot to mention that Kodi debug logging must NOT be enabled...
Ok - I will "make" a new log-file... Wink

EDIT

You can see the new log-file under the same link...
(2016-04-12, 22:05)marcelveldt Wrote: [ -> ]Your log is missing the part where the details for Keltica 2 are retrieved, the data was retrieved from the cache.
Did you use the contectmenu --> refresh on that album ?
I made a new file.
And yes - I used the context-menu to refresh the artwork for the album.
(2016-04-12, 22:36)AEOne Wrote: [ -> ]I made a new file.
And yes - I used the context-menu to refresh the artwork for the album.

Thanks for the new log, looking at it right now and all seems to be working correctly now except for "verschiedene interpreten - Keltica 2".
Somehow this one gets skipped completely, I guess because "Various Artists" is translated by Kodi into the user interface but not in the database.
I will do a quick fix for that, hold on...
(2016-04-12, 22:36)AEOne Wrote: [ -> ]I made a new file.
And yes - I used the context-menu to refresh the artwork for the album.

Can you please test with this new version ?

http://www.mb3admin.com/downloads/addons...1.0.78.zip
If it helps, I could take a look in the sql-database.
Then I could tell you, if 'Various Artists' or 'Verschiedene Interpreten' are in the database...
What's the best Skin to use with Kodi
(2016-04-12, 23:14)Biggs1 Wrote: [ -> ]What's the best Skin to use with Kodi

The one that suits your personal needs?
(2016-04-12, 23:13)AEOne Wrote: [ -> ]If it helps, I could take a look in the sql-database.
Then I could tell you, if 'Various Artists' or 'Verschiedene Interpreten' are in the database...

Yes, please as I am curious...
Also see the new version I posted above
Ok - one moment...
Ok - with the last version (v1.0.78 - it came also via Repo) we have a half success:
In the album list view the discart is present.
In the titles view of the album itself and during the playback there is no discart.

The boundary conditions are:
1.
In the MP3s there are the same tags for 'artist' and 'album artist' - they are "Various Artist".

2.
In the sql music database there are 3 tables - 'album_artist' and 'artist' and 'song_artist'.
For the "Keltica 2" album I have the following entries:
The album has the idAlbum = 617.
In the 'album_artist' table the matching entry has as idArtist = 133 and as idString = Verschiedene Interpreten. There is also an entry with idArtist = 132 and as idString = Various Artists.
In the 'artist' table the matching entry has as idArtist = 133 and as idString = Verschiedene Interpreten. There is also an entry with idArtist = 132 and as idString = Various Artists.
In the 'song_artist' table there is NO entry with idArtist = 133, only entries with idArtist = 132 and as idString = Various Artists. The number of entries matches to the overall songs of albums with the idArtist 133 AND 132.

3.
I used the context-menu to refresh the artwork for the album.
@AEOne, thanks for the help. Can you share the log again after browsing the non working album and play some songs from it?
(2016-04-13, 00:16)marcelveldt Wrote: [ -> ]@AEOne, thanks for the help. Can you share the log again after browsing the non working album and play some songs from it?
The log-file is updated.
Btw. is it correct that there are no more xml-files in the musicartcache-folder? Shocked Wink