Kodi Community Forum

Full Version: skin helper service
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2016-05-23, 18:19)marcelveldt Wrote: [ -> ]The line you changed will actually break favourites on android machines...
There must be a reason why it didn't work in the first place. Is your favourites.xml file in the correct location ? no path substitution or whatsoever ?
see the diference when I remove from your newest changes..
Code:
if not all_favs:

in
Code:
if all_favs:
widget favourite dont have info (same as Kodi Favourite)
Image
same widget favourite have info and favouritemedia start working with just media movies and tvshow(in my case just 2)
Image

Are you missed this:

-Google for PVR dont working too

*Backgrounds provided by the script
-Window(Home).Property(SkinHelper.PvrBackground) is empty,not working....
-Window(Home).Property(SkinHelper.PicturesBackground) is empty,not working....
(2016-05-23, 18:58)marcelveldt Wrote: [ -> ]
(2016-05-17, 01:32)leejk Wrote: [ -> ]I been having some issues with Kodi making calls to the YouTube addon, but since the addon has been uninstalled, these calls force the constant asking to install the Youtube addon. Originally I thought this was a CinemaVision issue, but discovered that it is this script that is for some reason making the calls to the nonexistent YouTube addon.

Which skin are you using ? Can you check if there is something in your favourites with this path ?

Hi,

I get these requests to YouTube when using the aeon mq6 mod skin. It seems to happen only with that skin. I posted in that forum about it, but I don't think they see it as a problem. I'm not using favorites, so it's empty.
(2016-05-17, 11:50)meowmoo Wrote: [ -> ]when i set the custom path for MusicArt, it would be nice if Skinhelper would save new artwork in the set folder, don't need to be a new option, if the user set the custom path / save artwok in that path.

with this, all MusicArt Addons, CdArt Manager, ArtistSlidshow and Skinhelper would save/use the artwork from the same folder.

the only thing is the Artwork need to be renamed so it match the other 2 Addons

It should already do that if you enable the custom path and disable the local (path based) lookup...
What needs to be renamed ?
(2016-05-18, 21:29)the_bo Wrote: [ -> ]The music videos dont have nfo files so they arent added to the library. Im just browsing the file folder structure when viewing them.
I would like to add a label on home screen showing the total number of music videos.
Is there way for skin helper to count all video files inside the subfolders.

No, because the path isn't known. Most easy way is to just create some nfo files for them.
For convenience use some metadata manager to create them
(2016-05-18, 23:53)meowmoo Wrote: [ -> ]I point skinhelper to my CdArt folder, and for some reasons I get wrong logos/banners
for "The White Stripes" it shows "The Stripes" Art
for "The Killers" it shows "The Kills" Art
in the xml it shows the right path to the logo ...\_cdART\The White Stripes\logo.png
this only happens on my Openelec setup, on the windows setup it works fine

Hmm, the matching was not strict enough. I;ve just adjusted it on Git.
Possible for you to test the latets version ? Use the contextmenu to flush the cache.
(2016-05-23, 10:50)Rubicon99 Wrote: [ -> ]I noticed yesterday that the Revenue amount for The Revenant being pulled from the TMDB API for was way off. It was reporting $167m whereas the TMDB website was was reporting $519m. I thought it may be an issue with the TMDB API database so I posted on their forum but was advised that the Revenue amount for The Revenant was updated from $167m to $519m on 23 April. I deleted the json cache files today and now the correct amount of $519m is being pulled, so looks like it was a persistent cache issue.

You're right. Some info is stored in a persistant cache to prevent overloading API's with too many requests. For example the script already hits the TMDB API with over 2 mln requests a day...

All info that is considered static is stored in the persistant cache (which you can wipe by deleting the files in addon_data). I considered the data from TMDB as static but I forgot about the revenue... The rotten tomatoes details are only stored in the temporary cache, flushed at fresh kodi boot.

I'll play with it a little to see if I can find a proper solution without loosing too much lookup speed or overloading the API.
Maybe ignore the details from the persistant cache for movies younger than 1 year or something ?
(2016-05-23, 19:40)Guilouz Wrote: [ -> ]Here french translation : https://drive.google.com/file/d/0BxrzR2L...sp=sharing

Thanks!
(2016-05-23, 21:10)tomer953 Wrote: [ -> ]but you have a little mistake there, please modify:
resources\lib\MainModule.py lines 638-644
change "value" to "newValue".
b.t.w, I PR'd translation... please consider to merge as well.

Thanks! Fixed the typo on Git.
(2016-05-23, 21:20)Angelinas Wrote: [ -> ]see the diference when I remove from your newest changes..
widget favourite dont have info (same as Kodi Favourite)

-Google for PVR dont working too

*Backgrounds provided by the script
-Window(Home).Property(SkinHelper.PvrBackground) is empty,not working....
-Window(Home).Property(SkinHelper.PicturesBackground) is empty,not working....

1) For some reason your kodi favourites file isn't read. Anyway I added a small workaround as you already figured out.

2) Google PVR images should already be fixed on Git.

3) PvrBackground only returns fanart for recordings, not live TV. Make sure that you have some recordings.

4) PicturesBackground will only work if you have actually set one or more sources in the picture library.
(2016-05-23, 23:11)leejk Wrote: [ -> ]I get these requests to YouTube when using the aeon mq6 mod skin. It seems to happen only with that skin. I posted in that forum about it, but I don't think they see it as a problem. I'm not using favorites, so it's empty.

I think that skin is using this script to get some image from YouTube. I will add a little check in the code if the YouTube addon is present...
Available in a few minutes on Git, asap on the repo.
Hi marcelveldt, please update language and translation for portuguese (Brazil)

http://files.xbmcbrasil.net/Suporte/reso....pt_br.zip

Please remove folder Portuguese (Brazil).

Tip: for others languages rename folder

resource.language.en_gb - for english
resource.language.es_es - for spanish
resource.language.fr_fr - for french
resource.language.he_il - for hebrew.

Thanks
(2016-05-24, 00:12)marcelveldt Wrote: [ -> ]PvrBackground only returns fanart for recordings, not live TV. Make sure that you have some recordings.
Yes but afther you change file https://github.com/marcelveldt/script.sk...46e02c1971
When I rollback one changes before this change PvrBackground showing Fanart from folder pvrthumbs and my PVR have BG.
Now becouse my PVR dont have suport for recording all bg are Black.
Please add new PvrBackgroundChannel to collect images from folder pvrthumbs ,realy missed that BG.
(2016-05-23, 17:28)marcelveldt Wrote: [ -> ]
(2016-05-03, 22:57)tomer953 Wrote: [ -> ]+ do you think of a way to increase\decrease subtitle font in real-time? maybe with the FR above I will reach it, but i'm not sure.
You can try to use that approach for the subtitle font, it may work

I tried,
and
Code:
action=setkodisetting,setting=subtitles.height,value=32
is indeed change the guisettings to the right value, but the problem is in Kodi, which is not refreshing the subtitle in real-time. only stop and replaying the video makes the change.
so I guess the script's can't help with that.. thx anyway.
(2016-05-23, 23:55)marcelveldt Wrote: [ -> ]
(2016-05-18, 23:53)meowmoo Wrote: [ -> ]I point skinhelper to my CdArt folder, and for some reasons I get wrong logos/banners
for "The White Stripes" it shows "The Stripes" Art
for "The Killers" it shows "The Kills" Art
in the xml it shows the right path to the logo ...\_cdART\The White Stripes\logo.png
this only happens on my Openelec setup, on the windows setup it works fine

Hmm, the matching was not strict enough. I;ve just adjusted it on Git.
Possible for you to test the latets version ? Use the contextmenu to flush the cache.

The white stripes /The Stripes is fine now

but i still cached 2 wrong ones,

"The Strokes" shows "The Strypes" Banner but the right logo
"The Killers" still shows "The Kills" Logo but the right banner
(2016-05-23, 23:49)marcelveldt Wrote: [ -> ]
(2016-05-17, 11:50)meowmoo Wrote: [ -> ]when i set the custom path for MusicArt, it would be nice if Skinhelper would save new artwork in the set folder, don't need to be a new option, if the user set the custom path / save artwok in that path.

with this, all MusicArt Addons, CdArt Manager, ArtistSlidshow and Skinhelper would save/use the artwork from the same folder.

the only thing is the Artwork need to be renamed so it match the other 2 Addons

It should already do that if you enable the custom path and disable the local (path based) lookup...
What needs to be renamed ?

If SH already do this, than nothing needs to be renamed :>

but im not sure on the settings, because if i disable the local lookup, SH will not Use the folder.jpg (album Cover) and cdArt.png, witch is stored in the lokal folder with the mp3's