Kodi Community Forum

Full Version: skin helper service
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Player.Art(xxx) is not working for TV-Recordings:
(2018-01-24, 22:28)Guilouz Wrote: [ -> ]But to have artworks with PVR, the only way is to use SHS, but it does not seem to work on player.
2695699 (post)
edit: NM ... today it works.. Big Grin
Receiving an error running 1.1.24 and KODI/Leia for UWP/XBOX version. Below is the log file:

http://ix.io/KEK

May be related to this in the FAQ for the UWP version of KODI, Python _subprocess module is not available on UWP, so an author of the add-on must work around or not use it for UWP.

Similiar issue with Artist Slideshow and pkscout was able to provide a patch to address AS, may be similar issue on the UWP version. I understand the UWP version of KODI is alpha and to expect issues.

Thanks!
Is there any development going on?
(2018-02-25, 12:02)Solo0815 Wrote: [ -> ]Is there any development going on?
I can't speak for Marcel, but I'm still refining a few features in Skin Helper Widgets.  Not enough outward-facing changes at the moment to push an update, but you can expect a new version on the beta repo within a month or so.

You can also check marcelveldt's github if you want to track his activity in his other addons, including the main Skin Helper Service.
(2018-02-16, 02:07)Govnah Wrote: [ -> ]Receiving an error running 1.1.24 and KODI/Leia for UWP/XBOX version. Below is the log file:

http://ix.io/KEK

May be related to this in the FAQ for the UWP version of KODI, Python _subprocess module is not available on UWP, so an author of the add-on must work around or not use it for UWP.

Similiar issue with Artist Slideshow and pkscout was able to provide a patch to address AS, may be similar issue on the UWP version. I understand the UWP version of KODI is alpha and to expect issues.

Thanks!
 The problem with XBOX One version is the cherrypy module. It rises error in python ctypes import. Someone have to fix this.
@Marcel wouldnt it be possible for your add-on to grab no.of metacritic reviews?
I've just started using this script and am running into problems showing rotating fanart for movie sets, the images never show but if I create a label with the same $INFO then it is being populated.

I have added <onload>Skin.SetBool(SkinHelper.EnableExtraFanart)</onload> to my home window and MyVideoNav (not entirely sure how I should use Skin.SetBool - never done so before) and then try to call the fanart using...
Code:
<control type="multiimage">
     <include>FullScreenDimensions</include>
     <aspectratio>scale</aspectratio>
     <fadetime>750</fadetime>
     <animation effect="fade" time="400">VisibleChange</animation>
     <texture background="true">$INFO[Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt)]</texture>
     <visible>Container.Content(Sets)</visible>
</control>

but no luck. As I mentioned if I have a label control with <label>$INFO[Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanart)]</label> then it has a value that looks to be calling the images, e.g.

Image

Is there another step I need to take to make the actual images appear? Maybe a setting I've missed?

Thanks
(2018-03-11, 15:15)Eddage Wrote: [ -> ] 
Code:
<control type="multiimage">
     <include>FullScreenDimensions</include>
     <aspectratio>scale</aspectratio>
     <fadetime>750</fadetime>
     <animation effect="fade" time="400">VisibleChange</animation>
     <texture background="true">$INFO[Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt)]</texture>
     <visible>Container.Content(Sets)</visible>
</control>

Is there another step I need to take to make the actual images appear? Maybe a setting I've missed?

Thanks 
"texture" change in "imagepath"
(2018-03-11, 15:27)Angelinas Wrote: [ -> ]
(2018-03-11, 15:15)Eddage Wrote: [ -> ]
Code:
<control type="multiimage">
     <include>FullScreenDimensions</include>
     <aspectratio>scale</aspectratio>
     <fadetime>750</fadetime>
     <animation effect="fade" time="400">VisibleChange</animation>
     <texture background="true">$INFO[Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt)]</texture>
     <visible>Container.Content(Sets)</visible>
</control>

Is there another step I need to take to make the actual images appear? Maybe a setting I've missed?

Thanks  
"texture" change in "imagepath" 
 I'm an idiot! Rofl Blush

Thanks!
(2018-03-04, 11:17)DimitarCC Wrote: [ -> ]
(2018-02-16, 02:07)Govnah Wrote: [ -> ]Receiving an error running 1.1.24 and KODI/Leia for UWP/XBOX version. Below is the log file:

http://ix.io/KEK

May be related to this in the FAQ for the UWP version of KODI, Python _subprocess module is not available on UWP, so an author of the add-on must work around or not use it for UWP.

Similiar issue with Artist Slideshow and pkscout was able to provide a patch to address AS, may be similar issue on the UWP version. I understand the UWP version of KODI is alpha and to expect issues.

Thanks!
 The problem with XBOX One version is the cherrypy module. It rises error in python ctypes import. Someone have to fix this.

 Image
Getting an error on Android...

Log file

Any ideas?
is there any plan to add trakt rating for movies and tv shows, and rottentomatos for tv show and episode?
Hello

I have a little problem with the webservice.

When i add
Quote: <texture background="true">http://localhost:52307/getthumb&title=$INFO[Listitem.Title]&channel=$INFO[ListItem.ChannelName]</texture>
i saw the poster-image. (all ok)

But when i add
Quote:<texture background="true">http://localhost:52307/getthumb&title=$INFO[Listitem.Title]&channel=$INFO[ListItem.ChannelName]&type=Banner</texture>
i saw always the same image (Poster - no Banner)

Do im something wrongHuh

MfG
FatFred