Kodi Community Forum

Full Version: skin helper service
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2021-03-24, 21:53)Angelinas Wrote: [ -> ]
(2021-03-24, 08:35)Chillbo Wrote: [ -> ]@Angelinas, hoping for a release of the missing dependencies to the Kodi repo soon! Great work and thank you Blush
I hope too .....Smile

Just finished upload on Marcel repo and user who have his repo installed will have full update of module and script.
https://github.com/kodi-community-addons...arcelveldt

User now can use Kodi repository for beta versions of SHS addons
Install version (old),
https://github.com/kodi-community-addons...-1.0.1.zip
Image
@Angelinas , great work, thank you so much! Smile

Regards,

Bart
(2021-03-24, 08:35)Chillbo Wrote: [ -> ]
(2021-03-22, 19:31)bsoriano Wrote: [ -> ]For right now, could you please provide again the link to the post where you mentioned the order in which the addons and modules need to be installed in Matrix?

Here you go, @bsoriano: https://forum.kodi.tv/showthread.php?tid...pid3020831

@Angelinas, hoping for a release of the missing dependencies to the Kodi repo soon! Great work and thank you Blush
@Chillbo , thanks! Smile

Regards,

Bart
(2021-03-24, 21:53)Angelinas Wrote: [ -> ]
(2021-03-24, 08:35)Chillbo Wrote: [ -> ]@Angelinas, hoping for a release of the missing dependencies to the Kodi repo soon! Great work and thank you Blush
I hope too .....Smile

Just finished upload on Marcel repo and user who have his repo installed will have full update of module and script.
https://github.com/kodi-community-addons...arcelveldt

User now can use Kodi repository for beta versions of SHS addons
Install version (old),
https://github.com/kodi-community-addons...-1.0.1.zip
Image

It cant be updated nor installed on kodi 18.9... It gives a dependency error of python 3.0.0 is missing or something...
(2021-03-25, 03:15)Converted Wrote: [ -> ]
(2021-03-24, 21:53)Angelinas Wrote: [ -> ]
(2021-03-24, 08:35)Chillbo Wrote: [ -> ]@Angelinas, hoping for a release of the missing dependencies to the Kodi repo soon! Great work and thank you Blush
I hope too .....Smile

Just finished upload on Marcel repo and user who have his repo installed will have full update of module and script.
https://github.com/kodi-community-addons...arcelveldt

User now can use Kodi repository for beta versions of SHS addons
Install version (old),
https://github.com/kodi-community-addons...-1.0.1.zip
Image

It cant be updated nor installed on kodi 18.9... It gives a dependency error of python 3.0.0 is missing or something...


Thats because the fixes and changes are for Kodi 19

Python 3 is kodi 19
Python 2 is kodi 18
(2021-03-10, 00:08)Angelinas Wrote: [ -> ]
(2021-03-09, 10:35)christofdarkan Wrote: [ -> ]Hi @marcelveldt 
I use Aeon Mq Skin 8 Matrix Mod by Latt's on Nvidia Shield.
latts9923 tell me to write in this thread and report the log.
I report you the error i receive, form Skin Helper Service and from TvShow Next Aired.
Hope can help to find a future solution.

How to reproduce:
For TvShow is random, i enter on series menu and sometimes give me the error.
For SkinHelper is random, i select information menu from a series, sometimes error and the info is empty, or no error and all the information.

Thanks

https://paste.kodi.tv/korotahudu.kodi
That isn't SHS isue, try to test this version of script.module.arrow....I just include changes from Authors github (systemcatch)
https://github.com/arrow-py/arrow

I tested and no more annoying message "ERROR - script.skin.helper.service", keep testing for log "AttributeError: 'bytes' object has no attribute 'tzinfo'"
https://mega.nz/file/XVgXAYYZ#PyTK4RpHMF...G4AUmjHna8

Edit....
script.tv.show.next.aired...now is down...grrrrrrr
So I'm using your files for my skin titan bingie mod, and I'm having issues with skin backup. It installs correctly but does nothing when trying to restore from backup. Do I just need to send you my Kodi log.
(2021-03-25, 14:48)spl147 Wrote: [ -> ]
(2021-03-25, 03:15)Converted Wrote: [ -> ]
(2021-03-24, 21:53)Angelinas Wrote: [ -> ]I hope too .....Smile

Just finished upload on Marcel repo and user who have his repo installed will have full update of module and script.
https://github.com/kodi-community-addons...arcelveldt

User now can use Kodi repository for beta versions of SHS addons
Install version (old),
https://github.com/kodi-community-addons...-1.0.1.zip
Image

It cant be updated nor installed on kodi 18.9... It gives a dependency error of python 3.0.0 is missing or something...


Thats because the fixes and changes are for Kodi 19

Python 3 is kodi 19
Python 2 is kodi 18

but the repo is set up a way that it doesnt differ between kodi versions.
therefore kodi try to update py3 version anyway snd gives the error.

i am also still on leia and used the updated versions (i think from sualfred) which had worked perfectly (backup,colorpicker) .
now i get update notifications and install will fail, because of the dependencie.

best will be reorganice the repo...

EDIT:

e.g.:

reporoot/leiaaddons/*all addons supposed for leia* + *belonging addon.xml*

<?xml version='1.0' encoding='UTF-8'?>
<addons>
<addon id="script.module.metadatautils"
       name="Metadata and Artwork module"
       version="1.0.38"
       provider-name="marcelveldt and others">
   <requires>
        <import addon="xbmc.python" version="2.13.0"/>
        <import addon="xbmc.addon" version="12.0.0"/>
         ...
    </requires>
   ....
</addon><addon id="script.skin.helper.service" name="Skin Helper Service" provider-name="marcelveldt" version="1.1.33">
    <requires>
     <import addon="xbmc.python" version="2.13.0"/>
        <import addon="xbmc.addon" version="12.0.0"/>
    </requires>
          ...
    </requires>
    .....
</addon>
...
</addons>

reporoot/matrixaddons/*all addons supposed for matrix* + *belonging addon.xml*

[syntax=xml]
<?xml version='1.0' encoding='UTF-8'?>
<addons>
<addon id="script.module.metadatautils"
       name="Metadata and Artwork module"
       version="1.0.38"
       provider-name="marcelveldt and others">
    <requires>
        <import addon="xbmc.python" version="3.0.0"/>
        <import addon="script.module.requests" version="2.9.1"/>
          ....
    </requires>
   ....
</addon><addon id="script.skin.helper.service" name="Skin Helper Service" provider-name="marcelveldt" version="1.1.33">
    <requires>
        <import addon="xbmc.python" version="3.0.0"/>
        <import addon="xbmc.addon" version="12.0.0"/>
         ....
    </requires>
    .....
</addon>
...
</addons>

reporoot/REPOSITORY/*all addons supposed for matrix* + *belonging addon.xml*

so that 'REPOSITORY/addon.xml'  can follow up this rooting
 

[syntax=xml]
<?xml version='1.0' encoding='UTF-8'?>
<addons>
<addon id="repository.marcelveldt" version="1.0.3" name="Marcelveldt's BETA repository" provider-name="marcelveldt, finkleandeinhorn">
        <extension name="Marcelveldt's BETA repository" point="xbmc.addon.repository">
            <dir>
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/</datadir>
            </dir>
            <dir minversion="18.9.0">
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/</datadir>
            </dir>
            <dir minversion="17.9.0">
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/</datadir>
            </dir>
        </extension>
    </addon>
</addons>
(2021-03-25, 16:42)mardukL Wrote: [ -> ]reporoot/REPOSITORY/*all addons supposed for matrix* + *belonging addon.xml*

so that 'REPOSITORY/addon.xml'  can follow up this rooting
 

[syntax=xml]
<?xml version='1.0' encoding='UTF-8'?>
<addons>
<addon id="repository.marcelveldt" version="1.0.3" name="Marcelveldt's BETA repository" provider-name="marcelveldt, finkleandeinhorn">
        <extension name="Marcelveldt's BETA repository" point="xbmc.addon.repository">
            <dir>
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/</datadir>
            </dir>
            <dir minversion="18.9.0">
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/</datadir>
            </dir>
            <dir maxversion="17.9.0">
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/</datadir>
            </dir>
        </extension>
    </addon>
</addons>
This mean that I need create new Branches for all version.....thats hard work....good idea but I stay only on Master
Just disable repository.marcelveldt  if you on Matrix > your version.

All repo is now only for Matrix (official version)

I didn't hit  (backup,colorpicker) ?!Huh....
https://github.com/kodi-community-addons...olorpicker
I realy don't know how you can update sualfred newest version with old Marcel, and how you have isue with update notice.
(2021-03-25, 16:01)AchillesPunks Wrote: [ -> ]So I'm using your files for my skin titan bingie mod, and I'm having issues with skin backup. It installs correctly but does nothing when trying to restore from backup. Do I just need to send you my Kodi log.
I explain how script work with skinshortcuts....Tested with your Skin and in that time was working ok.
Read this
https://github.com/kodi-community-addons.../issues/14
(2021-03-25, 17:56)Angelinas Wrote: [ -> ]This mean that I need create new Branches for all version.....thats hard work....good idea but I stay only on Master
Just disable repository.marcelveldt if you on Matrix > your version.
If you drop backward support no.
There is just need to do move the packed zip /md files and create the addon xml files for the install and version detection via Repo.
And if you use batch script to create new zip packes, you'll just have to redefine the target path.

SO THIS
https://github.com/kodi-community-addons...arcelveldt

is the only branch which need restructuring with suggested method.

Sorry for my bad english.

Here is an example how i and others did.
https://github.com/marduklev/repository.marduk



If i found time later i will do a pr.

(2021-03-25, 17:56)Angelinas Wrote: [ -> ]All repo is now only for Matrix (official version)
That made things easier.
But with the suggested method some addons which arent a problem for leia can still have easy acces. Which is currently not possible due to missing version check and python dependencie.


(2021-03-25, 17:56)Angelinas Wrote: [ -> ]I realy don't know how you can update sualfred newest version with old Marcel, and how you have isue with update notice.
he didn't bump the version number on his version number, so i had just install colorpicker,skin.backup within kodi from his repo instead marcelveldt repo.
i dint need to update for leia, its a very minor issue.
(2021-03-25, 17:56)Angelinas Wrote: [ -> ]
(2021-03-25, 16:42)mardukL Wrote: [ -> ]reporoot/REPOSITORY/*all addons supposed for matrix* + *belonging addon.xml*

so that 'REPOSITORY/addon.xml'  can follow up this rooting
 

[syntax=xml]
<?xml version='1.0' encoding='UTF-8'?>
<addons>
<addon id="repository.marcelveldt" version="1.0.3" name="Marcelveldt's BETA repository" provider-name="marcelveldt, finkleandeinhorn">
        <extension name="Marcelveldt's BETA repository" point="xbmc.addon.repository">
            <dir>
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repositories/</datadir>
            </dir>
            <dir minversion="18.9.0">
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/matrix/</datadir>
            </dir>
            <dir maxversion="17.9.0">
                <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/addons.xml</info>
                <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/addons.xml.md5</checksum>
                <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/leia/</datadir>
            </dir>
        </extension>
    </addon>
</addons>
This mean that I need create new Branches for all version.....thats hard work....good idea but I stay only on Master
Just disable repository.marcelveldt  if you on Matrix > your version.

All repo is now only for Matrix (official version)

I didn't hit  (backup,colorpicker) ?!Huh....
https://github.com/kodi-community-addons...olorpicker
I realy don't know how you can update sualfred newest version with old Marcel, and how you have isue with update notice.
(2021-03-25, 16:01)AchillesPunks Wrote: [ -> ]So I'm using your files for my skin titan bingie mod, and I'm having issues with skin backup. It installs correctly but does nothing when trying to restore from backup. Do I just need to send you my Kodi log.
I explain how script work with skinshortcuts....Tested with your Skin and in that time was working ok.
Read this
https://github.com/kodi-community-addons.../issues/14
That's what I needed thanks. I guess I was using the old one
(2021-03-25, 20:05)mardukL Wrote: [ -> ]
(2021-03-25, 17:56)Angelinas Wrote: [ -> ]This mean that I need create new Branches for all version.....thats hard work....good idea but I stay only on Master
Just disable repository.marcelveldt if you on Matrix > your version.
If you drop backward support no.
There is just need to do move the packed zip /md files and create the addon xml files for the install and version detection via Repo.
And if you use batch script to create new zip packes, you'll just have to redefine the target path.

SO THIS
https://github.com/kodi-community-addons...arcelveldt

is the only branch which need restructuring with suggested method.

Sorry for my bad english.

Here is an example how i and others did.
https://github.com/marduklev/repository.marduk



If i found time later i will do a pr.

(2021-03-25, 17:56)Angelinas Wrote: [ -> ]All repo is now only for Matrix (official version)
That made things easier.
But with the suggested method some addons which arent a problem for leia can still have easy acces. Which is currently not possible due to missing version check and python dependencie.


(2021-03-25, 17:56)Angelinas Wrote: [ -> ]I realy don't know how you can update sualfred newest version with old Marcel, and how you have isue with update notice.
he didn't bump the version number on his version number, so i had just install colorpicker,skin.backup within kodi from his repo instead marcelveldt repo.
i dint need to update for leia, its a very minor issue.
Whenever you have time do you think maybe you could give me a hand on creating a repository for my skin? I have always been using cartmans, to get mine to install but would like to create my own with matrix. I have everything on the Github.
@Angelinas Thanks for keeping the helpers active, I have been using Titan Skin from the day it was commissioned by Marcel  where every dependencies addons works out of the box once you download the Marcel repo. That said with recent migration Kodi py2 to py3 addons started  breaking and several efforts have been in motion to make some of them works. Moving from Leia to Matrix caused Titan skin did not fuction properly in some arears, I as did a research into the cause, I got assistance from the developer of Emby addon, I was advised to change few scripts as below, thereafter those issues where resolved.
Appreciate if you can incorporate these changes in the helper addon so emby addon will continue to work out of the box, let me know when those changes are made so I can test.


Thanks

 Those files needs patches: "plugin.video.emby" to "plugin.video.emby-next-gen"  I hope thiese changes once made will make the helper work out of the box.

.kodi/addons/script.skin.helper.backgrounds/resources/lib/smartshortcuts.py

.kodi/addons/script.skin.helper.backgrounds/resources/lib/backgrounds_updater.py

.kodi/addons/script.skin.helper.widgets/resources/lib/favourites.py

.kodi/addons/script.module.metadatautils/lib/helpers/extrafanart.py
(2021-03-25, 20:05)mardukL Wrote: [ -> ]If you drop backward support no.
There is just need to do move the packed zip /md files and create the addon xml files for the install and version detection via Repo.
And if you use batch script to create new zip packes, you'll just have to redefine the target path.

SO THIS
https://github.com/kodi-community-addons...arcelveldt

is the only branch which need restructuring with suggested method.

Sorry for my bad english.

Here is an example how i and others did.
https://github.com/marduklev/repository.marduk

If i found time later i will do a pr.

More like that solution, then creating new branches.
if that migration work, that will be a simple for mine later repo update.
 
(2021-03-25, 20:28)t123thomas Wrote: [ -> ]Those files needs patches: "plugin.video.emby" to "plugin.video.emby-next-gen"  I hope thiese changes once made will make the helper work out of the box.
If I understand Addon Emby have new id, i will change name in file path
https://github.com/search?q=org%3Akodi-c...&type=code
(2021-03-25, 20:33)Angelinas Wrote: [ -> ]
(2021-03-25, 20:05)mardukL Wrote: [ -> ]If you drop backward support no.
There is just need to do move the packed zip /md files and create the addon xml files for the install and version detection via Repo.
And if you use batch script to create new zip packes, you'll just have to redefine the target path.

SO THIS
https://github.com/kodi-community-addons...arcelveldt

is the only branch which need restructuring with suggested method.

Sorry for my bad english.

Here is an example how i and others did.
https://github.com/marduklev/repository.marduk

If i found time later i will do a pr.

More like that solution, then creating new branches.
if that migration work, that will be a simple for mine later repo update.
 
(2021-03-25, 20:28)t123thomas Wrote: [ -> ]Those files needs patches: "plugin.video.emby" to "plugin.video.emby-next-gen"  I hope thiese changes once made will make the helper work out of the box.
If I understand Addon Emby have new id, i will change name in file path
https://github.com/search?q=org%3Akodi-c...&type=code

created pr.

https://github.com/kodi-community-addons...ldt/pull/6

- note the link change if install repo from zip if testing
(2021-03-27, 03:45)mardukL Wrote: [ -> ]
(2021-03-25, 20:33)Angelinas Wrote: [ -> ]
(2021-03-25, 20:05)mardukL Wrote: [ -> ] 
created pr.

https://github.com/kodi-community-addons...ldt/pull/6

- note the link change if install repo from zip if testing

hello mardukl

Just wanted to test the new repo version 1.0.3.
I have found 3 small mistakes.

Replace  "/master/repositories" with "/master/repository" .

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<addon id="repository.marcelveldt" version="1.0.3" name="Marcelveldt's BETA repository" provider-name="marcelveldt, finkleandeinhorn">
    <requires>
        <import addon="xbmc.addon" version="12.0.0"/>
    </requires>
    <extension point="xbmc.addon.repository" name="Marcelveldt's BETA repository">
        <dir>
            <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repository/addons.xml</info>
            <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repository/addons.xml.md5</checksum>
            <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repository/</datadir>
        </dir>

script.skin.helper.widgets-1.0.42.zip is missing in the "matrix" folder and in the addon.xml.
script.skin.helper.widgets-1.0.42 has landed in the "olderversions" folder.

Please update.

Good work with the skin helper repo it is a great relief if everything works automatically again Smile
(2021-03-27, 19:03)Fuchs2468 Wrote: [ -> ]
(2021-03-27, 03:45)mardukL Wrote: [ -> ]
(2021-03-25, 20:33)Angelinas Wrote: [ -> ] 
created pr.

https://github.com/kodi-community-addons...ldt/pull/6

- note the link change if install repo from zip if testing

hello mardukl

Just wanted to test the new repo version 1.0.3.
I have found 3 small mistakes.

Replace  "/master/repositories" with "/master/repository" .

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<addon id="repository.marcelveldt" version="1.0.3" name="Marcelveldt's BETA repository" provider-name="marcelveldt, finkleandeinhorn">
    <requires>
        <import addon="xbmc.addon" version="12.0.0"/>
    </requires>
    <extension point="xbmc.addon.repository" name="Marcelveldt's BETA repository">
        <dir>
            <info compressed="false">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repository/addons.xml</info>
            <checksum>https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repository/addons.xml.md5</checksum>
            <datadir zip="true">https://raw.githubusercontent.com/kodi-community-addons/repository.marcelveldt/master/repository/</datadir>
        </dir>

script.skin.helper.widgets-1.0.42.zip is missing in the "matrix" folder and in the addon.xml.
script.skin.helper.widgets-1.0.42 has landed in the "olderversions" folder.

Please update.

Good work with the skin helper repo it is a great relief if everything works automatically again Smile

wooo, s**t, thanks.
fixed.

https://github.com/kodi-community-addons...ldt/pull/7