Kodi Community Forum

Full Version: skin helper service
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2015-10-28, 00:11)marcelveldt Wrote: [ -> ]
(2015-10-28, 00:10)Lunatixz Wrote: [ -> ]I use a custom overlay window....

Window.IsActive(script.pseudotv.TVOverlay.xml) + Window.IsActive(script.pseudotv.live.TVOverlay.xml)

Aha! That explains it... Let me add a few checks for that and I will have a new version for you to test within 30 mins.

Thanks, really appreciate it.... This helper is incredible.
(2015-10-28, 00:13)Lunatixz Wrote: [ -> ]Thanks, really appreciate it.... This helper is incredible.

Can you please check with latest Git ?
(2015-10-28, 00:33)marcelveldt Wrote: [ -> ]
(2015-10-28, 00:13)Lunatixz Wrote: [ -> ]Thanks, really appreciate it.... This helper is incredible.

Can you please check with latest Git ?

Perfect... Looks like its fixed.

Thanks again
(2015-10-28, 01:31)Lunatixz Wrote: [ -> ]Perfect... Looks like its fixed.

Thanks again

Great! Thanks to you too
Y.A.F.R. Yet Another Feature Request...

Is it possible to have different settings for radio?

I have a issue with radio images being scraped with current pvr settings "Directory Structure For Cache Folder = ProgramTitle" it works great for pvr but the issue with fm radio is that it doesn't have any information so the artwork goes to folder "No information available" for all channels but if I change the setting to channelname all is good. But not good for pvr now.

So are we able to have 1 setting for pvr and 1 setting for radio?

Edit.1

I just had a thought and yes it hurt a little. Maybe the easier solution having it see the title as "No information available" to ignore title and use channel name instead and same if title is empty or blank.

Edit.2

Can we have a option to limit extrafanart aswell please

Edit.3

With the other request about mpaa could there be a option to set it in the pvrdetails.xml

Edit.4

Can we use the <plot> in pvrdetails.xml? I couldn't find anything in the readme
(2015-10-26, 17:03)marcelveldt Wrote: [ -> ]
(2015-10-26, 16:36)Dumyat Wrote: [ -> ]So I upgraded to the latest github and can now add new/overwright existing images ok, but I am seeing some other odd behaviour since upgrading. Everytime I open Kodi and go to the pvr epg, I don't get any artwork showing. However, if I go to addons, open the configure screen on your script and press okay, then go back to the pvr epg, all the artwork is showing immediately.
It might be (but I haven't tested it) that it will only start working when you browse the epg. Did you try to move to the next title to see if it pulls the artwork ? If not, please look in your kodi logfile, might be some clue in there...

(2015-10-26, 16:36)Dumyat Wrote: [ -> ]Also, I'm not getting poster artwork showing up for every programme that has been downloaded when using it with the DialogFullScreenInfo.xml file. What's strange is I get poster artwork for some shows, but not for others for some reason. This is the code, I'm using, which worked fine on the previous version of your script that I was using:-
PHP Code:
<texture fallback="new_pvr/blue/fallback/fallback_tvposter.png">http://localhost:8888/getthumb&title=$INFO[VideoPlayer.Title]&amp;channel=$INFO[VideoPlayer.Channel]&amp;type=poster</texture> 

Is there anything I need to change on this code?

Please change the port to 52307, so localhost:52307 instead of localhost:8888. I had to change the port to something that really shouldn't be in use on the system.
Hi Marcel.....
Hate to say it, but I'm still getting this same issue. I've been tinkering with two the different versions (0.0.37 and 0.0.47) of your script for the past couple of days, to see if I could understand what might be causing this to happen in version 0.0.47, but I have to admit, I'm pretty stumped.

What I don't really understand is the code I've used in the 'MyPVRGuide.xml' file works flawlessly for version 0.0.37 and I get the landscape artwork appearing instantly everytime I enter the epg, but for some reason in version 0.0.47, artwork doesn't appear until I go through the above process.
I even removed the original artwork files that had been captured by version 0.0.37, when using 0.0.47 to see if that was problem. But even when the script started building new artwork files with 0.0.47 I'm still getting the same issue. Sad
The only thing I have changed between the two versions is disabling the background wall image and music artwork features in 0.0.47. Like I say, I'm pretty stumped now. As a final shot in the dark, I assume there has been no difference in the code I need to use to catch the landscape images in 0.0.47?
This is the code I'm using in 0.0.37, which works perfectly everytime:-
PHP Code:
<control type="image">
                <
posx>1235</posx>
                <
posy>-7</posy>
                <
width>735</width>
                <
height>230</height>
                <
aspectratio align="center" aligny="center">keep</aspectratio>
                <
texture>$INFO[Window(Home).Property(SkinHelper.PVR.landscape)]</texture>
                </
control

I think this script is absolutely amazing and for that reason, I don't want to get left behind using a version that isn't current.
Any thoughts and feedback would be really appreciated
Thanks
(2015-10-28, 14:24)Dumyat Wrote: [ -> ]I think this script is absolutely amazing and for that reason, I don't want to get left behind using a version that isn't current.
Any thoughts and feedback would be really appreciated
Thanks

You did enable the pvr thumbs feature in your skin ?

Skin.SetBool(SkinHelper.EnablePVRThumbs)
(2015-10-28, 07:09)Rjsachse Wrote: [ -> ]Y.A.F.R. Yet Another Feature Request...

Is it possible to have different settings for radio?

I have a issue with radio images being scraped with current pvr settings "Directory Structure For Cache Folder = ProgramTitle" it works great for pvr but the issue with fm radio is that it doesn't have any information so the artwork goes to folder "No information available" for all channels but if I change the setting to channelname all is good. But not good for pvr now.

So are we able to have 1 setting for pvr and 1 setting for radio?

Edit.1

I just had a thought and yes it hurt a little. Maybe the easier solution having it see the title as "No information available" to ignore title and use channel name instead and same if title is empty or blank.

Edit.2

Can we have a option to limit extrafanart aswell please

Edit.3

With the other request about mpaa could there be a option to set it in the pvrdetails.xml

Edit.4

Can we use the <plot> in pvrdetails.xml? I couldn't find anything in the readme

1) I haven't implemented support for FM radio... I see no way of doing that correctly ? What info is there to provide for just the channel without having any program info ? The channel icon ?
For playing radio however I did add the support. If the channel provides artist/song info the artwork and info will be pulled.

2) Extrafanart limit will be added. What would be a good amount ? 5 or something like that ?

3) You can enter any value in the pvrdetails.xml and that will be available as window prop... If you type <mpaa>NL-6</mpaa> than the window property SkinHelper.PVR.mpaa will be filled for you.The same for the plot.

About that mpaa detection from the plot.. that sounds really tricky to me. Different guide services, languages etc. Also the guide providers are not known to be very accurate/consistent with their info. That will be a hell to code, maintain. What I can do is use the details from TMDB for any title found.
(2015-10-28, 01:38)marcelveldt Wrote: [ -> ]
(2015-10-28, 01:31)Lunatixz Wrote: [ -> ]Perfect... Looks like its fixed.

Thanks again

Great! Thanks to you too

awesome work guys! This is what the community is all about! cheers!
(2015-10-28, 14:34)marcelveldt Wrote: [ -> ]
(2015-10-28, 14:24)Dumyat Wrote: [ -> ]I think this script is absolutely amazing and for that reason, I don't want to get left behind using a version that isn't current.
Any thoughts and feedback would be really appreciated
Thanks

You did enable the pvr thumbs feature in your skin ?

Skin.SetBool(SkinHelper.EnablePVRThumbs)

Yes, confirm pvrthumbs feature enabled
What's also strange is artwork for other pvr screens (recordings/tv channel list/fullscreeninfo) all work as expected using version 0.0.47. So, it's only the epg screen that appears to be causing me an issue.....
(2015-10-28, 15:22)Dumyat Wrote: [ -> ]Yes, confirm pvrthumbs feature enabled
What's also strange is artwork for other pvr screens (recordings/tv channel list/fullscreeninfo) all work as expected using version 0.0.47. So, it's only the epg screen that appears to be causing me an issue.....

Issue reproduced. I will look for the fix
(2015-10-28, 19:22)marcelveldt Wrote: [ -> ]
(2015-10-28, 15:22)Dumyat Wrote: [ -> ]Yes, confirm pvrthumbs feature enabled
What's also strange is artwork for other pvr screens (recordings/tv channel list/fullscreeninfo) all work as expected using version 0.0.47. So, it's only the epg screen that appears to be causing me an issue.....

Issue reproduced. I will look for the fix
I have that version 0.0.47 and dont have problem with images.
I do Test and this is resultat....After install script,restart kodi and all working in all window for PVR
All nine (9) images are present in EPG Window.
Image

@Marcel Have you planed to add "info for Cast" in PVR.(from IMDB or TMDB) as Label.Latter some thumb for them. Smile
PHP Code:
$INFO[Window(Home).Property(SkinHelper.PVR.Cast)]
$INFO[Window(Home).Property(SkinHelper.PVR.Role)] 

(2015-10-28, 20:22)marcelveldt Wrote: [ -> ]First release to the Kodi repo, after that I will look into adding more features
This expects all authors of Kodi skins, just go ahead...Great news ! Thanks to you
(2015-10-28, 20:20)Angelinas Wrote: [ -> ]@Marcel Have you planed to add "info for Cast" in PVR.(from IMDB or TMDB) as Label.Latter some thumb for them. Smile
PHP Code:
$INFO[Window(Home).Property(SkinHelper.PVR.Cast)]
$INFO[Window(Home).Property(SkinHelper.PVR.Role)] 

First release to the Kodi repo, after that I will look into adding more features
(2015-10-28, 15:22)Dumyat Wrote: [ -> ]Yes, confirm pvrthumbs feature enabled
What's also strange is artwork for other pvr screens (recordings/tv channel list/fullscreeninfo) all work as expected using version 0.0.47. So, it's only the epg screen that appears to be causing me an issue.....

Please check latest Git. It should now be fixed
(2015-10-28, 20:48)marcelveldt Wrote: [ -> ]
(2015-10-28, 15:22)Dumyat Wrote: [ -> ]Yes, confirm pvrthumbs feature enabled
What's also strange is artwork for other pvr screens (recordings/tv channel list/fullscreeninfo) all work as expected using version 0.0.47. So, it's only the epg screen that appears to be causing me an issue.....

Please check latest Git. It should now be fixed

That's great Marcel.....thanks Smile
I will check it out and revert back.....